D13106: Add RTL support to some QtQuick ported KCMs

2018-06-29 Thread David Edmundson
davidedmundson abandoned this revision. davidedmundson added a comment. I'm starting to think you're right about putting it at a higher level. I'm not sure how viable it is. REPOSITORY R119 Plasma Desktop REVISION DETAIL https://phabricator.kde.org/D13106 To: davidedmundson,

D13745: Implement support for virtual desktops on Wayland

2018-06-29 Thread Eike Hein
hein updated this revision to Diff 36903. hein added a comment. Adjust to new semantics for IsOnAllDesktops. REPOSITORY R120 Plasma Workspace CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D13745?vs=36857=36903 BRANCH master REVISION DETAIL https://phabricator.kde.org/D13745

D13717: Implement Seek() and Seeked()

2018-06-29 Thread Adam Mokhtari
mokhtari marked 3 inline comments as done. mokhtari added inline comments. INLINE COMMENTS > broulik wrote in content-script.js:177 > Please avoid negating a longer statement, this makes the code hard to > understand at a glance: > > if (activePlayer.seekable.length === 0) Good point.

D13717: Implement Seek() and Seeked()

2018-06-29 Thread Adam Mokhtari
mokhtari updated this revision to Diff 36902. mokhtari added a comment. Clean things up a bit: - use signal auto-relaying to clean up mprisplugin logic - use more readable test in content-script.js REPOSITORY R856 Plasma Browser Integration CHANGES SINCE LAST UPDATE

D10297: Add new "Tools" button above System Monitor's process list

2018-06-29 Thread gregormi
gregormi added a comment. In D10297#272726 , @rkflx wrote: > Awesome, I did not expect that the fix for the shortcuts would be so simple. Thanks for your patience, we are nearly there… INLINE COMMENTS > rkflx wrote in

D10297: Add new "Tools" button above System Monitor's process list

2018-06-29 Thread gregormi
gregormi updated this revision to Diff 36895. gregormi marked an inline comment as done. gregormi edited the summary of this revision. gregormi added a comment. - info comment - Remove the now useless "not set" string - Set shortcut text with Qt methods and omit the translation context

D7087: Add "Copy Info" button to the About System KCM

2018-06-29 Thread gregormi
gregormi marked 6 inline comments as done. gregormi added inline comments. INLINE COMMENTS > rkflx wrote in Module.cpp:260 > Maybe you could avoid this special case if you added a hidden label in > `loadSoftware`? > > Also, "label in … the button" sounds a bit odd. Perhaps "label" would be >

D7087: Add "Copy Info" button to the About System KCM

2018-06-29 Thread gregormi
gregormi updated this revision to Diff 36893. gregormi added a comment. - Rework the Module.ui layout to fix the spacing - Add dummy label to remove special case for "Distro" - Use C++11 for loop and add qAsConst - Make RTL aware by not removing the colon - Improve translation context

D7087: Add "Copy Info" button to the About System KCM

2018-06-29 Thread gregormi
gregormi added a comment. I added some qDebug code in Module::copyToClipboard() and noticed that the method is always called twice when the Copy to clipboard button is clicked. When I remove the line 125 in Module.cpp: connect(ui->pushButtonCopyInfo, ::clicked, this, ::copyToClipboard);

D7087: Add "Copy Info" button to the About System KCM

2018-06-29 Thread gregormi
gregormi added a comment. Thanks Henrik for the review. I fixed the layout and it looks now like this in Qt Designer: F5972316: grafik.png The blue arrow shows a difference to your proposal. Do you think the grid layout there is ok? I push an

D13745: Implement support for virtual desktops on Wayland

2018-06-29 Thread Marco Martin
mart added inline comments. INLINE COMMENTS > waylandtasksmodel.cpp:458 > +return (window->plasmaVirtualDesktops().isEmpty() > +|| d->virtualDesktopInfo->numberOfDesktops() == > window->plasmaVirtualDesktops().count()); > } else if (role == Geometry) { note that the

PSA: Phabricator staging repositories

2018-06-29 Thread Bhushan Shah
Hello developers, So in last few days I and Ben has been working on setting up the staging repositories for phabricator. More information on this feature is documented as part of Harbormaster documentation [1] change handoff section. To explain further, this will allow the people to push commits

D13772: Add AppStream metadata

2018-06-29 Thread Nathaniel Graham
ngraham added a comment. Are folks satisfied with this now? REPOSITORY R106 KSysguard REVISION DETAIL https://phabricator.kde.org/D13772 To: ngraham, #plasma, apol, mak, pino Cc: pino, mak, plasma-devel, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas,

D13793: [Icons KCM] Load preview pixmaps for animation on-demand and cache them

2018-06-29 Thread David Edmundson
davidedmundson added inline comments. INLINE COMMENTS > main.cpp:484 > { > +const QString cacheKey = themeName + QLatin1Char('@') + > QString::number(size) + QLatin1Char('@') + QString::number(dpr,'f',1) + > QLatin1Char('@') + QString::number(limit); > + so if you request previewIcons

D13793: [Icons KCM] Load preview pixmaps for animation on-demand and cache them

2018-06-29 Thread Kai Uwe Broulik
broulik updated this revision to Diff 36882. broulik added a comment. - Explain why QVariantList REPOSITORY R119 Plasma Desktop CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D13793?vs=36881=36882 REVISION DETAIL https://phabricator.kde.org/D13793 AFFECTED FILES

D13793: [Icons KCM] Load preview pixmaps for animation on-demand and cache them

2018-06-29 Thread Kai Uwe Broulik
broulik updated this revision to Diff 36881. broulik added a comment. - Add comment explaining the number 6 REPOSITORY R119 Plasma Desktop CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D13793?vs=36878=36881 REVISION DETAIL https://phabricator.kde.org/D13793 AFFECTED FILES

D13793: [Icons KCM] Load preview pixmaps for animation on-demand and cache them

2018-06-29 Thread Marco Martin
mart added inline comments. INLINE COMMENTS > main.h:110 > +// ListView deletes and recreates delegates as you scroll, so once we > generated previews, cache them > +QHash*/> m_previewCache; > + leftovers? > main.qml:156 > Qt.callLater(function() { > -

D13793: [Icons KCM] Load preview pixmaps for animation on-demand and cache them

2018-06-29 Thread Kai Uwe Broulik
broulik updated this revision to Diff 36878. broulik retitled this revision from "[Icons KCM] Cache preview pixmaps" to "[Icons KCM] Load preview pixmaps for animation on-demand and cache them". broulik edited the summary of this revision. broulik edited the test plan for this revision.

D13793: [Icons KCM] Cache preview pixmaps

2018-06-29 Thread Kai Uwe Broulik
broulik updated this revision to Diff 36876. broulik added a comment. - Evict cache when installing new theme REPOSITORY R119 Plasma Desktop CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D13793?vs=36875=36876 REVISION DETAIL https://phabricator.kde.org/D13793 AFFECTED FILES

D13793: [Icons KCM] Cache preview pixmaps

2018-06-29 Thread Kai Uwe Broulik
broulik planned changes to this revision. broulik added a comment. TODO evict cache when reloading model (installing new theme) REPOSITORY R119 Plasma Desktop REVISION DETAIL https://phabricator.kde.org/D13793 To: broulik, #plasma Cc: plasma-devel, ragreen, Pitel, ZrenBot, lesliezhai,

D13793: [Icons KCM] Cache preview pixmaps

2018-06-29 Thread Kai Uwe Broulik
broulik created this revision. broulik added a reviewer: Plasma. Restricted Application added a project: Plasma. Restricted Application added a subscriber: plasma-devel. broulik requested review of this revision. REVISION SUMMARY ListView deletes and recreates delegates as you scroll, leading

D6096: Add Wayland RemoteAccess capabilities to KRfb

2018-06-29 Thread Jan Grulich
jgrulich added a comment. One more possible thing to improve, I don't know if there is interest in supporting Gnome, but Gnome creates streams in BGRx format, which means it wouldn't mach your stream, if you want to support it you need to change it to something like : ":",

D13694: Fix wrong availability of profiles and ports.

2018-06-29 Thread David Rosca
This revision was not accepted when it landed; it landed in state "Needs Review". This revision was automatically updated to reflect the committed changes. Closed by commit R115:ba737f478208: Fix wrong availability of profiles and ports. (authored by akrutzler, committed by drosca). REPOSITORY

D13717: Implement Seek() and Seeked()

2018-06-29 Thread Kai Uwe Broulik
broulik added inline comments. INLINE COMMENTS > content-script.js:177 > +if (activePlayer) { > +if (!(activePlayer.seekable.length > 0)) { > +console.warn("Got seek command, but player is not seekable"); Please avoid negating a longer statement, this makes the code hard

D13788: Use Pin/Unpin also for window tasks when there's only one activity

2018-06-29 Thread Kai Uwe Broulik
broulik added inline comments. INLINE COMMENTS > ContextMenu.qml:486 > > -checkable: true > - > -text: i18nc("Toggle action for showing a launcher button while the > application is not running", "") > +text: (isPinned ? i18nc("Action for removing the launcher button >