Re: [pulseaudio-discuss] Transitioning from pa_bool_t to C99 bool

2012-07-05 Thread Arun Raghavan
On Thu, 2012-07-05 at 15:19 +0800, rong deng wrote: 2012/7/2 David Henningsson david.hennings...@canonical.com: I don't think there is any reason to not do s/pa_bool_t/bool/g. Probably the reason for this might be historical, as some compilers may have supported some C99 features but not

Re: [pulseaudio-discuss] Transitioning from pa_bool_t to C99 bool

2012-07-05 Thread rong deng
2012/7/5 Arun Raghavan arun.ragha...@collabora.co.uk: On Thu, 2012-07-05 at 15:19 +0800, rong deng wrote: 2012/7/2 David Henningsson david.hennings...@canonical.com: I don't think there is any reason to not do s/pa_bool_t/bool/g. Probably the reason for this might be historical, as some

Re: [pulseaudio-discuss] Transitioning from pa_bool_t to C99 bool

2012-07-02 Thread David Henningsson
On 06/30/2012 12:36 PM, Tanu Kaskinen wrote: Hi, We handle booleans with these definitions: /* This type is not intended to be used in exported APIs! Use classic int there! */ #ifdef HAVE_STD_BOOL typedef bool pa_bool_t; #else typedef int pa_bool_t; #endif #ifndef FALSE #define FALSE

Re: [pulseaudio-discuss] Transitioning from pa_bool_t to C99 bool

2012-07-02 Thread Rémi Denis-Courmont
On Mon, 02 Jul 2012 08:45:42 +0200, David Henningsson david.hennings...@canonical.com wrote: It might make sense to keep something like #ifndef HAVE_STD_BOOL typedef int bool; I sincerely don't recommend that kind of hacks. int and bool are completely different things. The representation in

Re: [pulseaudio-discuss] Transitioning from pa_bool_t to C99 bool

2012-07-02 Thread David Henningsson
On 07/02/2012 09:26 AM, Rémi Denis-Courmont wrote: On Mon, 02 Jul 2012 08:45:42 +0200, David Henningsson david.hennings...@canonical.com wrote: It might make sense to keep something like #ifndef HAVE_STD_BOOL typedef int bool; I sincerely don't recommend that kind of hacks. int and bool are

[pulseaudio-discuss] Transitioning from pa_bool_t to C99 bool

2012-06-30 Thread Tanu Kaskinen
Hi, We handle booleans with these definitions: /* This type is not intended to be used in exported APIs! Use classic int there! */ #ifdef HAVE_STD_BOOL typedef bool pa_bool_t; #else typedef int pa_bool_t; #endif #ifndef FALSE #define FALSE ((pa_bool_t) 0) #endif #ifndef TRUE #define TRUE