On Wed, Apr 16 2008 at 02:51:53PM BRT, Trent Nelson <[EMAIL PROTECTED]> wrote:
>
> Following on from the success of previous sprint/bugfix weekends and
> sprinting efforts at PyCon 2008, I'd like to propose the next two
> Global Python Sprint Weekends take place on the following dates:
I currently have a patch to make it possible to change py3k warnings
in Python through new functions in sys: issue 2458. I realize the
functions are rather ugly, but I don't think there is another
practical way to do it unless you want to be writing PySys_GetObject
and checking it for NULL whenever
Anybody in Melbourne keen for this? Not sure if I'll be able to make it
myself, but I'd be interested to know if there's anybody in the area
keen to do the sprint.
Cheers,
T
Tarek Ziadé wrote:
> On Wed, Apr 16, 2008 at 8:40 PM, Michael Foord
> <[EMAIL PROTECTED]> wrote:
>
>> Trent Nelson wro
Terry Reedy wrote:
> "Michael Foord" <[EMAIL PROTECTED]> wrote in message
> news:[EMAIL PROTECTED]
> | I think that there is still work I can do on the docs even before any
> | grand renaming...
>
> In a related thread, I proposed and Guido approved that the 2.6/3.0 docs
> be changed to
> 1. speci
Guido van Rossum wrote:
> On Thu, Apr 17, 2008 at 3:31 PM, Jonathan Lange <[EMAIL PROTECTED]> wrote:
>> On Thu, Apr 17, 2008 at 11:49 PM, Michael Foord
>> <[EMAIL PROTECTED]> wrote:
>> > assert_raises_with_message(exc_class, message, callable, *args,
>> > **keywargs)
>> >
>>
>> I don'
On Fri, Apr 18, 2008 at 8:34 AM, Guido van Rossum <[EMAIL PROTECTED]> wrote:
>
> On Thu, Apr 17, 2008 at 3:31 PM, Jonathan Lange <[EMAIL PROTECTED]> wrote:
> > On Thu, Apr 17, 2008 at 11:49 PM, Michael Foord
> > <[EMAIL PROTECTED]> wrote:
> > > assert_raises_with_message(exc_class, mes
On Thu, Apr 17, 2008 at 3:31 PM, Jonathan Lange <[EMAIL PROTECTED]> wrote:
> On Thu, Apr 17, 2008 at 11:49 PM, Michael Foord
> <[EMAIL PROTECTED]> wrote:
> > assert_raises_with_message(exc_class, message, callable, *args,
> > **keywargs)
> >
>
> I don't think this one should go in.
>
On Thu, Apr 17, 2008 at 11:49 PM, Michael Foord
<[EMAIL PROTECTED]> wrote:
> assert_raises_with_message(exc_class, message, callable, *args,
> **keywargs)
>
I don't think this one should go in.
I think it would be better if assertRaises just returned the exception
object that it catches.
On Fri, Apr 18, 2008 at 12:54 AM, Guido van Rossum <[EMAIL PROTECTED]> wrote:
> I'm worried that a mass renaming would do anything but inconvenience
> users during the already stressful 2->3 transition.
>
> I'm more in favor of the original proposal of reducing the redundancy
> post-3.0.
>
> If
On Thu, Apr 17, 2008 at 7:06 PM, Guido van Rossum <[EMAIL PROTECTED]> wrote:
> Sounds like a neat little feature. Looking forward to it. Maybe the
> most useful use case would be to provide glob-style patterns for
> skipping files or directories (and their contents).
Alright I will work on it th
-On [20080417 19:46], Terry Reedy ([EMAIL PROTECTED]) wrote:
>Have you or are you going to make these changes or should I open a separate
>tracker issue?
You can always put it on my account in the tracker (asmodai) and I'll get to
it in the coming days.
--
Jeroen Ruigrok van
"Michael Foord" <[EMAIL PROTECTED]> wrote in message
news:[EMAIL PROTECTED]
| I think that there is still work I can do on the docs even before any
| grand renaming...
In a related thread, I proposed and Guido approved that the 2.6/3.0 docs
be changed to
1. specify that the Fail... names will di
On 17/04/2008, Tarek Ziadé <[EMAIL PROTECTED]> wrote:
>
> Hi,
>
> shutil.copytree is very convenient to make recursive copies, but
> os.walk has to be used everytime some filtering
> has to be done on the files copied., if you want to avoid copying some
> files.
>
> The code pattern with os.walk is
Sounds like a neat little feature. Looking forward to it. Maybe the
most useful use case would be to provide glob-style patterns for
skipping files or directories (and their contents).
--Guido
On Thu, Apr 17, 2008 at 9:52 AM, Tarek Ziadé <[EMAIL PROTECTED]> wrote:
> Hi,
>
> shutil.copytree is ve
On Thu, Apr 17, 2008 at 8:27 AM, Christian Heimes <[EMAIL PROTECTED]> wrote:
> Most of the etc. could be simplified with a function assertOp which
> takes an operator as first argument
>
> import operator
> def assertOp(self, op, a, b, msg):
> func = getattr(operator, op)
> self.assert_
> - copying a source to a target, but the pyc/pyo file
> def filtering(source, target):
> return os.path.splitext(filename) not in ('.pyc', '.pyo')
>
> shutil.copytree(source, target, filter_=filtering)
> -
oups, made a mistake in my example:
def fi
On Thu, Apr 17, 2008 at 7:59 AM, Michael Foord
<[EMAIL PROTECTED]> wrote:
> By etc I assume you mean:
>
>assertLessThan
>assertGreaterThan
>assertLessThanOrEquals
>assertGreaterThanOrEquals
These names are used here:
assertListEqual(self, list1, list2, msg=None):
assertIn(self, a
>> Apropos certificate, I like to suggest a PGP signing party for the
>> next PyCon. :]
Barry> /me smacks his head for not doing one in 2008!
Maybe a bunch of Python local user groups could be coaxed into having
mini-signing parties during upcoming meetings, then let natural
cross-fe
Hi,
shutil.copytree is very convenient to make recursive copies, but
os.walk has to be used everytime some filtering
has to be done on the files copied., if you want to avoid copying some files.
The code pattern with os.walk is pretty talkative :
- copying a source folder to
Michael Foord wrote:
> Guido van Rossum wrote:
>> I'm worried that a mass renaming would do anything but inconvenience
>> users during the already stressful 2->3 transition.
>>
>> I'm more in favor of the original proposal of reducing the redundancy
>> post-3.0.
>>
>>
>
> So nix the PEP-8'if
Jesse Noller wrote:
> On Thu, Apr 17, 2008 at 10:59 AM, Michael Foord
> <[EMAIL PROTECTED]> wrote:
>
>> Guido van Rossum wrote:
>> > I'm worried that a mass renaming would do anything but inconvenience
>> > users during the already stressful 2->3 transition.
>> >
>> > I'm more in favor of th
Christian Heimes wrote:
> Michael Foord schrieb:
>
>> By etc I assume you mean:
>>
>> assertLessThan
>> assertGreaterThan
>> assertLessThanOrEquals
>> assertGreaterThanOrEquals
>>
>> Would not variants be useful as well - it seems not as the not of one is
>> always another... (I
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On Apr 17, 2008, at 11:32 AM, Christian Heimes wrote:
> Barry Warsaw schrieb:
>> MvL is leading this effort and is currently trying to get a code
>> signing certificate (my attempts having utterly failed on the Mac ;).
>> Please coordinate with him.
>
Barry Warsaw schrieb:
> MvL is leading this effort and is currently trying to get a code
> signing certificate (my attempts having utterly failed on the Mac ;).
> Please coordinate with him.
Apropos certificate, I like to suggest a PGP signing party for the next
PyCon. :]
Christian
_
Great that you're taking this on, Michael!
On 17 Apr 2008, at 16:59, Michael Foord wrote:
>> If you're looking for useful features, Google has a set of extensions
>> to unittest.py that I find useful:
>>
>> - module-level setUp and tearDown
>>
> So when a suite is made from a module the setUp sh
Michael Foord schrieb:
> By etc I assume you mean:
>
> assertLessThan
> assertGreaterThan
> assertLessThanOrEquals
> assertGreaterThanOrEquals
>
> Would not variants be useful as well - it seems not as the not of one is
> always another... (I think 'assertLessThan' reads better t
On Thu, Apr 17, 2008 at 10:59 AM, Michael Foord
<[EMAIL PROTECTED]> wrote:
> Guido van Rossum wrote:
> > I'm worried that a mass renaming would do anything but inconvenience
> > users during the already stressful 2->3 transition.
> >
> > I'm more in favor of the original proposal of reducing th
Guido van Rossum wrote:
> I'm worried that a mass renaming would do anything but inconvenience
> users during the already stressful 2->3 transition.
>
> I'm more in favor of the original proposal of reducing the redundancy
> post-3.0.
>
>
So nix the PEP-8'ifying until after 3.0.
So new method
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On Apr 17, 2008, at 10:48 AM, Guido van Rossum wrote:
> This is going to be a major administrative hassle. Obviously you have
> to be extremely cautious with the private part of the certificate, or
> it's worthless. That means that there will probably
I'm worried that a mass renaming would do anything but inconvenience
users during the already stressful 2->3 transition.
I'm more in favor of the original proposal of reducing the redundancy post-3.0.
If you're looking for useful features, Google has a set of extensions
to unittest.py that I find
This is going to be a major administrative hassle. Obviously you have
to be extremely cautious with the private part of the certificate, or
it's worthless. That means that there will probably be only one person
who can sign binaries. That person would have also have to build all
the binaries -- sig
Hello all,
I'm starting to put together a list of cleanups (with documentation
changes) for the unittest module. I thought someone had already done
this but the issue with the most comments I could find was 2578 which
doesn't go into much detail:
http://bugs.python.org/issue2578
The thing mos
On Tue, Apr 15, 2008, Guido van Rossum wrote:
> On Tue, Apr 15, 2008 at 8:34 PM, Greg Ewing <[EMAIL PROTECTED]> wrote:
>> Guido van Rossum wrote:
>>>
>>> That's why I proposed <0, 1, ..., 9> for repr(range(10)).
>>
>> My worry is that this will lead a newcomer into thinking
>> this is some kind o
On Wed, Apr 16, 2008 at 8:40 PM, Michael Foord
<[EMAIL PROTECTED]> wrote:
> Trent Nelson wrote:
> > Following on from the success of previous sprint/bugfix weekends and
> > sprinting efforts at PyCon 2008, I'd like to propose the next two
> > Global Python Sprint Weekends take place
> * Why the binaries should be signed?
Makes the installation process on Windows Vista and Server 2008
a little nicer; instead of getting an "unknown-executable-could-
be-a-virus-aa-watchout"-type dialog with a big red flag,
you get a less threatening message saying that
Trent Nelson schrieb:
> Hi Barry,
>
> Friendly poke to see if there's been any progress on acquiring the relevant
> certificates such that we can code sign binaries on Windows for 2.6/3.0 ;-)
Can you explain:
* Why the binaries should be signed?
* What is required to sign the binaries?
* W
Hi Barry,
Friendly poke to see if there's been any progress on acquiring the relevant
certificates such that we can code sign binaries on Windows for 2.6/3.0 ;-)
Trent.
___
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/ma
37 matches
Mail list logo