Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Nick Coghlan
On 16 Oct 2013 11:42, "R. David Murray" wrote: > > On Wed, 16 Oct 2013 09:24:11 +1000, Nick Coghlan wrote: > > On 16 Oct 2013 01:54, "R. David Murray" wrote: > > > With that change, I'd be +1. With just suppress, I'm -0. > > > > Please, please, please just let it drop. Even though it eventually

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread R. David Murray
On Wed, 16 Oct 2013 09:24:11 +1000, Nick Coghlan wrote: > On 16 Oct 2013 01:54, "R. David Murray" wrote: > > With that change, I'd be +1. With just suppress, I'm -0. > > Please, please, please just let it drop. Even though it eventually > convinced me to change the name, this thread still epito

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Steven D'Aprano
On Wed, Oct 16, 2013 at 09:24:11AM +1000, Nick Coghlan wrote: > Even though it eventually > convinced me to change the name, this thread still epitomises everything > that sucks about soul destroying, energy draining bikeshed painting that > makes me wonder why I ever bother trying to make anythin

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Nick Coghlan
On 16 Oct 2013 01:54, "R. David Murray" wrote: > > On Tue, 15 Oct 2013 22:57:34 +1000, Nick Coghlan wrote: > > On 15 October 2013 22:27, Antoine Pitrou wrote: > > > Le Tue, 15 Oct 2013 22:05:41 +1000, > > > Nick Coghlan a écrit : > > > > > >> On 15 October 2013 13:12, Glenn Linderman > > >> wr

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Ethan Furman
On 10/15/2013 12:59 PM, Tim Delaney wrote: On 16 October 2013 05:17, Alexander Belopolsky mailto:alexander.belopol...@gmail.com>> wrote: On Tue, Oct 15, 2013 at 12:45 PM, Ethan Furman mailto:et...@stoneleaf.us>> wrote: > with trap(OSError) as cm: > os.unlink('missing.txt'

Re: [Python-Dev] Submitting PEP 453 (pip bootstrapping) for pronouncement

2013-10-15 Thread Nick Coghlan
On 14 Oct 2013 08:21, "Nick Coghlan" wrote: > > > On 14 Oct 2013 04:26, "Paul Moore" wrote: > > > > On 13 October 2013 13:43, Nick Coghlan wrote: > > > Accordingly, in addition to adding the option to extract and install ``pip`` > > > during installation, this PEP proposes that the Windows insta

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Greg Ewing
Zero Piraeus wrote: I thought the whole point was to replace code that would otherwise contain 'except: pass' with something slightly more concise. Hmmm, that suggests another potential name. with passing_on(OSError): os.remove(somefile) -- Greg __

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Tim Delaney
On 16 October 2013 05:17, Alexander Belopolsky < alexander.belopol...@gmail.com> wrote: > On Tue, Oct 15, 2013 at 12:45 PM, Ethan Furman wrote: > > with trap(OSError) as cm: > > os.unlink('missing.txt') > > if cm.exc: > > do_something() > > .. and why is this better than >

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread R. David Murray
On Tue, 15 Oct 2013 15:02:15 -0300, Zero Piraeus wrote: > : > > On Tue, Oct 15, 2013 at 09:45:59AM -0700, Ethan Furman wrote: > > [...] if the CM provides the value before, and the with block accepts > > it, it can then have the exception added to it: > > > > with trap(OSError) as cm: > >

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Glenn Linderman
On 10/15/2013 9:28 AM, PJ Eby wrote: On Tue, Oct 15, 2013 at 11:52 AM, R. David Murray wrote: >I think 'trap' would be much clearer. +1. Short and sweet, and just ambiguous enough that you don't leap to the conclusion that the error is ignored. I agree that "suppress" is basically a synonym

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Zero Piraeus
: On Tue, Oct 15, 2013 at 09:45:59AM -0700, Ethan Furman wrote: > [...] if the CM provides the value before, and the with block accepts > it, it can then have the exception added to it: > > with trap(OSError) as cm: > os.unlink('missing.txt') > if cm.exc: > do_something()

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Alexander Belopolsky
On Tue, Oct 15, 2013 at 12:45 PM, Ethan Furman wrote: > with trap(OSError) as cm: > os.unlink('missing.txt') > if cm.exc: > do_something() .. and why is this better than try: os.unlink('missing.txt') except OSError as exc: do_something() ? _

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Ethan Furman
On 10/15/2013 09:28 AM, PJ Eby wrote: On Tue, Oct 15, 2013 at 11:52 AM, R. David Murray wrote: What about making the context manager provide the trapped exception, in a fashion similar to what assertRaises does? Sadly, that won't work, since context managers provide a value *before* the block

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Brett Cannon
On Tue, Oct 15, 2013 at 12:49 PM, Eli Bendersky wrote: > On Tue, Oct 15, 2013 at 5:55 AM, Larry Hastings wrote: > >> >> >> I really want to get Argument Clinic in to Python 3.4. Currently the >> following is true: >> >>- It has an implementation I've been working on for more than a year. >>

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Antoine Pitrou
On Tue, 15 Oct 2013 15:20:34 +0100 Larry Hastings wrote: > If you want to struggle through it by hand, read clinic.py (obviously), > and then search for the string "clinic" in these files: > > Modules/_cursesmodule.c > Modules/_datetimemodule.c > Modules/_dbmmodule.c > Modules/po

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 10/15/2013 12:47 PM, Serhiy Storchaka wrote: > 15.10.13 15:55, Larry Hastings написав(ла): >> So, quick poll: do you approve of me checking Argument Clinic in to >> Python 3.4 trunk in its current state before 3.4a4? > > Could you get us a week fo

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Alexander Belopolsky
On Tue, Oct 15, 2013 at 8:27 AM, Antoine Pitrou wrote: >> I've come to the conclusion it makes sense to rename it from ignore to >> suppress, since that's the term already used for this operation in the >> rest of the context management docs: http://bugs.python.org/issue19266 > > "suppress" and/or

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Guido van Rossum
On Tue, Oct 15, 2013 at 9:49 AM, Eli Bendersky wrote: > And all of that just because the 3.4 deadling is looming. This makes me > somewhat sad about our process :-/ > Well, almost any process occasionally needs some pepper in the butt, and there's nothing like a hard deadline to get people to ta

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Eli Bendersky
On Tue, Oct 15, 2013 at 5:55 AM, Larry Hastings wrote: > > > I really want to get Argument Clinic in to Python 3.4. Currently the > following is true: > >- It has an implementation I've been working on for more than a year. >- I assert that it's a reasonable approach and the APIs are rea

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Serhiy Storchaka
15.10.13 15:55, Larry Hastings написав(ла): So, quick poll: do you approve of me checking Argument Clinic in to Python 3.4 trunk in its current state before 3.4a4? Could you get us a week for preliminary review before checking? I remember I proposed a little different syntax and I don't know w

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread PJ Eby
On Tue, Oct 15, 2013 at 8:57 AM, Nick Coghlan wrote: > So, having been convinced that "ignore" was the wrong choice of name, > reviewing the docs made it clear to me what the name *should* be. >From the point of view of code *outside* a block, the error is indeed suppressed. But, as one of those

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Skip Montanaro
> If this love-in continues I'll prep a release tonight and commit it in the > morning... just before my flight home across the Atlantic. You've got it backwards. You're supposed to release, then leave town for two weeks, not come home to field complaints. I think it might even be in the Zen of Py

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread PJ Eby
On Tue, Oct 15, 2013 at 11:52 AM, R. David Murray wrote: > I think 'trap' would be much clearer. +1. Short and sweet, and just ambiguous enough that you don't leap to the conclusion that the error is ignored. I agree that "suppress" is basically a synonym for "ignore"; trap at least *implies* s

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Larry Hastings
On 10/15/2013 03:52 PM, Guido van Rossum wrote: I'm +1 -- I have been ever since Larry & I discussed it at EuroPython 2012. If this love-in continues I'll prep a release tonight and commit it in the morning... just before my flight home across the Atlantic. //arry/ _

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Raymond Hettinger
On Oct 15, 2013, at 5:55 AM, Larry Hastings wrote: > I'd like to propose much the same thing for Argument Clinic: check it in now, > before 3.4a4, and let it bake in trunk a little before feature freeze at beta > 1 while I run around and finish the documentation. This is a good plan. "Lettin

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Barry Warsaw
On Oct 15, 2013, at 11:52 AM, R. David Murray wrote: >I think 'trap' would be much clearer. What about making the context >manager provide the trapped exception, in a fashion similar to >what assertRaises does? Even if that was almost never used in practice, >the fact that the CM provides only *

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Zero Piraeus
: On Tue, Oct 15, 2013 at 10:05:41PM +1000, Nick Coghlan wrote: > I've come to the conclusion it makes sense to rename it from ignore to > suppress, since that's the term already used for this operation in the > rest of the context management docs: http://bugs.python.org/issue19266 > > Given the

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread R. David Murray
On Tue, 15 Oct 2013 22:57:34 +1000, Nick Coghlan wrote: > On 15 October 2013 22:27, Antoine Pitrou wrote: > > Le Tue, 15 Oct 2013 22:05:41 +1000, > > Nick Coghlan a écrit : > > > >> On 15 October 2013 13:12, Glenn Linderman > >> wrote: > >> > Of course, if the name were changed to be accurate,

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Guido van Rossum
I'm +1 -- I have been ever since Larry & I discussed it at EuroPython 2012. On Tue, Oct 15, 2013 at 6:06 AM, Nick Coghlan wrote: > On 15 October 2013 22:55, Larry Hastings wrote: > > So, quick poll: do you approve of me checking Argument Clinic in to > Python > > 3.4 trunk in its current state

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Larry Hastings
On 10/15/2013 02:59 PM, Antoine Pitrou wrote: Le Tue, 15 Oct 2013 13:55:47 +0100, Larry Hastings a écrit : You can review the existing code here: https://bitbucket.org/larry/python-clinic/ You didn't create it as a (Bitbucket) fork of CPython, and you didn't put your changes in a separat

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Antoine Pitrou
Le Tue, 15 Oct 2013 13:55:47 +0100, Larry Hastings a écrit : > > You can review the existing code here: > > https://bitbucket.org/larry/python-clinic/ You didn't create it as a (Bitbucket) fork of CPython, and you didn't put your changes in a separate branch, so this repo is a bit useless t

Re: [Python-Dev] non-US zip archives support in zipfile.py

2013-10-15 Thread Martin v. Löwis
Am 15.10.13 14:49, schrieb Daniel Holth: > It is part of the ZIP specification. CP437 or UTF-8 are the two > official choices, but other encodings happen on Russian, Japanese > systems. Indeed. Formally, the other encodings are not supported by the ZIP specification, and are thus formally misuse o

Re: [Python-Dev] non-US zip archives support in zipfile.py

2013-10-15 Thread Oleg Broytman
Hi! On Tue, Oct 15, 2013 at 12:22:29PM +0200, "\"Martin v. L?wis\"" wrote: > Am 15.10.13 10:53, schrieb Daniel Holth: > > FYI zipfile does do UTF-8 > > (http://hg.python.org/cpython/file/d7ebe03fa752/Lib/zipfile.py#l368). > > Only the non-Unicode encodings might need some help. I like that the >

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Larry Hastings
On 10/15/2013 02:06 PM, Nick Coghlan wrote: On 15 October 2013 22:55, Larry Hastings wrote: So, quick poll: do you approve of me checking Argument Clinic in to Python 3.4 trunk in its current state before 3.4a4? I'm inclined to say yes, but ultimately the +1 you need is Guido's :) In the pas

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Nick Coghlan
On 15 October 2013 22:55, Larry Hastings wrote: > So, quick poll: do you approve of me checking Argument Clinic in to Python > 3.4 trunk in its current state before 3.4a4? I'm inclined to say yes, but ultimately the +1 you need is Guido's :) Cheers, Nick. -- Nick Coghlan | ncogh...@gmail.c

Re: [Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 10/15/2013 08:55 AM, Larry Hastings wrote: > So, quick poll: do you approve of me checking Argument Clinic in to > Python 3.4 trunk in its current state before 3.4a4? +1 Tres. - -- ==

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Nick Coghlan
On 15 October 2013 22:27, Antoine Pitrou wrote: > Le Tue, 15 Oct 2013 22:05:41 +1000, > Nick Coghlan a écrit : > >> On 15 October 2013 13:12, Glenn Linderman >> wrote: >> > Of course, if the name were changed to be accurate, or the feature >> > made less prone to misuse, then maybe it would term

[Python-Dev] Checking in Argument Clinic early?

2013-10-15 Thread Larry Hastings
I really want to get Argument Clinic in to Python 3.4. Currently the following is true: * It has an implementation I've been working on for more than a year. * I assert that it's a reasonable approach and the APIs are ready for public consumption. * The syntax for the DSL is the one pr

Re: [Python-Dev] non-US zip archives support in zipfile.py

2013-10-15 Thread Daniel Holth
On Tue, Oct 15, 2013 at 8:02 AM, Steven D'Aprano wrote: > On Tue, Oct 15, 2013 at 10:20:03AM +0200, Victor Stinner wrote: >> Both issues are related and should be fixed in the *same* commit. >> Python should provide an option to encode explicitly filenames to >> UTF-8. Or maybe better: encode to U

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Antoine Pitrou
Le Tue, 15 Oct 2013 22:05:41 +1000, Nick Coghlan a écrit : > On 15 October 2013 13:12, Glenn Linderman > wrote: > > Of course, if the name were changed to be accurate, or the feature > > made less prone to misuse, then maybe it would terminate. > > I've come to the conclusion it makes sense to

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Nick Coghlan
On 15 October 2013 13:12, Glenn Linderman wrote: > Of course, if the name were changed to be accurate, or the feature made less > prone to misuse, then maybe it would terminate. I've come to the conclusion it makes sense to rename it from ignore to suppress, since that's the term already used for

Re: [Python-Dev] non-US zip archives support in zipfile.py

2013-10-15 Thread Steven D'Aprano
On Tue, Oct 15, 2013 at 10:20:03AM +0200, Victor Stinner wrote: > Both issues are related and should be fixed in the *same* commit. > Python should provide an option to encode explicitly filenames to > UTF-8. Or maybe better: encode to UTF-8 by default, with an option to > encode to cp437, and anot

Re: [Python-Dev] non-US zip archives support in zipfile.py

2013-10-15 Thread Martin v. Löwis
Am 15.10.13 10:53, schrieb Daniel Holth: > FYI zipfile does do UTF-8 > (http://hg.python.org/cpython/file/d7ebe03fa752/Lib/zipfile.py#l368). > Only the non-Unicode encodings might need some help. I like that the > patch is only concerned with decoding. Is it necessary to support > writing non-UTF8

Re: [Python-Dev] non-US zip archives support in zipfile.py

2013-10-15 Thread Daniel Holth
FYI zipfile does do UTF-8 (http://hg.python.org/cpython/file/d7ebe03fa752/Lib/zipfile.py#l368). Only the non-Unicode encodings might need some help. I like that the patch is only concerned with decoding. Is it necessary to support writing non-UTF8 encodings? On Tue, Oct 15, 2013 at 10:20 AM, Victo

Re: [Python-Dev] non-US zip archives support in zipfile.py

2013-10-15 Thread Victor Stinner
Both issues are related and should be fixed in the *same* commit. Python should provide an option to encode explicitly filenames to UTF-8. Or maybe better: encode to UTF-8 by default, with an option to encode to cp437, and another to encode to an arbitrary encoding. Victor 2013/10/15 Alexander Be

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-15 Thread Baptiste Carvello
Le 15/10/2013 05:12, Glenn Linderman a écrit : > > I've got an extra can of "break_out_if" paint here... > another shed color: with contextlib.except_pass(FileNotFoundError): os.unlink(fname) explicit and hopefully not too ugly ___ Pytho