[Python-Dev] Proposed changes to provide compression support for rotated log files

2011-12-15 Thread Vinay Sajip
In response to http://bugs.python.org/issue13516 I'm thinking of implementing some changes in the rotating file handlers, as outlined here: http://plumberjack.blogspot.com/2011/12/improved-flexibility-for-log-file.html The changes (including tests) are almost ready to check in, but I thought I'd

Re: [Python-Dev] Proposed changes to provide compression support for rotated log files

2011-12-15 Thread Antoine Pitrou
On Thu, 15 Dec 2011 10:31:08 + (UTC) Vinay Sajip vinay_sa...@yahoo.co.uk wrote: In response to http://bugs.python.org/issue13516 I'm thinking of implementing some changes in the rotating file handlers, as outlined here:

Re: [Python-Dev] Proposed changes to provide compression support for rotated log files

2011-12-15 Thread Terry Reedy
On 12/15/2011 5:31 AM, Vinay Sajip wrote: In response to http://bugs.python.org/issue13516 I'm thinking of implementing some changes in the rotating file handlers, as outlined here: http://plumberjack.blogspot.com/2011/12/improved-flexibility-for-log-file.html The changes (including tests) are

Re: [Python-Dev] Proposed changes to provide compression support for rotated log files

2011-12-15 Thread Vinay Sajip
Antoine Pitrou solipsis at pitrou.net writes: def filename(self, name) sounds like a poor method name. You're right - perhaps def rotation_filename(self, default_name) is better. Regards, Vinay Sajip ___ Python-Dev mailing list

Re: [Python-Dev] Proposed changes to provide compression support for rotated log files

2011-12-15 Thread Vinay Sajip
Terry Reedy tjreedy at udel.edu writes: It appears you are adding two methods to do the same thing. One is to subclass and override one or two functions. The other is to define one or two custom functions and attach as attributes. Both seem equally easy. (Actually, subclassing takes one