[Qemu-devel] Re: [PATCH] pci: Add missing 'const' in argument to pci_get_xxx

2010-01-11 Thread Michael S. Tsirkin
On Mon, Jan 11, 2010 at 09:20:13PM +0100, Stefan Weil wrote: pci_get_byte, pci_get_word, pci_get_long and pci_get_quad all take a const uint8_t pointer, because they only read the configuration data. Their prototypes should reflect this fact. Signed-off-by: Stefan Weil

Re: [Qemu-devel] [PATCH 0/5] tcg-sparc improvements

2010-01-11 Thread Palle Lyckegaard
On Mon, 11 Jan 2010, Richard Henderson wrote: Richard Henderson (5): tcg-sparc: Add tcg_out_arithc. tcg-sparc: Implement add2, sub2, mulu2. tcg-sparc: Do not remove %o[012] from 'r' constraint. tcg-sparc: Implement division properly. tcg-sparc: Implement ext32[su]_i64 Great work :-)

Re: [Qemu-devel] [PATCHv2] Add KVM paravirt cpuid leaf

2010-01-11 Thread Jan Kiszka
Anthony Liguori wrote: On 01/07/2010 10:24 AM, Gleb Natapov wrote: diff --git a/target-i386/kvm.c b/target-i386/kvm.c index 4084503..6a841de 100644 --- a/target-i386/kvm.c +++ b/target-i386/kvm.c @@ -17,6 +17,7 @@ #includesys/mman.h #includelinux/kvm.h +#includelinux/kvm_para.h

[Qemu-devel] [RFC] New naming rules for GPXE romfiles

2010-01-11 Thread Stefan Weil
The current names of GPXE romfiles are something like pxe-e1000.bin, pxe-ne2k_pci.bin, pxe-rtl8139.bin. This was adequate when these names were computed by a simple rule using the device name. Today, an ethernet device can be associated to any romfile name. Etherboot's Rom-o-Matic (which

[Qemu-devel] Re: [PATCH 1/6] Make config space accessor host bus trapable

2010-01-11 Thread Blue Swirl
On Sun, Jan 10, 2010 at 6:41 PM, Blue Swirl blauwir...@gmail.com wrote: On Sun, Jan 3, 2010 at 7:18 PM, Blue Swirl blauwir...@gmail.com wrote: On Sun, Jan 3, 2010 at 6:06 PM, Michael S. Tsirkin m...@redhat.com wrote: On Sun, Jan 03, 2010 at 06:50:15PM +0100, Alexander Graf wrote: On

Re: [Qemu-devel] [RFC] New naming rules for GPXE romfiles

2010-01-11 Thread Anthony Liguori
On 01/11/2010 03:18 PM, Stefan Weil wrote: The current names of GPXE romfiles are something like pxe-e1000.bin, pxe-ne2k_pci.bin, pxe-rtl8139.bin. This was adequate when these names were computed by a simple rule using the device name. Today, an ethernet device can be associated to any romfile

Re: [Qemu-devel] [PATCHv2] Add KVM paravirt cpuid leaf

2010-01-11 Thread Anthony Liguori
On 01/11/2010 02:40 PM, Jan Kiszka wrote: Anthony Liguori wrote: On 01/07/2010 10:24 AM, Gleb Natapov wrote: diff --git a/target-i386/kvm.c b/target-i386/kvm.c index 4084503..6a841de 100644 --- a/target-i386/kvm.c +++ b/target-i386/kvm.c @@ -17,6 +17,7 @@ #includesys/mman.h

[Qemu-devel] Re: [RFC] API change for pci_set_word and related functions

2010-01-11 Thread Anthony Liguori
On 01/11/2010 02:30 PM, Michael S. Tsirkin wrote: On Mon, Jan 11, 2010 at 09:18:51PM +0100, Stefan Weil wrote: Michael S. Tsirkin schrieb: On Mon, Jan 11, 2010 at 08:38:53PM +0100, Stefan Weil wrote: Michael S. Tsirkin schrieb: On Thu, Jan 07, 2010 at 04:07:26PM

[Qemu-devel] Re: [RFC] API change for pci_set_word and related functions

2010-01-11 Thread Stefan Weil
Anthony Liguori schrieb: On 01/11/2010 02:30 PM, Michael S. Tsirkin wrote: On Mon, Jan 11, 2010 at 09:18:51PM +0100, Stefan Weil wrote: Michael S. Tsirkin schrieb: On Mon, Jan 11, 2010 at 08:38:53PM +0100, Stefan Weil wrote: Michael S. Tsirkin schrieb: On Thu, Jan

[Qemu-devel] Re: [PATCH 1/6] Make config space accessor host bus trapable

2010-01-11 Thread Igor Kovalenko
On Tue, Jan 12, 2010 at 12:29 AM, Blue Swirl blauwir...@gmail.com wrote: On Sun, Jan 10, 2010 at 6:41 PM, Blue Swirl blauwir...@gmail.com wrote: On Sun, Jan 3, 2010 at 7:18 PM, Blue Swirl blauwir...@gmail.com wrote: On Sun, Jan 3, 2010 at 6:06 PM, Michael S. Tsirkin m...@redhat.com wrote: On

[Qemu-devel] Re: [RFC] API change for pci_set_word and related functions

2010-01-11 Thread Anthony Liguori
On 01/11/2010 04:10 PM, Stefan Weil wrote: I haven't read this whole thread, but I really prefer things like pci_set_vendor_id(pci_dev, ); A close alternative, would be some refactoring to allow PCI config space to be represented as a C structure. Gerd had some patches at one point for

Re: [Qemu-devel] [PATCH] raw-posix: Detect CDROM via ioctl

2010-01-11 Thread Simon Horman
On Mon, Jan 11, 2010 at 01:30:18PM -0500, Cole Robinson wrote: Current CDROM detection is hardcoded based on source file name. Make this smarter by attempting a CDROM specific ioctl. This makes '-cdrom /dev/sr0' succeed with no media present. Signed-off-by: Cole Robinson

Re: [Qemu-devel] [PATCHv2] Add KVM paravirt cpuid leaf

2010-01-11 Thread Jan Kiszka
Anthony Liguori wrote: On 01/11/2010 02:40 PM, Jan Kiszka wrote: Anthony Liguori wrote: On 01/07/2010 10:24 AM, Gleb Natapov wrote: diff --git a/target-i386/kvm.c b/target-i386/kvm.c index 4084503..6a841de 100644 --- a/target-i386/kvm.c +++ b/target-i386/kvm.c @@ -17,6 +17,7 @@

Re: [Qemu-devel] [PATCH 5/8] virtio-serial-bus: Add support for buffering guest output, throttling guests

2010-01-11 Thread Jamie Lokier
Amit Shah wrote: Are you talking about a VNC protocol command between qemu's VNC server and the user's VNC client, or a private protocol between the guest and qemu's VNC server? What happens is: 1. Guest puts something on its clipboard 2. An agent on the guest gets notified of new

Re: [Qemu-devel] [PATCH] raw-posix: Detect CDROM via ioctl

2010-01-11 Thread Cole Robinson
On 01/11/2010 06:13 PM, Simon Horman wrote: On Mon, Jan 11, 2010 at 01:30:18PM -0500, Cole Robinson wrote: Current CDROM detection is hardcoded based on source file name. Make this smarter by attempting a CDROM specific ioctl. This makes '-cdrom /dev/sr0' succeed with no media present.

Re: [Qemu-devel] QMP forward compatibility support

2010-01-11 Thread Luiz Capitulino
On Mon, 11 Jan 2010 12:57:15 -0600 Anthony Liguori anth...@codemonkey.ws wrote: On 01/11/2010 12:34 PM, Luiz Capitulino wrote: Hi. We (Markus and I) are working on getting QMP forward compatibility support, supported. :) We have a plan for it and I'd like to ask the CC'ed

Re: [Qemu-devel] QMP forward compatibility support

2010-01-11 Thread Anthony Liguori
On 01/11/2010 06:04 PM, Luiz Capitulino wrote: As async messages were one of the reasons for having QMP, I thought that there was a consensus that making it part of the original protocol was ok, meaning that they would be always available. That's the only reason. Right, but then it's

Re: [Qemu-devel] [PATCH 5/8] virtio-serial-bus: Add support for buffering guest output, throttling guests

2010-01-11 Thread Anthony Liguori
On 01/11/2010 05:33 PM, Jamie Lokier wrote: Amit Shah wrote: Are you talking about a VNC protocol command between qemu's VNC server and the user's VNC client, or a private protocol between the guest and qemu's VNC server? What happens is: 1. Guest puts something on its clipboard

Re: [Qemu-devel] [PATCH 5/8] virtio-serial-bus: Add support for buffering guest output, throttling guests

2010-01-11 Thread Anthony Liguori
On 01/11/2010 02:39 AM, Amit Shah wrote: On (Fri) Jan 08 2010 [10:26:59], Anthony Liguori wrote: On 01/08/2010 07:35 AM, Jamie Lokier wrote: Sometimes it looks like TCP is maintaining write boundaries, but it is just an artifact of its behaviour on many systems, and is not reliable

Re: [Qemu-devel] [PATCH 1/5] lsi: use QTAILQ for lsi_queue

2010-01-11 Thread Anthony Liguori
On 01/06/2010 10:08 AM, Gerd Hoffmann wrote: Replace the funky array logic for queued commands with standard qemu list functions. Also rename lsi_queue to lsi_request. Signed-off-by: Gerd Hoffmannkra...@redhat.com Applied all. Thanks. Regards, Anthony Liguori --- hw/lsi53c895a.c |

[Qemu-devel] [ANNOUNCE] KVM developer conference call

2010-01-11 Thread Chris Wright
The KVM project is announcing a regular conference call focused on KVM development issues. The call will take place weekly on Tuesdays at 15:00 UTC for 1 hour. The purpose of the call is to discuss relevant development issues in a high bandwidth forum, certainly _not_ meant to supplant

[Qemu-devel] KVM call agenda for Jan 12

2010-01-11 Thread Chris Wright
Please send in any agenda items you are interested in covering. 1) administrivia 2) qemu 0.13 kvm feature merge issues 3) vhost-net todo's

[Qemu-devel] RE: [ANNOUNCE] KVM developer conference call

2010-01-11 Thread Xin, Xiaohui
Hi, Chris We are interested in joining the conference, since we are now working on the zero copy patch based on vhost-net. Thanks Xiaohui -Original Message- From: kvm-ow...@vger.kernel.org [mailto:kvm-ow...@vger.kernel.org] On Behalf Of Chris Wright Sent: Tuesday, January 12, 2010

Re: [Qemu-devel] Re: [SeaBIOS] [PATCH 0/8] option rom loading overhaul.

2010-01-11 Thread Jamie Lokier
Gleb Natapov wrote: On Sun, Dec 20, 2009 at 09:28:34AM -0600, Anthony Liguori wrote: Gleb Natapov wrote: On Sun, Dec 20, 2009 at 09:11:18AM -0600, Anthony Liguori wrote: Gleb Natapov wrote: On Sun, Dec 20, 2009 at 08:58:40AM -0600, Anthony Liguori wrote: No. You have to physically shut

Re: [Qemu-devel] [PATCH V12 00/27] split out piix specific part from pc emulator and some clean ups

2010-01-11 Thread Isaku Yamahata
Hi Anthony. Although I know that you're busy catching up the holidays, what's the status of this patch series? It looks like that you've committed patches which conflicts with it, so what can I do with this patch series to make your merge easier? thanks, On Wed, Jan 06, 2010 at 11:39:24AM

Re: [Qemu-devel] [PATCH 5/8] virtio-serial-bus: Add support for buffering guest output, throttling guests

2010-01-11 Thread Amit Shah
On (Mon) Jan 11 2010 [18:28:52], Anthony Liguori wrote: I would think that any buffering should be pushed back to the guest. IOW, if there's available data from the char driver, but the guest doesn't have a buffer. Don't select on the char driver until the guest has a buffer available. If

Re: [Qemu-devel] [PATCH 5/8] virtio-serial-bus: Add support for buffering guest output, throttling guests

2010-01-11 Thread Amit Shah
On (Mon) Jan 11 2010 [23:33:56], Jamie Lokier wrote: Amit Shah wrote: Are you talking about a VNC protocol command between qemu's VNC server and the user's VNC client, or a private protocol between the guest and qemu's VNC server? What happens is: 1. Guest puts something on its

Re: [Qemu-devel] [PATCHv2] Add KVM paravirt cpuid leaf

2010-01-11 Thread Gleb Natapov
On Mon, Jan 11, 2010 at 01:18:32PM -0600, Anthony Liguori wrote: On 01/07/2010 10:24 AM, Gleb Natapov wrote: diff --git a/target-i386/kvm.c b/target-i386/kvm.c index 4084503..6a841de 100644 --- a/target-i386/kvm.c +++ b/target-i386/kvm.c @@ -17,6 +17,7 @@ #includesys/mman.h

[Qemu-devel] [PATCH 1/4] Remove unused code

2010-01-11 Thread Liran Schour
blk_mig_save_bulked_block is never called with sync flag. Remove the sync flag. Calculate bulk completion during blk_mig_save_bulked_block. Signed-off-by: Liran Schour lir...@il.ibm.com --- block-migration.c | 63 1 files changed, 24

<    1   2