Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Robby Findler
Ah, sorry Alex. I mean "maximal" in the sense of this wikipedia page (and also how I was taught in math class, so definitely a "mathy" word(!)): https://en.wikipedia.org/wiki/Maximal_element Robby On Sun, Oct 11, 2015 at 9:48 PM, Alex Knauth wrote: > > On Oct 11, 2015, at

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Daniel Prager
find-min and find-max are (already) good names in my opinion. They shorten both minimum / minimal (maximum / maximal), which works for both numbers (whence our intuition) and partial orders. How about find-min or find-max with an optional keyword argument #:order-by (defaulting to <)? I dislike

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Vincent St-Amour
Similar to what JCG suggested: `find-most`? Vincent On Mon, 12 Oct 2015 14:37:43 -0500, Daniel Prager wrote: > > find-min and find-max are (already) good names in my opinion. They > shorten both minimum / minimal (maximum / maximal), which works for both > numbers (whence our intuition) and

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Martin DeMello
One problem with generalising find-max and find-min into a single hof is that they are closer in spirit to a fold than a find. The name find- makes you think that the passed in function should be a predicate on one element, not two. How about something like first-by? > (first-by stringstring

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Andrew Kent
... what about 'select' or 'select-by'? (If not... I'm just helping eliminate all the bad names... =) On Mon, Oct 12, 2015 at 7:39 PM Alex Knauth wrote: > The names `first-by` and `find-first-by` both sound good to me. > > Alexis? > > On Oct 12, 2015, at 4:54 PM, Martin

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Greg Hendershott
Oh, I love a good bikeshedding thread! ;) I think JCG nailed it: most - It's not excessively numeric. - Unlike "best" it's not judge-y or normative. - The polarity isn't _too_ weird for negatives. (Although "least " might be smoother English, "most " or "most {un,in}-" is usually clear

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Alex Knauth
> On Oct 12, 2015, at 8:35 PM, Alexis King wrote: > > I’m not completely sold on `most`, but I’m close. I like that it’s terse and > fairly obvious in what it does. The obvious downside is that it’s a little > vague. The expression (most < lst) doesn’t read super well,

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Matthew Butterick
> p.s. Although `find-most` is OK, IMO `find-` is usually a noise prefix > from the Department of Redundancy Department. Sort of like naming a > function `return-foo` instead of just `foo`. What else would a > function do except find or return foo? Agreed, but for this reason, `find-max` and

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Robby Findler
That's a great name. :) Robby On Mon, Oct 12, 2015 at 4:59 PM, Greg Hendershott wrote: > Oh, I love a good bikeshedding thread! ;) > > I think JCG nailed it: > > most > > - It's not excessively numeric. > > - Unlike "best" it's not judge-y or normative. > > - The

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Alex Knauth
The names `first-by` and `find-first-by` both sound good to me. Alexis? > On Oct 12, 2015, at 4:54 PM, Martin DeMello wrote: > > One problem with generalising find-max and find-min into a single hof is that > they are closer in spirit to a fold than a find. The name

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Alex Knauth
> On Oct 12, 2015, at 5:59 PM, Greg Hendershott > wrote: > > p.s. Although `find-most` is OK, IMO `find-` is usually a noise prefix > from the Department of Redundancy Department. Sort of like naming a > function `return-foo` instead of just `foo`. What else would a

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Alexis King
I’m not completely sold on `most`, but I’m close. I like that it’s terse and fairly obvious in what it does. The obvious downside is that it’s a little vague. The expression (most < lst) doesn’t read super well, IMO. I think passing a less-than? argument makes this function much closer

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-12 Thread Alex Knauth
> On Oct 12, 2015, at 8:55 PM, Alex Knauth wrote: > > >> On Oct 12, 2015, at 8:35 PM, Alexis King wrote: >> In the same line of thought as `append-map`, the name `first-sort` has >> crossed my mind, but this feels just as opaque. The name

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-11 Thread Robby Findler
Find-best is right to me. The "best" under < is the most negative number. Find-maximal is also okay and slightly more accurate. Robby On Sunday, October 11, 2015, Alex Knauth wrote: > Hi, > > Alexis King and I were discussing adding versions of argmin and argmax to > the

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-11 Thread Andrew Kent
'leftmost' or 'rightmost'? Or 'find-leftmost' 'find-rightmost'? I dunno, maybe those are more confusing. They seem to hint at the right idea to me (at least as it relates to argument order and the relation). On Sun, Oct 11, 2015, 6:25 PM Alex Knauth wrote: > Hi, > > Alexis

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-11 Thread Ben Lerner
What about "find-min-by"/"find-max-by"?  (Or, if it's more standard Rackety style, "find-min/by" and "find-max/by", where the slash denotes a variant of an otherwise common function...) Ben On 10/11/2015 6:24 PM, Alex Knauth wrote:

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-11 Thread Matthias Felleisen
argbest > On Oct 11, 2015, at 6:24 PM, Alex Knauth wrote: > > Hi, > > Alexis King and I were discussing adding versions of argmin and argmax to the > alexis/collection library, but we agreed that find-min and find-max were > clearer names. Then we came up with a

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-11 Thread Alex Knauth
My responses to Robby Findler, Andrew Kent, JCG, Ben Lerner, and Matthias Felleisen: Something I should have said before: I want this to be one abstraction over both find-min and find-max. > On Oct 11, 2015, at 6:29 PM, Robby Findler > wrote: > > Find-best is

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-11 Thread Matthias Felleisen
> On Oct 11, 2015, at 10:00 PM, Alex Knauth wrote: > > Um, ok. If we were making the naming consistent with argmin and argmax, that > would be good. But we renamed those to find-min and find-max because we > thought arg... was confusing. I know we try not to be confusing

Re: [racket-users] Naming for generalization of find-min and find-max?

2015-10-11 Thread Alex Knauth
> On Oct 11, 2015, at 10:41 PM, Nadeem Abdul Hamid wrote: > find-optimal ? > Originally I thought "optimal = maximal" and I didn't like it because it felt too number-y and too close to max. Robby got me to realize that optimal doesn't imply numbers, and is really closer to