[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-12-06 Thread Mike Percy (Code Review)
Mike Percy has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Patch Set 5: Code-Review+2


--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 5
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 
Gerrit-Comment-Date: Fri, 07 Dec 2018 03:43:23 +
Gerrit-HasComments: No


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-12-06 Thread Mike Percy (Code Review)
Mike Percy has submitted this change and it was merged. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..

(02/05) delta_store: convert DeltaIterator::PrepareBatch flags into bitfield

A follow-on patch will introduce DeltaIterator::SelectUpdates(), a new
method for extracting delta information from a DeltaIterator. As it is
only to be used by diff scans and will require dedicated in-memory state,
it'll also come with a new DeltaIterator::PrepareBatch() flag.

However, diff scans will need to use both SelectUpdates() and
ApplyUpdates(), and it'd be a shame to have to reseek and reprepare just to
use both extraction methods. As such, this patch makes it possible to
prepare a batch for use in multiple delta extraction methods.

Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Reviewed-on: http://gerrit.cloudera.org:8080/11857
Tested-by: Kudu Jenkins
Reviewed-by: Mike Percy 
---
M src/kudu/tablet/delta_iterator_merger.cc
M src/kudu/tablet/delta_iterator_merger.h
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/delta_store.h
M src/kudu/tablet/deltafile.cc
M src/kudu/tablet/deltafile.h
M src/kudu/tablet/deltamemstore.cc
M src/kudu/tablet/deltamemstore.h
M src/kudu/tablet/tablet-test-util.h
9 files changed, 55 insertions(+), 80 deletions(-)

Approvals:
  Kudu Jenkins: Verified
  Mike Percy: Looks good to me, approved

--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: merged
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 6
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-26 Thread Mike Percy (Code Review)
Mike Percy has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Patch Set 4: Code-Review+2


--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 4
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 
Gerrit-Comment-Date: Mon, 26 Nov 2018 20:04:08 +
Gerrit-HasComments: No


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-14 Thread Mike Percy (Code Review)
Mike Percy has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Patch Set 3: Code-Review+2


--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 3
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 
Gerrit-Comment-Date: Thu, 15 Nov 2018 00:21:11 +
Gerrit-HasComments: No


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-09 Thread Adar Dembo (Code Review)
Adar Dembo has removed Kudu Jenkins from this change.  ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Removed reviewer Kudu Jenkins with the following votes:

* Verified-1 by Kudu Jenkins (120)
--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: deleteReviewer
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 3
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-08 Thread Adar Dembo (Code Review)
Adar Dembo has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Patch Set 2:

(3 comments)

http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h
File src/kudu/tablet/delta_store.h:

http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h@205
PS2, Line 205:   // 'flags' is a bitfield describing what operation(s) the 
batch will be used
> Nit: Is there a more descriptive name that could be used? prepairForFlags?
Sure, I can rename it to something more specific.


http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h@349
PS2, Line 349: prepared_for
> prepared_flags_
Done


http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h@369
PS2, Line 369: prepared_for_
> same
Done



--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 2
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 
Gerrit-Comment-Date: Fri, 09 Nov 2018 04:58:40 +
Gerrit-HasComments: Yes


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-08 Thread Adar Dembo (Code Review)
Hello Mike Percy, David Ribeiro Alves, Grant Henke, Todd Lipcon,

I'd like you to reexamine a change. Please visit

http://gerrit.cloudera.org:8080/11857

to look at the new patch set (#3).

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..

(02/05) delta_store: convert DeltaIterator::PrepareBatch flags into bitfield

A follow-on patch will introduce DeltaIterator::SelectUpdates(), a new
method for extracting delta information from a DeltaIterator. As it is
only to be used by diff scans and will require dedicated in-memory state,
it'll also come with a new DeltaIterator::PrepareBatch() flag.

However, diff scans will need to use both SelectUpdates() and
ApplyUpdates(), and it'd be a shame to have to reseek and reprepare just to
use both extraction methods. As such, this patch makes it possible to
prepare a batch for use in multiple delta extraction methods.

Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
---
M src/kudu/tablet/delta_iterator_merger.cc
M src/kudu/tablet/delta_iterator_merger.h
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/delta_store.h
M src/kudu/tablet/deltafile.cc
M src/kudu/tablet/deltafile.h
M src/kudu/tablet/deltamemstore.cc
M src/kudu/tablet/deltamemstore.h
M src/kudu/tablet/tablet-test-util.h
9 files changed, 55 insertions(+), 80 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/57/11857/3
--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 3
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-08 Thread Mike Percy (Code Review)
Mike Percy has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Patch Set 2:

(2 comments)

nice little code reduction in the test code

http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h
File src/kudu/tablet/delta_store.h:

http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h@349
PS2, Line 349: prepared_for
prepared_flags_


http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h@369
PS2, Line 369: prepared_for_
same



--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 2
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 
Gerrit-Comment-Date: Thu, 08 Nov 2018 23:53:12 +
Gerrit-HasComments: Yes


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-07 Thread Grant Henke (Code Review)
Grant Henke has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Patch Set 2: Code-Review+1

(1 comment)

http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h
File src/kudu/tablet/delta_store.h:

http://gerrit.cloudera.org:8080/#/c/11857/2/src/kudu/tablet/delta_store.h@205
PS2, Line 205:   // 'flags' is a bitfield describing what operation(s) the 
batch will be used
Nit: Is there a more descriptive name that could be used? prepairForFlags? I 
assume the intent of this bitfield is only to be used to identify the target 
use of the batch.



--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 2
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 
Gerrit-Comment-Date: Wed, 07 Nov 2018 22:27:53 +
Gerrit-HasComments: Yes


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-02 Thread Adar Dembo (Code Review)
Adar Dembo has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Patch Set 2: Verified+1

Overriding Jenkins, flaky TSAN test failure in DefaultSourceTest.


--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 2
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 
Gerrit-Comment-Date: Fri, 02 Nov 2018 15:50:01 +
Gerrit-HasComments: No


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-02 Thread Adar Dembo (Code Review)
Adar Dembo has removed Kudu Jenkins from this change.  ( 
http://gerrit.cloudera.org:8080/11857 )

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..


Removed reviewer Kudu Jenkins with the following votes:

* Verified-1 by Kudu Jenkins (120)
--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: deleteReviewer
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 2
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] (02/05) delta store: convert DeltaIterator::PrepareBatch flags into bitfield

2018-11-01 Thread Adar Dembo (Code Review)
Hello Mike Percy, David Ribeiro Alves, Kudu Jenkins, Grant Henke, Todd Lipcon,

I'd like you to reexamine a change. Please visit

http://gerrit.cloudera.org:8080/11857

to look at the new patch set (#2).

Change subject: (02/05) delta_store: convert DeltaIterator::PrepareBatch flags 
into bitfield
..

(02/05) delta_store: convert DeltaIterator::PrepareBatch flags into bitfield

A follow-on patch will introduce DeltaIterator::SelectUpdates(), a new
method for extracting delta information from a DeltaIterator. As it is
only to be used by diff scans and will require dedicated in-memory state,
it'll also come with a new DeltaIterator::PrepareBatch() flag.

However, diff scans will need to use both SelectUpdates() and
ApplyUpdates(), and it'd be a shame to have to reseek and reprepare just to
use both extraction methods. As such, this patch makes it possible to
prepare a batch for use in multiple delta extraction methods.

Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
---
M src/kudu/tablet/delta_iterator_merger.cc
M src/kudu/tablet/delta_iterator_merger.h
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/delta_store.h
M src/kudu/tablet/deltafile.cc
M src/kudu/tablet/deltafile.h
M src/kudu/tablet/deltamemstore.cc
M src/kudu/tablet/deltamemstore.h
M src/kudu/tablet/tablet-test-util.h
9 files changed, 55 insertions(+), 80 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/57/11857/2
--
To view, visit http://gerrit.cloudera.org:8080/11857
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Id500ec3cc9459a78ae1098be3f3cd0cacb7a7a1a
Gerrit-Change-Number: 11857
Gerrit-PatchSet: 2
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Grant Henke 
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Mike Percy 
Gerrit-Reviewer: Todd Lipcon