Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Alan Bateman
On Wed, 30 Aug 2023 17:38:01 GMT, Stefan Karlsson wrote: > I wouldn't be opposed to a change that: > > * Keeps the `createJavaProcessBuilder` name > * Renames `createTestJvm` to `createJavaProcessBuilderPrependTestOpts` > * Renames `executeTestJvm` to `executeJavaPrependTestOpts` > * Removes `cr

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v3]

2023-08-30 Thread Chris Plummer
On Thu, 31 Aug 2023 01:34:44 GMT, David Holmes wrote: > I'm not seeing how calling processDebuggeeOutput lets us "see" stderr? If > there is nothing the test needs to read from stderr then I don't see any > point in processing it. I was thinking that maybe processDebuggeeOutput() should be upd

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread David Holmes
On Wed, 30 Aug 2023 11:31:20 GMT, Mark Sheppard wrote: > So you could create a single createJavaProcessBuilder with add an additional > parameter boolean addTestOpts e.g. createJavaProcessBuilder(List command, boolean addTestOpts) { ... } @msheppar that is actually where we started, and it was

Re: RFR: 8313277: Resolve multiple definition of 'normalize' when statically linking JDK native libraries with user code

2023-08-30 Thread David Holmes
On Tue, 29 Aug 2023 23:37:06 GMT, Jiangli Zhou wrote: > Please review this simple change from @cjmoon1 for resolving static linking > issue caused by multiple definition of 'normalize'. @cjmoon1's branch can be > found at: > https://github.com/openjdk/jdk/compare/master...cjmoon1:jdk:fix_norma

Re: RFR: 8313277: Resolve multiple definition of 'normalize' when statically linking JDK native libraries with user code

2023-08-30 Thread David Holmes
On Wed, 30 Aug 2023 15:35:20 GMT, Jiangli Zhou wrote: > Could you please clarify the last part of your comment? Is it related to > namespace? No not namespaces, just by using C++ so it a member function, then C++ name mangling would mean the symbol would be different to some same-named functio

Integrated: 8315421: [BACKOUT] 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags

2023-08-30 Thread Leonid Mesnik
On Thu, 31 Aug 2023 01:50:48 GMT, Leonid Mesnik wrote: > Please review following trivial fix which reverts > 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags This pull request has now been integrated. Changeset: 218829e0 Author:Leonid Mesnik URL: https://git.

Re: RFR: 8315421: [BACKOUT] 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags

2023-08-30 Thread Leonid Mesnik
On Thu, 31 Aug 2023 02:25:37 GMT, David Holmes wrote: >> Please review following trivial fix which reverts >> 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags > > Backout looks good. Thanks. @dholmes-ora, thank you forreview - PR Comment: https://git.openjdk

Re: RFR: 8315421: [BACKOUT] 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags

2023-08-30 Thread David Holmes
On Thu, 31 Aug 2023 01:50:48 GMT, Leonid Mesnik wrote: > Please review following trivial fix which reverts > 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags Backout looks good. Thanks. - Marked as reviewed by dholmes (Reviewer). PR Review: https://git.open

Re: RFR: 8315421: [BACKOUT] 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags

2023-08-30 Thread Leonid Mesnik
On Thu, 31 Aug 2023 01:50:48 GMT, Leonid Mesnik wrote: > Please review following trivial fix which reverts > 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags Tested with tier1. - PR Comment: https://git.openjdk.org/jdk/pull/15502#issuecomment-1700247867

RFR: 8315421: [BACKOUT] 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags

2023-08-30 Thread Leonid Mesnik
Please review following trivial fix which reverts 8314834 serviceability/jdwp/AllModulesCommandTest.java ignores VM flags - Commit messages: - Revert "8314834: serviceability/jdwp/AllModulesCommandTest.java ignores VM flags" Changes: https://git.openjdk.org/jdk/pull/15502/files W

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v3]

2023-08-30 Thread Leonid Mesnik
On Thu, 31 Aug 2023 01:29:28 GMT, David Holmes wrote: >> Leonid Mesnik has updated the pull request incrementally with one additional >> commit since the last revision: >> >> removed unused code. > > test/hotspot/jtreg/serviceability/jdwp/DebuggeeLauncher.java line 103: > >> 101: >> 102:

Re: RFR: 8311775: [TEST] duplicate verifyHeapDump in several tests [v4]

2023-08-30 Thread Yi Yang
> This is a follow-up patch of #13667. verifyHeapDump is duplicated in several > tests, this patch tries to consolidate them into one method. Yi Yang has updated the pull request incrementally with one additional commit since the last revision: Update HeapDumpTest.java - Changes

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v3]

2023-08-30 Thread David Holmes
On Wed, 30 Aug 2023 22:51:31 GMT, Leonid Mesnik wrote: >> So previously we would terminate the debuggee the first time we saw any >> output on stderr, and now instead we ignore stderr. What if instead we >> process stderr the same as stdout? Would that cause a failure because the >> output is

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v3]

2023-08-30 Thread David Holmes
On Thu, 31 Aug 2023 00:07:19 GMT, Leonid Mesnik wrote: >> Test failed because of unexpected output of version string. >> The standard convention for tests is to skip any unexpected output (version >> string, VM warning, vm logging) and only fail on expected error patterns. >> Fix is tested by

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v2]

2023-08-30 Thread Leonid Mesnik
On Wed, 30 Aug 2023 23:28:23 GMT, Chris Plummer wrote: >> Leonid Mesnik has updated the pull request incrementally with one additional >> commit since the last revision: >> >> restore errorhandler > > test/hotspot/jtreg/serviceability/jdwp/DebuggeeLauncher.java line 110: > >> 108: @Overr

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v3]

2023-08-30 Thread Leonid Mesnik
> Test failed because of unexpected output of version string. > The standard convention for tests is to skip any unexpected output (version > string, VM warning, vm logging) and only fail on expected error patterns. > Fix is tested by running with default options and with '-showversion' vm > o

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v2]

2023-08-30 Thread Chris Plummer
On Wed, 30 Aug 2023 22:57:00 GMT, Leonid Mesnik wrote: >> Test failed because of unexpected output of version string. >> The standard convention for tests is to skip any unexpected output (version >> string, VM warning, vm logging) and only fail on expected error patterns. >> Fix is tested by

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v2]

2023-08-30 Thread Leonid Mesnik
On Wed, 30 Aug 2023 22:31:43 GMT, Chris Plummer wrote: >> Not exactly, the stderr is just ignored. We don't expect anything so just >> ignore it. > > So previously we would terminate the debuggee the first time we saw any > output on stderr, and now instead we ignore stderr. What if instead we

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834 [v2]

2023-08-30 Thread Leonid Mesnik
> Test failed because of unexpected output of version string. > The standard convention for tests is to skip any unexpected output (version > string, VM warning, vm logging) and only fail on expected error patterns. > Fix is tested by running with default options and with '-showversion' vm > o

Re: RFR: JDK-8313656: assert(!JvmtiExport::can_support_virtual_threads()) with -XX:-DoJVMTIVirtualThreadTransitions

2023-08-30 Thread Leonid Mesnik
On Thu, 10 Aug 2023 01:45:47 GMT, Alex Menkov wrote: > The change fixes several issues with capability management: > - handling can_support_virtual_threads capability. > JvmtiExport::can_support_virtual_threads() should be set to true if we have > one or more agent with can_support_virtual_thre

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834

2023-08-30 Thread Chris Plummer
On Wed, 30 Aug 2023 22:15:52 GMT, Leonid Mesnik wrote: >> test/hotspot/jtreg/serviceability/jdwp/DebuggeeLauncher.java line 107: >> >>> 105: @Override >>> 106: public void onStringRead(StreamHandler handler, String line) { >>> 107: processDebuggeeOutput(line); >> >> So the fix i

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834

2023-08-30 Thread Leonid Mesnik
On Wed, 30 Aug 2023 22:05:53 GMT, Daniel D. Daugherty wrote: >> Test failed because of unexpected output of version string. >> The standard convention for tests is to skip any unexpected output (version >> string, VM warning, vm logging) and only fail on expected error patterns. >> Fix is tes

Re: RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834

2023-08-30 Thread Daniel D . Daugherty
On Wed, 30 Aug 2023 21:03:17 GMT, Leonid Mesnik wrote: > Test failed because of unexpected output of version string. > The standard convention for tests is to skip any unexpected output (version > string, VM warning, vm logging) and only fail on expected error patterns. > Fix is tested by runn

RFR: 8315406: serviceability/jdwp/AllModulesCommandTest.java fails after JDK-8314834

2023-08-30 Thread Leonid Mesnik
Test failed because of unexpected output of version string. The standard convention for tests is to skip any unexpected output (version string, VM warning, vm logging) and only fail on expected error patterns. Fix is tested by running with default options and with '-showversion' vm option. --

Integrated: JDK-8286789: Test forceEarlyReturn002.java timed out

2023-08-30 Thread Alex Menkov
On Tue, 15 Aug 2023 23:03:31 GMT, Alex Menkov wrote: > This is an attempt to fix suspicious code in the forceEarlyReturn002.java and > un-problemlist it to see if the problem appear again. > > The test fails in "virtual thread factory" mode with timeout for unclear > reason after it finished t

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Stefan Karlsson
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Leo Korinth
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Integrated: 8314834: serviceability/jdwp/AllModulesCommandTest.java ignores VM flags

2023-08-30 Thread Leonid Mesnik
On Mon, 28 Aug 2023 20:10:59 GMT, Leonid Mesnik wrote: > The test is fixed to start debuggee with tested VM options. > Verified with tier1, running svc tests with different vm flags and virtual > thread. This pull request has now been integrated. Changeset: 8e4cda06 Author:Leonid Mesnik U

Integrated: 8314824: Fix serviceability/jvmti/8036666/GetObjectLockCount.java to use vm flags

2023-08-30 Thread Leonid Mesnik
On Mon, 28 Aug 2023 19:12:04 GMT, Leonid Mesnik wrote: > Arguments were added to the launcher arguments. This pull request has now been integrated. Changeset: 93e82c01 Author:Leonid Mesnik URL: https://git.openjdk.org/jdk/commit/93e82c01460a70f214653a558d53c1c6180ae0d3 Stats: 6

Re: RFR: 8313277: Resolve multiple definition of 'normalize' when statically linking JDK native libraries with user code

2023-08-30 Thread Jiangli Zhou
On Wed, 30 Aug 2023 02:45:42 GMT, David Holmes wrote: > I'm sure I've said it before but there has to be a better way to handle this. > We should not have to rename perfectly well-named functions to insert a > unique prefix due to static linking conflicts. If this were C++ code rather > than C

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Roger Riggs
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Mark Sheppard
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Leo Korinth
> Rename createJavaProcessBuilder so that it is not used by mistake instead of > createTestJvm. > > I have used the following sed script: `find -name "*.java" | xargs -n 1 sed > -i -e > "s/createJavaProcessBuilder(/createJavaProcessBuilderIgnoreTestJavaOpts(/g"` > > Then I have manually modifi

Re: RFR: 8315097: Rename createJavaProcessBuilder [v2]

2023-08-30 Thread David Holmes
On Tue, 29 Aug 2023 16:45:12 GMT, Roger Riggs wrote: >> I don't think this is the best change across so many files. >> It gives a very ugly name to a common test function and affects a very large >> number of tests. > >> @RogerRiggs If it is only the name you want changed, maybe you can offer a