Re: [Spice-devel] [PATCH v4 00/17] Remove DummyChannel* objects

2016-12-02 Thread Frediano Ziglio
> 
> I'm a little bit confused. This appears to be the third patch series
> that is designated "v4". That means this should actually be v6, no?
> (although the previous series was sent exactly 1 minute before this
> one, so maybe they're the same?)
>

Yes, did some mistakes preparing and sending version 5.
I sent v5 named as v4 and a mix of old and new twice.
I'll do some updated (with split) and post a new version.

Frediano
 
> 
> On Thu, 2016-12-01 at 11:24 +, Frediano Ziglio wrote:
> > These objects were used by the sound channel as
> > this channel read/write to/from client directly.
> > This make the code of this channel quite different
> > from the other ones.
> > Also this reduce code duplication from RedChannelClient
> > and increase encapsulation.
> > First set of patches attempt to rename fields/structures
> > to prepare for the conversion to RedChannel/RedChannelClient
> > and GObject.
> > Than other patches basically do the conversion and
> > some cleanup.
> > 
> > Changes since v4:
> > - merged some patches;
> > - make sure all commit are working;
> > - some comment updates;
> > - added some additional cleanup patches.
> > 
> > Changes since v3:
> > - updated some commit message;
> > - rename structures and related fields in the same commit.
> > - reverted wrong field rename (RedChannel *client).
> > 
> > Changes since v2:
> > - send playback data as soon as possible;
> > - split renames putting client renames first then worker ones;
> > - some commit message changes.
> > 
> > Changes since v1:
> > - split some long lines;
> > - do not attempt to free in progress frame before is full sent.
> >   This could cause raw frames to be overridden.
> > 
> > Frediano Ziglio (17):
> >   sound: Use worker directly
> >   sound: Rename SndChannel to SndChannelClient
> >   sound: Rename {Record,Playback}Channel to *ChannelClient
> >   sound: Rename SndWorker to SndChannel
> >   sound: Convert SndChannel to GObject
> >   sound: Implements config_socket RedChannel callback
> >   sound: Convert SndChannelClient to GObject
> >   Remove DummyChannel* objects
> >   Make RedChannelClient::incoming private
> >   sound: Free more on SndChannel finalize
> >   sound: Use default disconnect for client channels
> >   sound: Reuse code for snd_set_{playback,record}_peer
> >   sound: Reuse code for migrating client channels
> >   sound: Reuse code to set volume and mute
> >   sound: Use default message handler if possible
> >   sound: Make clear active and client_active are boolean
> >   sound: Use memcpy instead of manually copy volume array
> > 
> >  server/Makefile.am  |4 +-
> >  server/dummy-channel-client.c   |  138 +--
> >  server/dummy-channel-client.h   |   64 +-
> >  server/dummy-channel.c  |   94 +--
> >  server/dummy-channel.h  |   60 +-
> >  server/red-channel-client-private.h |   11 +-
> >  server/red-channel-client.c |   12 +-
> >  server/red-channel-client.h |   13 +-
> >  server/sound.c  | 1737 +--
> > -
> >  9 files changed, 850 insertions(+), 1283 deletions(-)
> >  delete mode 100644 server/dummy-channel-client.c
> >  delete mode 100644 server/dummy-channel-client.h
> >  delete mode 100644 server/dummy-channel.c
> >  delete mode 100644 server/dummy-channel.h
> > 
> > base-commit: 1f800090ef671e9fccb49ed64c01a85b6eb0890a
> 
___
Spice-devel mailing list
Spice-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/spice-devel


Re: [Spice-devel] [PATCH v4 00/17] Remove DummyChannel* objects

2016-12-01 Thread Jonathon Jongsma
I'm a little bit confused. This appears to be the third patch series
that is designated "v4". That means this should actually be v6, no?
(although the previous series was sent exactly 1 minute before this
one, so maybe they're the same?)


On Thu, 2016-12-01 at 11:24 +, Frediano Ziglio wrote:
> These objects were used by the sound channel as
> this channel read/write to/from client directly.
> This make the code of this channel quite different
> from the other ones.
> Also this reduce code duplication from RedChannelClient
> and increase encapsulation.
> First set of patches attempt to rename fields/structures
> to prepare for the conversion to RedChannel/RedChannelClient
> and GObject.
> Than other patches basically do the conversion and
> some cleanup.
> 
> Changes since v4:
> - merged some patches;
> - make sure all commit are working;
> - some comment updates;
> - added some additional cleanup patches.
> 
> Changes since v3:
> - updated some commit message;
> - rename structures and related fields in the same commit.
> - reverted wrong field rename (RedChannel *client).
> 
> Changes since v2:
> - send playback data as soon as possible;
> - split renames putting client renames first then worker ones;
> - some commit message changes.
> 
> Changes since v1:
> - split some long lines;
> - do not attempt to free in progress frame before is full sent.
>   This could cause raw frames to be overridden.
> 
> Frediano Ziglio (17):
>   sound: Use worker directly
>   sound: Rename SndChannel to SndChannelClient
>   sound: Rename {Record,Playback}Channel to *ChannelClient
>   sound: Rename SndWorker to SndChannel
>   sound: Convert SndChannel to GObject
>   sound: Implements config_socket RedChannel callback
>   sound: Convert SndChannelClient to GObject
>   Remove DummyChannel* objects
>   Make RedChannelClient::incoming private
>   sound: Free more on SndChannel finalize
>   sound: Use default disconnect for client channels
>   sound: Reuse code for snd_set_{playback,record}_peer
>   sound: Reuse code for migrating client channels
>   sound: Reuse code to set volume and mute
>   sound: Use default message handler if possible
>   sound: Make clear active and client_active are boolean
>   sound: Use memcpy instead of manually copy volume array
> 
>  server/Makefile.am  |4 +-
>  server/dummy-channel-client.c   |  138 +--
>  server/dummy-channel-client.h   |   64 +-
>  server/dummy-channel.c  |   94 +--
>  server/dummy-channel.h  |   60 +-
>  server/red-channel-client-private.h |   11 +-
>  server/red-channel-client.c |   12 +-
>  server/red-channel-client.h |   13 +-
>  server/sound.c  | 1737 +--
> -
>  9 files changed, 850 insertions(+), 1283 deletions(-)
>  delete mode 100644 server/dummy-channel-client.c
>  delete mode 100644 server/dummy-channel-client.h
>  delete mode 100644 server/dummy-channel.c
>  delete mode 100644 server/dummy-channel.h
> 
> base-commit: 1f800090ef671e9fccb49ed64c01a85b6eb0890a
___
Spice-devel mailing list
Spice-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/spice-devel


[Spice-devel] [PATCH v4 00/17] Remove DummyChannel* objects

2016-12-01 Thread Frediano Ziglio
These objects were used by the sound channel as
this channel read/write to/from client directly.
This make the code of this channel quite different
from the other ones.
Also this reduce code duplication from RedChannelClient
and increase encapsulation.
First set of patches attempt to rename fields/structures
to prepare for the conversion to RedChannel/RedChannelClient
and GObject.
Than other patches basically do the conversion and
some cleanup.

Changes since v4:
- merged some patches;
- make sure all commit are working;
- some comment updates;
- added some additional cleanup patches.

Changes since v3:
- updated some commit message;
- rename structures and related fields in the same commit.
- reverted wrong field rename (RedChannel *client).

Changes since v2:
- send playback data as soon as possible;
- split renames putting client renames first then worker ones;
- some commit message changes.

Changes since v1:
- split some long lines;
- do not attempt to free in progress frame before is full sent.
  This could cause raw frames to be overridden.

Frediano Ziglio (17):
  sound: Use worker directly
  sound: Rename SndChannel to SndChannelClient
  sound: Rename {Record,Playback}Channel to *ChannelClient
  sound: Rename SndWorker to SndChannel
  sound: Convert SndChannel to GObject
  sound: Implements config_socket RedChannel callback
  sound: Convert SndChannelClient to GObject
  Remove DummyChannel* objects
  Make RedChannelClient::incoming private
  sound: Free more on SndChannel finalize
  sound: Use default disconnect for client channels
  sound: Reuse code for snd_set_{playback,record}_peer
  sound: Reuse code for migrating client channels
  sound: Reuse code to set volume and mute
  sound: Use default message handler if possible
  sound: Make clear active and client_active are boolean
  sound: Use memcpy instead of manually copy volume array

 server/Makefile.am  |4 +-
 server/dummy-channel-client.c   |  138 +--
 server/dummy-channel-client.h   |   64 +-
 server/dummy-channel.c  |   94 +--
 server/dummy-channel.h  |   60 +-
 server/red-channel-client-private.h |   11 +-
 server/red-channel-client.c |   12 +-
 server/red-channel-client.h |   13 +-
 server/sound.c  | 1737 +---
 9 files changed, 850 insertions(+), 1283 deletions(-)
 delete mode 100644 server/dummy-channel-client.c
 delete mode 100644 server/dummy-channel-client.h
 delete mode 100644 server/dummy-channel.c
 delete mode 100644 server/dummy-channel.h

base-commit: 1f800090ef671e9fccb49ed64c01a85b6eb0890a
-- 
git-series 0.9.1
___
Spice-devel mailing list
Spice-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/spice-devel


[Spice-devel] [PATCH v4 00/17] Remove DummyChannel* objects

2016-12-01 Thread Frediano Ziglio
These objects were used by the sound channel as
this channel read/write to/from client directly.
This make the code of this channel quite different
from the other ones.
Also this reduce code duplication from RedChannelClient
and increase encapsulation.
First set of patches attempt to rename fields/structures
to prepare for the conversion to RedChannel/RedChannelClient
and GObject.
Than other patches basically do the conversion and
some cleanup.

Changes since v4:
- merged some patches;
- make sure all commit are working;
- some comment updates;
- added some additional cleanup patches.

Changes since v3:
- updated some commit message;
- rename structures and related fields in the same commit.
- reverted wrong field rename (RedChannel *client).

Changes since v2:
- send playback data as soon as possible;
- split renames putting client renames first then worker ones;
- some commit message changes.

Changes since v1:
- split some long lines;
- do not attempt to free in progress frame before is full sent.
  This could cause raw frames to be overridden.

Frediano Ziglio (17):
  sound: Use worker directly
  sound: Rename SndChannel to SndChannelClient
  sound: Rename {Record,Playback}Channel to *ChannelClient
  sound: Rename SndWorker to SndChannel
  sound: Convert SndChannel to GObject
  sound: Implements config_socket RedChannel callback
  sound: Convert SndChannelClient to GObject
  Remove DummyChannel* objects
  Make RedChannelClient::incoming private
  sound: Free more on SndChannel finalize
  sound: Use default disconnect for client channels
  sound: Reuse code for snd_set_{playback,record}_peer
  sound: Reuse code for migrating client channels
  sound: Reuse code to set volume and mute
  sound: Use default message handler if possible
  sound: Make clear active and client_active are boolean
  sound: Use memcpy instead of manually copy volume array

 server/Makefile.am  |4 +-
 server/dummy-channel-client.c   |  138 +--
 server/dummy-channel-client.h   |   64 +-
 server/dummy-channel.c  |   94 +--
 server/dummy-channel.h  |   60 +-
 server/red-channel-client-private.h |   11 +-
 server/red-channel-client.c |   12 +-
 server/red-channel-client.h |   13 +-
 server/sound.c  | 1737 +---
 9 files changed, 850 insertions(+), 1283 deletions(-)
 delete mode 100644 server/dummy-channel-client.c
 delete mode 100644 server/dummy-channel-client.h
 delete mode 100644 server/dummy-channel.c
 delete mode 100644 server/dummy-channel.h

base-commit: 1f800090ef671e9fccb49ed64c01a85b6eb0890a
-- 
git-series 0.9.1
___
Spice-devel mailing list
Spice-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/spice-devel