Re: [MERGE] Address comments from Alex and Amos.

2008-09-22 Thread Benno Rice
On 22/09/2008, at 11:26 PM, Amos Jeffries wrote: Benno Rice wrote: Address comments from Alex and Amos. - Add some comments describing various function purposes. - Remove some debugging debugs that had crept in. - Use debugs() in preference to debug()(). - Adjust some debug levels. Getting

[MERGE] Address more comments from Amos.

2008-09-22 Thread Benno Rice
Address more comments from Amos. - Change debug levels in existing code. - Rename htcpHandle to htcpHandleMsg. # Bazaar merge directive format 2 (Bazaar 0.90) # revision_id: [EMAIL PROTECTED] # target_branch: http://www.squid-cache.org/bzr/squid3/trunk/ # testament_sha1:

[MERGE] Address comments from Alex and Amos.

2008-09-21 Thread Benno Rice
Address comments from Alex and Amos. - Add some comments describing various function purposes. - Remove some debugging debugs that had crept in. - Use debugs() in preference to debug()(). - Adjust some debug levels. # Bazaar merge directive format 2 (Bazaar 0.90) # revision_id: [EMAIL

Upgrade bzr on squid-cache.org to 1.6.1?

2008-09-21 Thread Benno Rice
Whenever I communicate with bzr on squid-cache.org it complains about the server not speaking network protocol version 3. I understand that this probably isn't a show-stopper of any nature but would it be an idea to update bzr on squid-cache.org at some point? -- Benno Rice [EMAIL

[MERGE] Finish forward-porting HTCP enhancements from squid 2.HEAD.

2008-09-17 Thread Benno Rice
This is a forward-port of the HTCP changes I made to squid 2.HEAD. Changes include: - Ability to send HTCP CLR requests when objects are invalidated or purged from the cache. - Config logic to allow the following: - HTCP peers who ONLY receive CLR messages from us. - HTCP peers

[MERGE] Further cleanup of urlAbsolute and friends.

2008-09-02 Thread Benno Rice
Ok, hopefully this meets with everybody's approval. Changes in this version: - Split urlAbsolute into urlIsRelative and urlMakeAbsolute. - Make urlIsRelative compliant with the RFC as to what defines a relative URL. - Use a malloc'ed buffer instead of a stack-allocated array and xstrdup in

[MERGE] Address Alex and Amos' comments.

2008-09-02 Thread Benno Rice
Address Alex and Amos' comments. - Use bool instead of int for urlIsRelative. - Document what leads to a NULL return in urlMakeAbsolute and mention the responsibility of the caller to free the result in the non-NULL case. - Declare variables closer to where they're used. - Fix indentation. #

[MERGE] Rework urlAbsolute to be a little more streamlined.

2008-08-31 Thread Benno Rice
Resubmit this patch, including changes based on comments by various people. - Mention RFC text in relation to changing the default behaviour in relation to unknown HTTP methods. - Use safe_free instead of xfree. - Rework urlAbsolute to use snprintf in a slightly better way. Snprintf is now

Re: [MERGE] Rework urlAbsolute to be a little more streamlined.

2008-08-31 Thread Benno Rice
) and returning urlbuf plain at the end. As in malloc it? -- Benno Rice [EMAIL PROTECTED]

Re: [MERGE] RFC-compliant object invalidation behaviour.

2008-08-28 Thread Benno Rice
(or whatever) that it's a resubmit? -- Benno Rice [EMAIL PROTECTED]

Re: cvs commit: squid/src url.c

2008-08-28 Thread Benno Rice
On 29/08/2008, at 5:09 AM, Henrik Nordstrom wrote: On tis, 2008-08-26 at 19:34 -0600, Benno Rice wrote: benno 2008/08/26 19:34:42 MDT Modified files: src url.c Log: Fix breakage caused by recent GCC fixes. The fixes in question prevented the returning of pre

Re: [MERGE] RFC-compliant object invalidation behaviour.

2008-08-28 Thread Benno Rice
On 28/08/2008, at 9:26 PM, Amos Jeffries wrote: Benno Rice wrote: [snip] # Bazaar merge directive format 2 (Bazaar 0.90) # revision_id: [EMAIL PROTECTED] # target_branch: file:///home/benno/squid-work/squid3-repo

Re: [MERGE] RFC-compliant object invalidation behaviour.

2008-08-28 Thread Benno Rice
On 29/08/2008, at 2:13 PM, Alex Rousskov wrote: On Thu, 2008-08-28 at 15:16 +1000, Benno Rice wrote: RFC-compliant object invalidation behaviour. - Switch the default from not purging if the method is unknown to purging if the method is unknown. - return false; // be conservative: we

Re: HTCP enhancements

2008-08-27 Thread Benno Rice
On 27/08/2008, at 4:26 PM, Amos Jeffries wrote: Benno Rice wrote: The attached patch adds some enhancements to squid 2.HEAD's HTCP support. These are: - Properly process CLR requests. - Allow peers to have no CLRs, only CLRs, or only CLRs not related to PURGE requests sent to them

[MERGE] Fix build on systems where $(MAKE) != make

2008-08-27 Thread Benno Rice
Respect $(MAKE) in error translation build. On FreeBSD, make is not GNU make. GNU make can be installed from ports, but it is installed as gmake, not make. This makes it vital that Makefiles that wish to work on FreeBSD always invoke make with $(MAKE) instead of make. The recent error

Re: [MERGE] Fix build on systems where $(MAKE) != make

2008-08-27 Thread Benno Rice
On 27/08/2008, at 3:36 PM, Benno Rice wrote: Respect $(MAKE) in error translation build. [snip] Sorry about this coming through twice. I'm a bit new to this whole bzr thing. =) -- Benno Rice [EMAIL PROTECTED]

[MERGE] RFC-compliant object invalidation behaviour.

2008-08-27 Thread Benno Rice
RFC-compliant object invalidation behaviour. - Switch the default from not purging if the method is unknown to purging if the method is unknown. - When purging URIs sourced from Location and Content-Location headers, make sure the URL is absolute before a) comparing it to see if hosts match

HTCP enhancements

2008-08-26 Thread Benno Rice
this patch on Friday barring any objections. htcp-patch.diff Description: Binary data -- Benno Rice [EMAIL PROTECTED]

Re: Squid-2 Subversion Checklist

2008-08-14 Thread Benno Rice
trivial, and for which all the toolchain stuff on squid-cache.org is already done. Except that, as previously noted, this makes life hell for our Win32 maintainer. Has bzr sorted out the line-ending problems yet? -- Benno Rice [EMAIL PROTECTED]

Re: Unknown method handling in squid 2.x

2008-08-12 Thread Benno Rice
On 12/08/2008, at 4:05 PM, Amos Jeffries wrote: On 16/07/2008, at 4:12 PM, Benno Rice wrote: Here are two patches against squid 2.HEAD. The first completely changes the nature of method_t in order to allow squid to pass through methods it doesn't know about. What is currently called

Re: Unknown method handling in squid 2.x

2008-08-12 Thread Benno Rice
On 12/08/2008, at 4:28 PM, Robert Collins wrote: On Tue, 2008-08-12 at 16:20 +1000, Benno Rice wrote: On 12/08/2008, at 4:05 PM, Amos Jeffries wrote: By that do you mean you are syncing with the logic fix made for 3.1? I didn't directly refer to that, no. I set up a set of simple unit

httpMaybeRemovePublic and collapsed_forwarding

2008-06-23 Thread Benno Rice
that the StoreEntry in use may not be right in someway. Is there some way I can tell whether it's safe to run httpMaybeRemovePublic in the collapsed case? Many thanks, Benno. -- Benno Rice [EMAIL PROTECTED]

Re: New version of patch for bug 1893

2008-06-23 Thread Benno Rice
On 17/06/2008, at 2:20 PM, Benno Rice wrote: I believe I've fixed the case where an object moves from non-Vary to Vary. If people could test this and see if I've solved that case I'd be most appreciative. Patch is attached to the bug in Bugzilla. Has anyone managed to have a look

Re: Problem with CVS pserver?

2008-04-09 Thread Benno Rice
On 09/04/2008, at 4:42 PM, Amos Jeffries wrote: Benno Rice wrote: I've started getting this today: cvs -z9 -d :pserver:[EMAIL PROTECTED]:/squid co squid open /dev/null failed Operation not supported Has something broken on the CVS server? The central repository has been migrated from CVS

Problem with CVS pserver?

2008-04-08 Thread Benno Rice
I've started getting this today: cvs -z9 -d :pserver:[EMAIL PROTECTED]:/squid co squid open /dev/null failed Operation not supported Has something broken on the CVS server? -- Benno Rice [EMAIL PROTECTED]

Getting back in to Squid

2008-04-05 Thread Benno Rice
Hi there, Some of you may remember me from the original https accelerator support code way back when. I'm looking to get back into doing some squid work in various areas and so thought getting back on to the dev list would be a good idea. =) Look forward to helping out! -- Benno Rice

EAGAIN on bind in commResetFD?

2003-10-07 Thread Benno Rice
a band-aid in there until we can get another machine up and running along side. Many thanks. -- Benno Rice [EMAIL PROTECTED] signature.asc Description: This is a digitally signed message part