Re: normalize ldap DN in the config

2021-10-06 Thread Gleydson Soares
> On Oct 6, 2021, at 2:13 PM, Claudio Jeker wrote: > > Run into this while setting up a new DN. > The DN in namespace only matches if it is normalized. > So it may be best to do this by default when adding a namespace. > With this using a capitalized namespace like "o=OpenBSD,c=CA" will >

Re: sample unbound.conf tweak

2020-06-21 Thread Gleydson Soares
On Sun, Jun 21, 2020 at 04:47:22PM +0100, Stuart Henderson wrote: > An "uncomment" was left in when we reenabled dnssec by default, > and it seems a bit pointless to say "comment out to disable". ok? > makes sense, ok with me. > > Index: unbound.conf >

Re: refer to pointers as non-null

2020-01-31 Thread Gleydson Soares
On Fri, Jan 31, 2020 at 05:33:05AM -0500, Ted Unangst wrote: > Noticed this in wait.2, though I imagine other occurences abound. > > I believe non-null is clearer when refering to a pointer than non-zero, which > is a bit 80s, and less likely to be mistaken for the value pointed to. This > same

Re: introduce 'pfctl -FR' to reset settings to defaults

2019-04-06 Thread Gleydson Soares
+void > +pfctl_reset(int dev, int opts) > +{ > + struct pfctlpf; > + struct pfr_buffer t; > + int i; > + > + pf.dev = dev; > + pfctl_init_options(); > + > + /* Force reset upon pfctl_load_options() */ > + pf.debug_set = 1; > + pf.reass_set = 1; > +

Re: Replace getprogname() to argv[0] in bnaddsub

2018-07-17 Thread Gleydson Soares
On Tue, Jul 17, 2018 at 10:09:37PM +0900, Kinichiro Inoguchi wrote: > To run regress bnaddsub on Windows, I would like to supersede getprogname > with argv[0] since it is not on Windows. > > OK ? > > Index: regress/lib/libcrypto/bn/addsub/bnaddsub.c >

Re: sync calloc call in ber.c

2018-06-27 Thread Gleydson Soares
On Wed, Jun 27, 2018 at 10:05:52AM -0400, Rob Pierce wrote: > This ber.c change has been in ldapd since rev 1.1 and was applied to snmpd > back > in 2012. The following diff applies the change to the ldap client and ypldap. > > Ok? looks right, > > Index: usr.bin/ldap/ber.c >

Re: ldapd: avoid passing NULL to asprintf(3) when there's no parent dn entry

2018-06-25 Thread Gleydson Soares
On Mon, Jun 25, 2018 at 12:27:23PM +0200, Jeremie Courreges-Anglas wrote: > On Mon, Jun 25 2018, Gleydson Soares wrote: > > avoid passing NULL to asprintf(3) when there's no parent dn entry, > > this happens when adding a new naming context and then putting the first > > rdn

Re: ldapd: fix regress

2018-06-25 Thread Gleydson Soares
On Mon, Jun 25, 2018 at 08:49:31AM +0200, Landry Breuil wrote: > On Mon, Jun 25, 2018 at 02:25:40AM -0300, Gleydson Soares wrote: > > unbreak ldapd regress, > > everything seems to be working fine. > > the point of the overly complicated grep line was to handle the case >

ldapd: avoid passing NULL to asprintf(3) when there's no parent dn entry

2018-06-24 Thread Gleydson Soares
avoid passing NULL to asprintf(3) when there's no parent dn entry, this happens when adding a new naming context and then putting the first rdn in. Jun 24 23:51:23 x250 ldapd: vfprintf %s NULL in "@%.*s,%.*s" Jun 25 00:13:14 x250 ldapd: vfprintf %s NULL in "@%.*s,%.*s" ? ldapd.diff Index:

vmd: sync DPADD with LDADD

2018-06-23 Thread Gleydson Soares
sync DPADD with LDADD adding missing ${LIBPTHREAD} to ensure that binary is rebuilt in case of pthread library changes. Index: Makefile === RCS file: /cvs/src/usr.sbin/vmd/Makefile,v retrieving revision 1.17 diff -u -p -r1.17 Makefile

spamlogd: add missing ${LIBCRYPTO} to DPADD

2018-06-23 Thread Gleydson Soares
add missing ${LIBCRYPTO} Index: Makefile === RCS file: /cvs/src/libexec/spamlogd/Makefile,v retrieving revision 1.7 diff -u -p -r1.7 Makefile --- Makefile21 Aug 2013 16:13:30 - 1.7 +++ Makefile24 Jun 2018 04:04:42

sasyncd: remove redundant memset() call

2018-06-23 Thread Gleydson Soares
calloc() already filled all the memory block to 0, zap memset(). Index: pfkey.c === RCS file: /cvs/src/usr.sbin/sasyncd/pfkey.c,v retrieving revision 1.28 diff -u -p -r1.28 pfkey.c --- pfkey.c 18 Apr 2017 02:29:56 - 1.28

Re: use __func__ in iked util.c log_debug

2018-06-22 Thread Gleydson Soares
On Fri, Jun 22, 2018 at 08:58:24AM -0400, Rob Pierce wrote: > ok? looks good to me, > > Index: util.c > === > RCS file: /cvs/src/sbin/iked/util.c,v > retrieving revision 1.35 > diff -u -p -r1.35 util.c > --- util.c13 Dec 2017

Re: ldap(1) -y secretfile

2018-06-21 Thread Gleydson Soares
escription: All people in organisation objectclass: organizationalunit dn: cn=gleydson soares,ou=people,dc=trusted,dc=com,dc=br objectclass: inetOrgPerson cn: Gleydson Soares sn: Gleydson uid: gsoares <...> i like it, ok gsoares@

vmd: def nitems() locally

2018-04-30 Thread Gleydson Soares
hi, following diff defines nitems locally and stop including Index: control.c === RCS file: /cvs/src/usr.sbin/vmd/control.c,v retrieving revision 1.22 diff -u -p -r1.22 control.c --- control.c 8 Sep 2017 06:24:31 - 1.22

Re: ldapd: one negation is enough

2017-07-28 Thread Gleydson Soares
Florian Obser writes: > this made my head hurt, pointed out by clang. > > "logical not is only applied to the left hand side of this comparison > [-Wlogical-not-parentheses]" > > OK? oh I realized I had forgotten something, I've this change in my tree for months and ok'ed

Re: pfctl: Fix function name in errx(3) message

2017-03-27 Thread Gleydson Soares
> What about the other calls to calloc(3); shouldn't we keep their > respective error messages consistent? seems that several err()/errx() calls in pfctl code are hard-coding the function name... instead of hard code, maybe those calls should be changed to: errx(1, "%s: anystring", __func__)

Re: Improved support for Apple trackpads: tests needed

2017-03-10 Thread Gleydson Soares
Hi Ulf, > This patch for ubcmtp makes it use the multitouch-input functions of > wsmouse. It's the first driver that would apply the "tracking" variant > (wsmouse_mtframe). > > No wonders will result from the change, but the two-finger gestures that > involve movement - scrolling and

Re: undocumented -P/-I in relayd, vmd, httpd, ...

2017-02-28 Thread Gleydson Soares
Philipp Buehler writes: > Hi there, > > while crawling through relayd source, I noticed that there is I:P: in > getopt. > P is obviously setting the proc-title, but I am unsure what to "get" > from an > instance-number via -I. > > This found way

Re: fix uname.3 manpage.

2016-10-09 Thread Gleydson Soares
Philip Guenther <guent...@gmail.com> writes: > > On Sat, 8 Oct 2016, Gleydson Soares wrote: > > uname(3) function returns 0 on successful and -1 on failure. > > "non-negative value" is wrong here. > > Hmm, that's a direct quote from the standard. While

fix uname.3 manpage.

2016-10-09 Thread Gleydson Soares
uname(3) function returns 0 on successful and -1 on failure. "non-negative value" is wrong here. Index: uname.3 === RCS file: /cvs/src/lib/libc/gen/uname.3,v retrieving revision 1.15 diff -u -p -r1.15 uname.3 --- uname.3 21 Jan

passwd(1) - use explicit_bzero(3)

2016-08-31 Thread Gleydson Soares
after recents passwd(1) changes, We should use explicit_bzero(3) for clearing these sensitive strings. OK? Index: local_passwd.c === RCS file: /cvs/src/usr.bin/passwd/local_passwd.c,v retrieving revision 1.50 diff -u -p -r1.50

Re: wifind(8) find your wifi

2016-06-02 Thread Gleydson Soares
On Thu, Jun 2, 2016 at 7:52 PM, Mike Belopuhov <m...@belopuhov.com> wrote: > On 3 June 2016 at 00:17, Gleydson Soares <gsoa...@gmail.com> wrote: >> I usually just use a small script that lives in ~/bin >> > > It's a great name, though. Oops, Disregard it... it wa

wifind(8) find your wifi

2016-06-02 Thread Gleydson Soares
I usually just use a small script that lives in ~/bin cat ~/bin/wifi #!/bin/sh if [[ $1 == "home" ]]; then doas ifconfig run0 nwid foonet wpa wpakey ultrasecret doas dhclient run0 fi

Re: doas: adjust yyerror() output

2016-04-26 Thread Gleydson Soares
> what about just printing "doas: "? I prefer not hardcoded string, although I've committed as you pointed out,

doas: adjust yyerror() output

2016-04-25 Thread Gleydson Soares
I just stumbled over this... % doas abc syntax error at line 1 % I took some secs trying to figure out what was wrong with abc's command syntax that I typed out. But bingo, It was happenned due my doas.conf has a syntax error... Seems that yyerror() doesn't print out the progname's

Re: ldapd: add -r option to specify datadir path

2016-02-02 Thread Gleydson Soares
> Here's a similar diff for ldapctl, thoughts? With your tweaks sounds much better. OK gsoares@

Re: ldapd: add -r option to specify datadir path

2016-02-02 Thread Gleydson Soares
> Thinking about it .. would a call to access(2) with R_OK|W_OK|R_OK|F_OK > satisfy > everyone ? Or only F_OK ? Sounds better than chdir(2), but it will lack if datadir was passed to access(2) without including trailing "/" eg with access(datadir, F_OK): $ touch /home/gsoares/testfile <-

Re: ldapd: add -r option to specify datadir path

2016-02-01 Thread Gleydson Soares
Hi Landry, On Sun, Jan 31, 2016 at 09:39:52AM +0100, Landry Breuil wrote: > Hi, > > i'm tinkering with ldapd and writing regress tests for it, and to > allow running independent instances (with separate port/control > socket/etc) i needed to add the possibility to specify an alternative >

Re: ldapd: add -r option to specify datadir path

2016-02-01 Thread Gleydson Soares
On Mon, Feb 1, 2016 at 5:13 PM, Jérémie Courrèges-Anglas <j...@wxcvbn.org> wrote: > Gleydson Soares <gsoa...@gmail.com> writes: > >> Hi Landry, >> >> On Sun, Jan 31, 2016 at 09:39:52AM +0100, Landry Breuil wrote: >>> Hi, >>>

Re: [PATCH] octeon.html

2016-01-13 Thread Gleydson Soares
committed, thanks!

Re: ARP input path without KERNEL_LOCK

2015-12-29 Thread Gleydson Soares
On Tue, Dec 29, 2015 at 7:23 AM, Martin Pieuchot wrote: > I got one positive test report from Hrvoje Popovski and one from mxb, > anybody else tried this diff? seems fine here, no regressions so far...

Re: [patch] basename(1) tweaks

2015-12-24 Thread Gleydson Soares
>> - activate stack protector > > Hm? Changing the exit to a return does this? yes, stack protector only works if the function returns.

relayctl(8): add manpage "log" bits

2015-11-26 Thread Gleydson Soares
hi, as spotted out by Luis Gustavo on misc@ http://marc.info/?l=openbsd-misc=144859324815165=2 relayct(8) manpage is missing the "log" bits. here is a diff to fix that OKs? // gsoares ? relayctl Index: relayctl.8 === RCS file:

Re: ntpd(8): Make -n quieter

2015-09-01 Thread Gleydson Soares
On Tue, Sep 01, 2015 at 09:21:03AM +0200, Peter Hessler wrote: > On 2015 Aug 31 (Mon) at 14:28:11 -0400 (-0400), Michael Reed wrote: > :On 08/31/15 07:36, Sebastian Benoit wrote: > :> Michael Reed(m.r...@mykolab.com) on 2015.08.30 14:58:35 -0400: > :>> Hi all, > :>> > :>> If ntpd is run with the

Re: [patch]file: xstrdup just wrappes strdup(3)

2015-06-17 Thread Gleydson Soares
+ err(1, xstrdup); slight tweak, usually the err output is: err(1, strdup)

Re: FUSE Patches

2015-06-03 Thread Gleydson Soares
Stefan Sperling s...@stsp.name writes: On Sun, Feb 22, 2015 at 01:17:27AM +0800, Helg wrote: I thought I might be a bit late with this but thanks for letting me know. I'll keep working on it and submit the patches individually once 5.7 is released. Any news? FUSE patches are exciting...

Re: Fix for connect race in relayd

2015-05-31 Thread Gleydson Soares
(The pastebin expire) patches on tech@ are preferably as inline(text/plain) in the body of the email. and make sure that your mail client doesn't corrupt it. most openbsd developers uses mutt, but there are a lot of MUAs that handle correctly inline content disposition without mangling the

Re: mg(1) segfault

2015-04-10 Thread Gleydson Soares
I hate the startup file. Look, this is a use after free, but I can't find it... #0 0x1b9de0b1b77f in definemacro (f=0, n=1) at /usr/src/usr.bin/mg/macro.c:43 43 lp2 = lp1-l_fp; (gdb) p *maclhead $1 = {l_fp = 0xdfdfdfdfdfdfdfdf, l_bp =

mg(1) segfault

2015-04-04 Thread Gleydson Soares
mg(1) segfault. it is triggered as follows: 1- echo (start-kbd-macro) $HOME/.mg 2- open mg and type twice C-x ( find below the backtrace and a patch to fix. OK? Program received signal SIGBUS, Bus error. definemacro (f=Variable f is not available. ) at macro.c:43 43

Re: mg(1) segfault

2015-04-04 Thread Gleydson Soares
return (macrodef = FALSE); but we shouldn't change macrodef here. ? mg ? mg_segfault.diff ? v2_mg_segfault.diff Index: macro.c === RCS file: /cvs/src/usr.bin/mg/macro.c,v retrieving revision 1.16 diff -u -p -u -p

Re: [miniroot/install.sub] skip x* sets if do not expect to run X.

2013-01-13 Thread Gleydson Soares
please, disregard this diff. it is definitely wrong. -- gsoares

[miniroot/install.sub] skip x* sets if do not expect to run X.

2013-01-11 Thread Gleydson Soares
the diff below changes src/distrib/miniroot/install.sub to by default skip x* sets if someone do not expect to run X Do you expect to run the X Window System [no] if someone still want to install those sets may select by hand afterwards: Set name(s)? (or 'abort' or 'done') [done] x* i've

Re: M_DONTWAIT - M_NOWAIT

2012-12-28 Thread Gleydson Soares
On Fri, Dec 28, 2012 at 1:25 PM, Todd C. Miller todd.mil...@courtesan.com wrote: OK for all but that m_split() change where M_DONTWAIT is actually appropriate. We shouldn't be using M_DONTWAIT for malloc() but it is correct for the mbuf functions. Ooops. good catch. m_split() was changed by a

set ifp-if_baudrate with IF_Gbps() / IF_Mbps()

2012-11-23 Thread Gleydson Soares
set ifp-if_baudrate with IF_Gbps() / IF_Mbps(). OK ? Index: if_ste.c === RCS file: /cvs/src/sys/dev/pci/if_ste.c,v retrieving revision 1.48 diff -u -p -r1.48 if_ste.c --- if_ste.c18 Oct 2012 21:44:21 - 1.48 +++ if_ste.c

usr.bin/mail: use F_OK instead of 0 in access()

2012-11-13 Thread Gleydson Soares
hi, use F_OK macro instead of 0 in access() when cheching by file existence. make de code easier to read. no funcional change. OK ? Index: cmd2.c === RCS file: /cvs/src/usr.bin/mail/cmd2.c,v retrieving revision 1.18 diff -u -p

src/sys/net/if_pflow.c - fix kernel builds without bpfilter

2012-11-08 Thread Gleydson Soares
Hi, protect bpfilter portion with #if NBPFILTER 0. fix kernel builds without bpfilter. OK ? Index: if_pflow.c === RCS file: /cvs/src/sys/net/if_pflow.c,v retrieving revision 1.21 diff -u -p -r1.21 if_pflow.c --- if_pflow.c 30 Oct

Re: Virtio drivers for OpenBSD

2012-07-11 Thread Gleydson Soares
could you resubmit a new diff against -current ? please, attach it inline here. On Wed, Jul 11, 2012 at 9:07 AM, Stefan Fritsch s...@sfritsch.de wrote: Hi, I have been working on porting NetBSD's virtio drivers to OpenBSD. I am not finished yet, but in order to prevent duplicate work, I

Re: [resend] ipv6 support for tftp

2012-04-27 Thread Gleydson Soares
On Fri, Apr 27, 2012 at 12:34:19PM -0400, Brad Smith wrote: Tested against OpenBSD's tftpd and dnsmasq. Working fine for me. here is an updated version of the diff. - setpeer0() and setpeer() were renamed accordingly for clarity and consistency. (requested by henning@) - fix memleak(call

Re: [resend] ipv6 support for tftp

2012-04-19 Thread Gleydson Soares
On Tue, Mar 06, 2012 at 09:32:47AM +, Stuart Henderson wrote: On 2011/01/22 19:40, Gleydson Soares wrote: can anyone test this diff? your feedback will be most welcome On Wed, Sep 08, 2010 at 11:51:11AM -0300, Gleydson Soares wrote: hi, - ipv6 support for tftp client

bgplg: use -A with traceroute6 to print the AS number

2012-03-27 Thread Gleydson Soares
now that we've the option -A with traceroute6, bgplg is happy to use OK ? Index: bgplg.h === RCS file: /cvs/src/usr.bin/bgplg/bgplg.h,v retrieving revision 1.8 diff -u -p -r1.8 bgplg.h --- bgplg.h 8 Nov 2011 12:21:29 -

Re: etc/rc.d/ldapd stop - pexp - ldapd: ldap server

2011-09-20 Thread Gleydson Soares
On Tue, Sep 20, 2011 at 04:33:10PM +0200, MERIGHI Marcus wrote: anyone? it is in, already committed. mcmer-open...@tor.at (MERIGHI Marcus), 2011.09.09 (Fri) 16:22 (CEST): Hello, the stock $ /etc/rc.d/ldapd stop does not work for me. The diff below makes it work. Index:

plug a memleak in output_listing()

2011-02-11 Thread Gleydson Soares
plug a memleak in output_listing(); from NetBSD Index: aicasm.c === RCS file: /cvs/src/sys/dev/microcode/aic7xxx/aicasm.c,v retrieving revision 1.14 diff -u -r1.14 aicasm.c --- aicasm.c4 Oct 2005 23:46:14 - 1.14 +++

[resend] ipv6 support for tftp

2011-01-22 Thread Gleydson Soares
can anyone test this diff? your feedback will be most welcome On Wed, Sep 08, 2010 at 11:51:11AM -0300, Gleydson Soares wrote: hi, - ipv6 support for tftp client. based on an old itojun's diff. Index: tftpsubs.c === RCS file

ipv6 support for tftp

2010-09-08 Thread Gleydson Soares
hi, - ipv6 support for tftp client. based on an old itojun's diff. [demime 1.01d removed an attachment of type text/x-diff]

Re: ipv6 support for tftp

2010-09-08 Thread Gleydson Soares
On Wed, Sep 08, 2010 at 11:51:11AM -0300, Gleydson Soares wrote: hi, - ipv6 support for tftp client. based on an old itojun's diff. i forgot to attach the diff inline. Index: tftpsubs.c === RCS file: /cvs/src/usr.bin/tftp

update bind/root.hint

2010-06-18 Thread Gleydson Soares
hi, sync root.hint with ftp.internic.net. - ipv6 address for i-root added - remove extra spaces in k-root and l-root Index: root.hint === RCS file: /cvs/src/etc/bind/root.hint,v retrieving revision 1.7 diff -u root.hint ---

libexec/tftp-proxy: should to call endpwent()

2010-06-02 Thread Gleydson Soares
endpwent() here to close file descriptor opened by getpwnam(), since that all work with the password database was done. Index: tftp-proxy.c === RCS file: /cvs/src//libexec/tftp-proxy/tftp-proxy.c,v retrieving revision 1.6 diff -u

Re: which ISO for a VM?

2010-04-06 Thread Gleydson Soares
On Mon, Apr 5, 2010 at 11:38 AM, Sean Kennedy woodentu...@hotmail.com wrote: I concur, it was a Valid question on running OpenBSD in a VM. really, i was very radical in the last email. really. shut it up and hack. maybe starting helping the virtualbox guys to close the related bug at

Re: which ISO for a VM?

2010-04-03 Thread Gleydson Soares
virtualize your brain. it is nice. On Fri, Apr 2, 2010 at 6:23 AM, Zachary Uram net...@gmail.com wrote: I have never run OpenBSD before and want to try it out. Wondering if there is an ISO I can run in VirtualBox? If not what is the recommended method for users who wish to run OpenBSD in

Re: if_loop

2010-01-08 Thread Gleydson Soares
On Fri, Jan 8, 2010 at 9:15 PM, Claudio Jeker cje...@diehard.n-r-g.com wrote: On Fri, Jan 08, 2010 at 01:06:03AM -0300, Gleydson Soares wrote: i guess that if ifp might be bpf attached in loop_clone_create() it should be detached case destroyed. Index: if_loop.c