Re: MPLS: mpls_do_error() cleanup

2018-12-25 Thread Denis Fondras
On Tue, Dec 25, 2018 at 06:47:27PM -0200, Martin Pieuchot wrote: > > Index: netinet/ip_icmp.c > > === > > RCS file: /cvs/src/sys/netinet/ip_icmp.c,v > > retrieving revision 1.181 > > diff -u -p -r1.181 ip_icmp.c > > ---

Kill usb_fill_di_task()

2018-12-25 Thread Martin Pieuchot
usbd_fill_deviceinfo() does not generate any I/O so there's no need to call it from a USB thread. So the diff below kills usb_fill_di_task(). While here do not skip USB devices without attached drivers. If you disable ugen(4) in your kernel they are properly handled. usbdevs(8) will simply not

Re: nanosleep(2): don't tsleep(9) if timeout is empty

2018-12-25 Thread Scott Cheloha
On Tue, Dec 25, 2018 at 11:24:54PM +0100, Mark Kettenis wrote: > > Date: Tue, 25 Dec 2018 09:31:25 -0500 > > From: Scott Cheloha > > > > On Tue, Dec 25, 2018 at 02:19:46PM +0100, Mark Kettenis wrote: > > > > Date: Mon, 24 Dec 2018 16:28:20 -0500 > > > > From: Scott Cheloha > > > > > > > > ok?

iSerialNumber -> serial

2018-12-25 Thread Martin Pieuchot
Simple change to have verbose USB device fit into 80 chars in usbdevs(8): Before == $ usbdevs -v addr 04: 0b95:1790 ASIX Elec. Corp., AX88179 high speed, power 248 mA, config 1, rev 1.00, iSerialNumber 133B8B1B30 driver: axen0

[DIFF] sys/net/bridgectl.c

2018-12-25 Thread Holger Mikolon
Hi tech@, I tried to understand the output of "ifconfig bridge0 addr", especially the "magic number" after the interface name. Apparently it indicates the aging of the entry (the value is only ever 0 or 1). Eventually I looked at the aging cycle code in bridge_rtage() and wondered why there are 3

patch: minor comment tyop in xserver

2018-12-25 Thread leo_tck
See below. Bit hasty, weren't we? :P --zeur. Index: xenocara/xserver/hw/xfree86/os-support/bsd/bsd_init.c === RCS file: /cvs/xenocara/xserver/hw/xfree86/os-support/bsd/bsd_init.c,v retrieving revision 1.21 diff -u -p -r1.21

sys/crypto & free(9) sizes

2018-12-25 Thread Martin Pieuchot
ok? Index: crypto/cryptosoft.c === RCS file: /cvs/src/sys/crypto/cryptosoft.c,v retrieving revision 1.84 diff -u -p -r1.84 cryptosoft.c --- crypto/cryptosoft.c 31 May 2018 19:40:58 - 1.84 +++ crypto/cryptosoft.c 29 Nov 2018

Re: nanosleep(2): don't tsleep(9) if timeout is empty

2018-12-25 Thread Mark Kettenis
> Date: Tue, 25 Dec 2018 09:31:25 -0500 > From: Scott Cheloha > > On Tue, Dec 25, 2018 at 02:19:46PM +0100, Mark Kettenis wrote: > > > Date: Mon, 24 Dec 2018 16:28:20 -0500 > > > From: Scott Cheloha > > > > > > ok? > > > > How can this happen? Only if the user asks to sleep for exactly 0ns.

uhub(4) w/o usbd_device2interface_handle()

2018-12-25 Thread Martin Pieuchot
Now that almost all USB drivers match a properly configured device, we can simplify them. Instead of calling usbd_device2interface_handle() simply use the `iface' argument passed to the *attach() function. This works well in uhub(4) because the interface 0 of the first configuration is always

Re: nanosleep(2): don't tsleep(9) if timeout is empty

2018-12-25 Thread Ted Unangst
Scott Cheloha wrote: > I might have a winner already, though. Earlier today I saw iridium busy > sleeping: repeat nanosleeps with zero'd timespec structs. I have a ktrace > here, but I have yet to reproduce. Need to fuss with it a bit more. > > fwiw, here's an exerpt: > > 90240/241378

Re: Please test: HZ bump

2018-12-25 Thread Mike Larkin
On Tue, Dec 25, 2018 at 06:37:03PM -0200, Martin Pieuchot wrote: > On 24/12/18(Mon) 20:07, Scott Cheloha wrote: > > On Tue, Dec 18, 2018 at 03:39:43PM -0600, Ian Sutton wrote: > > > On Mon, Aug 14, 2017 at 3:07 PM Martin Pieuchot wrote: > > > > > > > > I'd like to improve the fairness of the

wscons patches for many ttys (1/8)

2018-12-25 Thread leo_tck
This patch changes the names for emulated ttys from tty[C-J][0-9a-f] to tty[C-J]{0..254}. 255 is reserved for the cfg device and thus cannot currently be used. This enables consistent addressing for all emulated ttys, and is not unexpected to hit bits here and there; it is also a visible change,

wscons patches for many ttys (6/8)

2018-12-25 Thread leo_tck
These patches seperate the screen command keysyms into their own group, so that the full address range (minus that pesky 255) can be used, in conjunction with the MAKEDEV and ttys patches. Applies on top of the small wskbd patch, and the factual wsdisplay(4) patch. This affects the kernel and

patch: fix w(1) heading

2018-12-25 Thread leo_tck
I noticed I broke w(1) with my previous patch set: the 'TTY' column is no longer large enough. The below patch increases it in size by two characters, an also gives the 'USER' field an extra character, fixing an apparently existing wrong offset for the 'TTY' one. --zeurkous. Index:

Re: MPLSv6 1/2: kernel diff

2018-12-25 Thread Denis Fondras
On Mon, Dec 24, 2018 at 08:43:10PM -0200, Martin Pieuchot wrote: > On 24/12/18(Mon) 17:31, Denis Fondras wrote: > > Index: net/if_ethersubr.c > > === > > RCS file: /cvs/src/sys/net/if_ethersubr.c,v > > retrieving revision 1.256 > >

wscons patches for many ttys (0/8)

2018-12-25 Thread leo_tck
This patch enables the specification of WSDISPLAY_MAXSCREEN as an option in a config(8) file. Without, a multiple-definition error is thrown. This patch is expected to affect only the kernel, and then only at config(8) time. Index: src/sys/dev/wscons/wsdisplayvar.h

wscons patches for many ttys (2/8)

2018-12-25 Thread leo_tck
These patches fix up ttys(5) after the MAKEDEV change. Shouldn't this be moved into a seperate file, as per ttys.pty? Index: src/etc/etc.amd64/ttys === RCS file: /cvs/src/etc/etc.amd64/ttys,v retrieving revision 1.2 diff -u -p -r1.2

wscons patches for many ttys (5/8)

2018-12-25 Thread leo_tck
This patch somewhat generalizes the screen cmd keysym detection. It does depend on the relevant keysyms being contigious, though, but that shouldn't be a problem. Index: src/sys/dev/wscons/wskbd.c === RCS file:

wscons patches for many ttys (7/8)

2018-12-25 Thread leo_tck
These patches add a 'HiFn' keysym, useful in cases where F{13..24} input is desired and no suitable kbd is present. If, in opposition to some of the bolder statements below, it turns out to be trivial to fix the Cmd& issue, I'll gladly eat the words concerned :) Oh, and the reason I put the

wscons patches for many ttys (8/8)

2018-12-25 Thread leo_tck
These final patches add a second set of Cmd keysyms, that for now have one effect: add 128 to the screen index when a screen switch is commanded. Applies on top of the previous patches. Together with HiFn, this allows addressing of 48 emulated terminals using the three 'windoze' keys on a

wscons patches for many ttys (3/8)

2018-12-25 Thread leo_tck
Irrespective of the other patches, I believe this one should certainly be applied, as it corrects a factual error. Index: src/share/man/man4/wsdisplay.4 === RCS file: /cvs/src/share/man/man4/wsdisplay.4,v retrieving revision 1.53

wscons patches for many ttys (4/8)

2018-12-25 Thread leo_tck
Manual patch to go with the MAKEDEV and ttys patches. Applies on top of the factual patch. --- src/share/man/man4/wsdisplay.4.orig Mon Dec 24 06:25:42 2018 +++ src/share/man/man4/wsdisplay.4 Mon Dec 24 06:27:28 2018 @@ -27,7 +27,9 @@ .\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF

patch: fix rc(8) wsconsctl invocation

2018-12-25 Thread leo_tck
The following completely plausible: keyboard1.map+=keycode 101=HiFn in the wsconsctl.conf(5) file is not passed to wsconsctl(8) intact, leading to syntax errors being reported by the latter (and the requested action not being taken). The below patch fixes this by replacing the apparent UUOE

patch: rc(8) pass args to rc.local(8)

2018-12-25 Thread leo_tck
rc(8) does not pass its arguments to rc.local(8); this makes the latter unable to check for the 'autoboot' or 'shutdown' args. Patch below fixes this by simply passing the arguments. --zeurkous. Index: src/etc/rc === RCS

tcpdump, add SNMPv3 support

2018-12-25 Thread Martijn van Duren
Here's a diff to add SNMPv3 support to tcpdump. To get more information I decided to put to asn1_parse hex output under -vv and add additional information under -v, while keeping the plain output the same. OK? martijn@ Index: print-snmp.c

Re: Please test: HZ bump

2018-12-25 Thread Henri Kemppainen
> And then... can we reduce wakeup latency in general without raising HZ? Other > systems (e.g. DFly) have better wakeup latencies and still have HZ=100. What > are they doing? Can we borrow it? https://frenchfries.net/paul/dfly/nanosleep.html OpenBSD is still adding that one tick which

pfctl/pf.conf: remove "load anchor" support

2018-12-25 Thread Klemens Nanni
>From pf.conf(5): The anchor can also be populated by adding a load anchor rule after the anchor rule. When pfctl(8) loads pf.conf, it will also load all the rules from the file /etc/pf-spam.conf into the anchor. anchor spam load anchor

Re: pfctl/pf.conf: remove "load anchor" support

2018-12-25 Thread Sebastian Benoit
Klemens Nanni(k...@openbsd.org) on 2018.12.25 17:33:00 +0100: > From pf.conf(5): > > The anchor can also be populated by adding a load anchor rule after the > anchor rule. When pfctl(8) loads pf.conf, it will also load all the > rules from the file /etc/pf-spam.conf into the

Re: pfctl/pf.conf: remove "load anchor" support

2018-12-25 Thread Theo de Raadt
>When that commit was done in 2016, there should have been a commit to >current.html telling people tochange syntax. Both as a warning of a upcoming >change and as a reminder for us to remove the old syntax after release >(6.0?). I have always disliked the reliance on include, because errors

Re: pfctl/pf.conf: remove "load anchor" support

2018-12-25 Thread Sebastian Benoit
Sebastian Benoit(be...@openbsd.org) on 2018.12.25 18:13:27 +0100: > Klemens Nanni(k...@openbsd.org) on 2018.12.25 17:33:00 +0100: > > From pf.conf(5): > > > > The anchor can also be populated by adding a load anchor rule after the > > anchor rule. When pfctl(8) loads pf.conf, it will

Re: nanosleep(2): don't tsleep(9) if timeout is empty

2018-12-25 Thread Scott Cheloha
On Tue, Dec 25, 2018 at 02:19:46PM +0100, Mark Kettenis wrote: > > Date: Mon, 24 Dec 2018 16:28:20 -0500 > > From: Scott Cheloha > > > > ok? > > How can this happen? Only if the user asks to sleep for exactly 0ns. > That is a bit nonsensical. Currently we punish such a process by > making it

Re: nanosleep(2): don't tsleep(9) if timeout is empty

2018-12-25 Thread Mark Kettenis
> Date: Mon, 24 Dec 2018 16:28:20 -0500 > From: Scott Cheloha > > ok? How can this happen? Only if the user asks to sleep for exactly 0ns. That is a bit nonsensical. Currently we punish such a process by making it sleep. Which means that other processes can run. Why do you want to change

Re: change nc(1) port range delimiter

2018-12-25 Thread Daniel Jakots
On Sat, 22 Dec 2018 19:29:01 -0500, "Ted Unangst" wrote: > Stuart Henderson wrote: > > But I can't imagine scanning a range by name as being much used > > (tcpmux-socks or something just doesn't make sense). > > > > What I think would be least disruptive is to continue to allow - > > where the

Re: MPLSv6 1/2: kernel diff

2018-12-25 Thread Martin Pieuchot
On 25/12/18(Tue) 10:25, Denis Fondras wrote: > On Mon, Dec 24, 2018 at 08:43:10PM -0200, Martin Pieuchot wrote: > > On 24/12/18(Mon) 17:31, Denis Fondras wrote: > > > Index: net/if_ethersubr.c > > > === > > > RCS file:

Re: MPLSv6 1/2: kernel diff

2018-12-25 Thread Denis Fondras
On Tue, Dec 25, 2018 at 04:50:17PM -0200, Martin Pieuchot wrote: > On 25/12/18(Tue) 10:25, Denis Fondras wrote: > > On Mon, Dec 24, 2018 at 08:43:10PM -0200, Martin Pieuchot wrote: > > > On 24/12/18(Mon) 17:31, Denis Fondras wrote: > > > > Index: net/if_ethersubr.c > > > >

MPLS: mpls_do_error() cleanup

2018-12-25 Thread Denis Fondras
On Mon, Dec 24, 2018 at 08:43:10PM -0200, Martin Pieuchot wrote: > It would be great if you could think the IPv4 version as well to take > a 'struct sockaddr' argument instead of a `struct in_ifaddr'. > Here is a diff to convert "struct in_ifaddr" to "struct sockaddr" Index: netinet/ip_icmp.c

Re: pfctl/pf.conf: remove "load anchor" support

2018-12-25 Thread Klemens Nanni
On Tue, Dec 25, 2018 at 10:19:35AM -0700, Theo de Raadt wrote: > I have always disliked the reliance on include, because errors detected > during parse are poorly handled. Garbage format in the file will adjust > the global scope and the parser is clueless to cope well. Can you elaborate on this?

Re: Please test: HZ bump

2018-12-25 Thread Martin Pieuchot
On 24/12/18(Mon) 20:07, Scott Cheloha wrote: > On Tue, Dec 18, 2018 at 03:39:43PM -0600, Ian Sutton wrote: > > On Mon, Aug 14, 2017 at 3:07 PM Martin Pieuchot wrote: > > > > > > I'd like to improve the fairness of the scheduler, with the goal of > > > mitigating userland starvations. For that

Re: MPLSv6 1/2: kernel diff

2018-12-25 Thread Martin Pieuchot
On 25/12/18(Tue) 20:05, Denis Fondras wrote: > On Tue, Dec 25, 2018 at 04:50:17PM -0200, Martin Pieuchot wrote: > > On 25/12/18(Tue) 10:25, Denis Fondras wrote: > > > On Mon, Dec 24, 2018 at 08:43:10PM -0200, Martin Pieuchot wrote: > > > > On 24/12/18(Mon) 17:31, Denis Fondras wrote: > > > > >

Re: MPLS: mpls_do_error() cleanup

2018-12-25 Thread Martin Pieuchot
On 25/12/18(Tue) 21:16, Denis Fondras wrote: > On Mon, Dec 24, 2018 at 08:43:10PM -0200, Martin Pieuchot wrote: > > It would be great if you could think the IPv4 version as well to take > > a 'struct sockaddr' argument instead of a `struct in_ifaddr'. > > > > Here is a diff to convert "struct

Re: pfctl/pf.conf: remove "load anchor" support

2018-12-25 Thread Klemens Nanni
On Tue, Dec 25, 2018 at 07:19:21PM +0100, Sebastian Benoit wrote: > that said, if we want this, we might want to have pfctl print a warning for > a release cycle because it can impact the reachability of a machine. Like we > do with ifconfig vlanid/parent changes. Keep the behaviour in 6.4