Re: use tasks and a task_list to manage if_linkstatehooks

2019-11-06 Thread David Gwynne
On Wed, Nov 06, 2019 at 03:12:27PM +1000, David Gwynne wrote: > this is a follow-up to "use tasks and a task_list to manage > if_detachhooks" and converts the link state hooks to a task_list > with pre-allocated tasks. > > it's mostly mechanical, except for carp. each carp interface has a link >

sysupgrade: Allow to use another directory for the sets

2019-11-06 Thread Renaud Allard
Hello, Given the amount of people which encrypt /home directory on their servers, it might be useful to be able to define another directory for the sets in sysupgrade as /home_sysupgrade will not be available in that case. Here is a patch for this. Regards Index: sysupgrade.8

Re: slaacd(8): remove address / default route proposals

2019-11-06 Thread Tobias Heider
Great! I will run some tests with the diff. One thing I noticed: > @@ -1982,11 +1941,8 @@ gen_address_proposal(struct slaacd_iface *iface, > struct radv *ra, struct > > gen_addr(iface, prefix, addr_proposal, privacy); > > - tv.tv_sec = 0; > - tv.tv_usec = 0; > -

ctfconv/DWARF & clang static variables

2019-11-06 Thread Martin Pieuchot
When a static variable is defined in a function, clang(1) emits the following DWARF: <1><90>: Abbrev Number: 9 (DW_TAG_subprogram) DW_AT_name: (indirect string, offset: 0x213b): pageflttrap [...] <2>: Abbrev Number: 10 (DW_TAG_variable) DW_AT_name: (indirect

tcpdump(8) mention USB interfaces in -i

2019-11-06 Thread Stuart Henderson
Found this diff when updating an old tree, ok? Index: usr.sbin/tcpdump/tcpdump.8 === RCS file: /cvs/src/usr.sbin/tcpdump/tcpdump.8,v retrieving revision 1.108 diff -u -p -r1.108 tcpdump.8 --- usr.sbin/tcpdump/tcpdump.8 31 Oct 2019

Re: _pbuild user to have priority=5

2019-11-06 Thread Marc Espie
On Sat, Nov 02, 2019 at 02:35:28PM +0100, Solene Rapenne wrote: > On Sat, Nov 02, 2019 at 01:18:53PM +, Stuart Henderson wrote: > > On 2019/11/01 19:16, Theo de Raadt wrote: > > > Ted Unangst wrote: > > > > > > > Theo de Raadt wrote: > > > > > What about all the other users who aren't in

Re: relayd(8): transparent forward

2019-11-06 Thread mp1009
On 2019-11-06 08:25, Stuart Henderson wrote: On 2019/11/05 20:46, Mischa Peters wrote: When you are using transparent (Direct Server Return) you have to make sure you disable ARP on the servers you are load balancing. Transparent is not "direct server return", that is done with "route

ANSIfy & un-boolean_t alpha ddb(4)

2019-11-06 Thread Martin Pieuchot
ok? Index: arch/alpha/alpha/db_disasm.c === RCS file: /cvs/src/sys/arch/alpha/alpha/db_disasm.c,v retrieving revision 1.23 diff -u -p -r1.23 db_disasm.c --- arch/alpha/alpha/db_disasm.c27 Apr 2016 11:03:24 - 1.23 +++

un-boolean_t ddb(4) for arm64 & mips64

2019-11-06 Thread Martin Pieuchot
Ok? Index: arch/arm64/arm64/db_disasm.c === RCS file: /cvs/src/sys/arch/arm64/arm64/db_disasm.c,v retrieving revision 1.1 diff -u -p -r1.1 db_disasm.c --- arch/arm64/arm64/db_disasm.c17 Dec 2016 23:38:33 - 1.1 +++

Re: [rpki-client] Patch submission (tal.c)

2019-11-06 Thread Claudio Jeker
On Tue, Nov 05, 2019 at 01:57:09PM -0300, Alexandre Hamada wrote: > Hi Claudio. > > FYI, I've added some support for https. Not sure if this might be useful, > but here is the code for ta_parse_buffer. > > I´ve also modified tal_parse to display a warn message instead of exiting on > invalid

Re: ntpd is too noisy about 'DNS lookup tempfail' on IPv6 only hosts

2019-11-06 Thread Peter J. Philipp
On Wed, Nov 06, 2019 at 11:30:32AM +0100, Florian Obser wrote: > > @@ -94,7 +95,7 @@ host_dns1(const char *s, struct ntp_addr > > struct ntp_addr *h, *hh = NULL; > > > > memset(, 0, sizeof(hints)); > > - hints.ai_family = AF_UNSPEC; > > + hints.ai_family = (test_v4_gw() == 0)

Re: ntpd is too noisy about 'DNS lookup tempfail' on IPv6 only hosts

2019-11-06 Thread Florian Obser
On Wed, Nov 06, 2019 at 08:46:16AM +0100, Peter J. Philipp wrote: > Hi, > > I have an IPv6 only host arrowhead.ip6.centroid.eu, that has very noisy: > > Oct 29 09:12:48 arrowhead ntpd[18744]: DNS lookup tempfail > Oct 29 09:21:45 arrowhead last message repeated 2 times > > in fact: > >

Re: [patch] ftp: improve SMALL and NOSSL #ifdefs

2019-11-06 Thread Jan Klemkow
Hi Hiltjo, On Wed, Nov 06, 2019 at 07:53:02PM +0100, Hiltjo Posthuma wrote: > The below patch fixes the #ifndef's for usr.bin/ftp so any combination of > SMALL > and NOSSL will compile again. Diff looks good for me and works in all ifdef combinations without any warning or error. OK jan@

Re: [patch] ftp: improve SMALL and NOSSL #ifdefs

2019-11-06 Thread Hiltjo Posthuma
On Wed, Nov 06, 2019 at 08:33:09PM +0100, Jan Klemkow wrote: > Hi Hiltjo, > > On Wed, Nov 06, 2019 at 07:53:02PM +0100, Hiltjo Posthuma wrote: > > The below patch fixes the #ifndef's for usr.bin/ftp so any combination of > > SMALL > > and NOSSL will compile again. > > Diff looks good for me and

Re: diff: simplify MGETHDR error handling in tcp_output

2019-11-06 Thread Lucas
Hello Jan, Jan Klemkow wrote: > Hi, > > the following diff simplifies the error handling of MGETHDR() in > tcp_output(). Jumps earlier to out, prevents a double check of NULL and > makes the code more readable. > > OK? > > Bye, > Jan > > Index: netinet/tcp_output.c >

Re: slaacd(8): remove address / default route proposals

2019-11-06 Thread Florian Obser
On Wed, Nov 06, 2019 at 02:47:33PM +0100, Tobias Heider wrote: > I think the tv variable should be deleted in both gen_addr_proposal > and gen_dfr_rpoposal. Right now it is unitialized and (only) used > in log_debug. thanks, fixed! -- I'm not entirely sure you are real.

db_addr_t -> vaddr_t

2019-11-06 Thread Martin Pieuchot
This type is just another way to write 'vaddr_t' and requires pulling a ddb-specific MD header for that, can't we just use vaddr_t everywhere? Diff below does the conversion in sys/kern and sys/ddb, ok? Index: kern/kern_timeout.c

diff: simplify MGETHDR error handling in tcp_output

2019-11-06 Thread Jan Klemkow
Hi, the following diff simplifies the error handling of MGETHDR() in tcp_output(). Jumps earlier to out, prevents a double check of NULL and makes the code more readable. OK? Bye, Jan Index: netinet/tcp_output.c === RCS file:

Re: db_addr_t -> vaddr_t

2019-11-06 Thread Theo de Raadt
Makes sense. Some strange CMUism. Martin Pieuchot wrote: > This type is just another way to write 'vaddr_t' and requires pulling a > ddb-specific MD header for that, can't we just use vaddr_t everywhere? > > Diff below does the conversion in sys/kern and sys/ddb, ok? > > Index:

Re: slaacd(8): remove address / default route proposals

2019-11-06 Thread Tobias Heider
Testing hasn't shown any regressions and the diff makes sense, ok tobhe@ On Wed, Nov 06, 2019 at 04:00:34PM +0100, Florian Obser wrote: > On Wed, Nov 06, 2019 at 02:47:33PM +0100, Tobias Heider wrote: > > > I think the tv variable should be deleted in both gen_addr_proposal > > and

make 'ifconfig scan' trigger a background scan

2019-11-06 Thread Stefan Sperling
This diff allows the root user to trigger a background scan with: ifconfig iwm0 scan It supports two use cases which are currently not supported: 1) It will force an attempt at finding a better AP, even if the current AP is above the signal level threshold which will usually trigger a

[patch] ftp: improve SMALL and NOSSL #ifdefs

2019-11-06 Thread Hiltjo Posthuma
Hi, The below patch fixes the #ifndef's for usr.bin/ftp so any combination of SMALL and NOSSL will compile again. Patch: diff --git usr.bin/ftp/fetch.c usr.bin/ftp/fetch.c index 4c7e14b04bd..15927471f1a 100644 --- usr.bin/ftp/fetch.c +++ usr.bin/ftp/fetch.c @@ -201,14 +201,14 @@ url_get(const

Re: diff: simplify MGETHDR error handling in tcp_output

2019-11-06 Thread Jan Klemkow
Hi Lucas, On Wed, Nov 06, 2019 at 08:28:43PM +, Lucas wrote: > Jan Klemkow wrote: > > the following diff simplifies the error handling of MGETHDR() in > > tcp_output(). Jumps earlier to out, prevents a double check of NULL and > > makes the code more readable. > > > > OK? > > > > Bye, > >