[U-Boot] [PATCH 01/17] Introduce netdev.h header file and remove externs

2008-08-31 Thread Ben Warren
This addresses all drivers whose initializers have already been moved to board_eth_init()/cpu_eth_init(). Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/atmel/atngw100/atngw100.c |3 +- board/atmel/atstk1000/atstk1000.c |3 +- board/bf537-stamp/bf537-stamp.c

[U-Boot] [PATCH 03/17] Moved initialization of RTL8169 Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: linkstation r7780mp Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/linkstation/linkstation.c |6 ++ board/r7780mp/r7780mp.c |6 ++ include/netdev.h|4

[U-Boot] [PATCH 04/17] Moved initialization of RTL8139 Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: hidden_dragon MPC8544DS MPC8610HPCN R2DPLUS TB0229 Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/freescale/mpc8544ds/mpc8544ds.c |8

[U-Boot] [PATCH 07/17] Moved initialization of NATSEMI Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: a3000 Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/a3000/a3000.c |7 +++ include/netdev.h|4 net/eth.c |4 3 files changed, 11 insertions(+), 4 deletions(-) diff --git

[U-Boot] [PATCH 09/17] Moved initialization of GT6426x Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: EVB64260 P3G4 ZUMA Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/evb64260/evb64260.c |8 +++- include/netdev.h |1 + net/eth.c |7 --- 3 files

[U-Boot] [PATCH 10/17] Moved initialization of 3COM Ethernet controller (AmigaOne) to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: AmigaOneG3SE Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/MAI/AmigaOneG3SE/AmigaOneG3SE.c |9 + include/netdev.h |1 + net/eth.c |4

[U-Boot] [PATCH 11/17] Moved initialization of IncaIP Ethernet controller to board_eth_init

2008-08-31 Thread Ben Warren
Affected boards: IncaIP Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/incaip/incaip.c|8 drivers/net/inca-ip_sw.c |2 +- include/netdev.h |1 + net/eth.c|4 4 files

[U-Boot] [PATCH 12/17] Moved initialization of MPC512x_FEC Ethernet driver to CPU directory

2008-08-31 Thread Ben Warren
Added a cpu_eth_init() function to MPC512x CPU directory and removed code from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- cpu/mpc512x/cpu.c | 13 + cpu/mpc5xxx/cpu.c | 13 + include/netdev.h |2 ++ net/eth.c |4 4 files changed, 28

[U-Boot] [PATCH 13/17] Moved initialization of MPC5xxx_FEC Ethernet driver to CPU directory

2008-08-31 Thread Ben Warren
Modified board_eth_init() functions of boards that have this FEC in addition to other Ethernet controllers. Affected boards: bc3450 icecube mvbc_p o2dnt pm520 total5200 tq5200 Removed initialization of controller from net/eth.c

[U-Boot] [PATCH 14/17] Moved initialization of plb2800 Ethernet driver to board_eth_init

2008-08-31 Thread Ben Warren
Affected boards: purple Removed initialization of controller from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/purple/purple.c |9 + drivers/net/plb2800_eth.c |4 ++-- include/netdev.h |1 + net/eth.c |4 4

[U-Boot] [PATCH 15/17] Moved initialization of E1000 Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: ap1000 mvbc_p PM854 Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/amirix/ap1000/ap1000.c|7 +++ board/matrix_vision/mvbc_p/mvbc_p.c |3 ++- board/pm854/pm854.c

[U-Boot] [PATCH] sh: Remove CC line from board's Makefile

2008-08-31 Thread Nobuhiro Iwamatsu
Signed-off-by: Nobuhiro Iwamatsu [EMAIL PROTECTED] --- board/rsk7203/Makefile |3 --- board/sh7785lcr/Makefile |3 --- 2 files changed, 0 insertions(+), 6 deletions(-) diff --git a/board/rsk7203/Makefile b/board/rsk7203/Makefile index a44f9ca..7365d19 100644 ---

Re: [U-Boot] [PATCH 01/17] Introduce netdev.h header file and remove externs

2008-08-31 Thread Haavard Skinnemoen
Ben Warren [EMAIL PROTECTED] wrote: This addresses all drivers whose initializers have already been moved to board_eth_init()/cpu_eth_init(). Signed-off-by: Ben Warren [EMAIL PROTECTED] Nice. There are a few things though... --- board/atmel/atngw100/atngw100.c |3 +-

Re: [U-Boot] [PATCH 3/6] return is not a function

2008-08-31 Thread Wolfgang Denk
Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: Signed-off-by: Guennadi Liakhovetski [EMAIL PROTECTED] I don't see any need to change this code. Patch rejected. Best regards, Wolfgang Denk -- DENX Software Engineering GmbH, MD: Wolfgang Denk Detlev Zundel HRB 165235

Re: [U-Boot] [PATCH 4/6] Unify active vs. redundant environment variable naming

2008-08-31 Thread Wolfgang Denk
Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: Use consistent naming for active and redundant environment variables, remove redundant erase struct initialisation by using separate structs for the active and redundant environments. This is another sylistic change that is

Re: [U-Boot] how to support usbtty

2008-08-31 Thread mike zheng
On 8/30/08, Bryan O'Donoghue [EMAIL PROTECTED] wrote: On Fri, 29 Aug 2008 11:53:45 -0400 mike zheng [EMAIL PROTECTED] wrote: Hi Bryan, The USB/RS232 cable is a USB device, it shall has firmware in it, which works as a USB slave. What I need to do is have some code talk to this device

Re: [U-Boot] [PATCH 4/6] Unify active vs. redundant environment variable naming

2008-08-31 Thread Guennadi Liakhovetski
On Sun, 31 Aug 2008, Wolfgang Denk wrote: Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: Use consistent naming for active and redundant environment variables, remove redundant erase struct initialisation by using separate structs for the active and redundant

Re: [U-Boot] [PATCH v3] sh: Renesas R0P7785LC0011RL board support(Re: [U-Boot-Users] [PATCH v2] sh: Renesas R0P7785LC0011RL board support)

2008-08-31 Thread Jean-Christophe PLAGNIOL-VILLARD
--- /dev/null +++ b/board/sh7785lcr/Makefile @@ -0,0 +1,45 @@ +# +# Copyright (C) 2008 Yoshihiro Shimoda [EMAIL PROTECTED] +# +# This program is free software; you can redistribute it and/or +# modify it under the terms of the GNU General Public License as +# published by the Free

Re: [U-Boot] [PATCH 2/6] Separate flash read and write operations

2008-08-31 Thread Wolfgang Denk
Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: So, no, this is not because I didn't like somebody else's coding style. This is because with NAND addition this function would become an absolutely unreadable monster. So, I would consider this patch a readability

Re: [U-Boot] [PATCH 1/6] Convert fw_env.c to use a single environment image union

2008-08-31 Thread Wolfgang Denk
Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: This union replaces the typedef env_t, which was also defined in fw_env.c. Thus I was not fixing the issue you describe above, which I fully agree with - the tool and u-boot should ideally use the same definition from a

Re: [U-Boot] U-Boot Versioning

2008-08-31 Thread Luigi 'Comio' Mantellini
Il sabato 30 agosto 2008 01:12:31 Wolfgang Denk ha scritto: Dear Jerry Van Baren, In message [EMAIL PROTECTED] you wrote: Of course, we need silly alphabetical animal names for code names. Do we? No, wait, that's been done before. I know! We can use u-boat names for the code names.

Re: [U-Boot] [PATCH 5/6] Support environment anywhere within erase area

2008-08-31 Thread Guennadi Liakhovetski
On Sun, 31 Aug 2008, Wolfgang Denk wrote: Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: This will become more important with NAND support, in which case the minimum erase region is a block, which consists of several pages and can be 256KiB large. Please explain.

Re: [U-Boot] [PATCH 2/6] Separate flash read and write operations

2008-08-31 Thread Guennadi Liakhovetski
On Sun, 31 Aug 2008, Wolfgang Denk wrote: Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: So, no, this is not because I didn't like somebody else's coding style. This is because with NAND addition this function would become an absolutely unreadable monster. So,

Re: [U-Boot] [PATCH 4/6] Unify active vs. redundant environment variable naming

2008-08-31 Thread Wolfgang Denk
Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: Would it suffice to change the patch description for this patch to be accepted, or do you still want this patch to be dropped / changes? We could use fdcur, fdtrg, devcur, devtrg, erasecur, erasetrg to save the typing,

Re: [U-Boot] [PATCH 5/6] Support environment anywhere within erase area

2008-08-31 Thread Wolfgang Denk
Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: Erase area - this is all we erase, as opposed to one erase sector. On NOR this is limited by the environment size, on NAND by the number of blocks - the fifth parameter in the configuration file. This area may contain

Re: [U-Boot] [PATCH 0/6] Support NAND in fw_printenv/fw_setenv

2008-08-31 Thread Guennadi Liakhovetski
On Sun, 31 Aug 2008, Wolfgang Denk wrote: Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: What follows is a patch series to support NAND environment under Linux, including bad blocks. In principle, this is just one logical change, but it is a big one... So I split

Re: [U-Boot] [PATCH 6/6] Support environment in NAND

2008-08-31 Thread Guennadi Liakhovetski
On Sun, 31 Aug 2008, Wolfgang Denk wrote: Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: --- a/tools/env/fw_env.c +++ b/tools/env/fw_env.c @@ -44,6 +44,12 @@ #defineCMD_GETENV fw_printenv #defineCMD_SETENV fw_setenv +#define min(x, y)

Re: [U-Boot] [GIT PULL] Please pull coldfire tree

2008-08-31 Thread Wolfgang Denk
Dear John Rigby, In message [EMAIL PROTECTED] you wrote: Wolfgang, Resend, wrong subject in previous email The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4: Wolfgang Denk (1): Merge branch 'master' of /home/wd/git/u-boot/custodians are available

Re: [U-Boot] [GIT PULL] Please pull mpc5xxx tree

2008-08-31 Thread Wolfgang Denk
Dear John Rigby, In message [EMAIL PROTECTED] you wrote: Wolfgang, The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4: Wolfgang Denk (1): Merge branch 'master' of /home/wd/git/u-boot/custodians are available in the git repository at:

Re: [U-Boot] [PATCH rev2] ADS5121: Fix NOR and CPLD ALE timing for rev 2 silicon

2008-08-31 Thread Wolfgang Denk
Dear John Rigby, In message [EMAIL PROTECTED] you wrote: MPC5121 rev 2 silicon has a new register for controlling how long CS is asserted after deassertion of ALE in multiplexed mode. The default is to assert CS together with ALE. The alternative is to assert CS (ALEN+1)*LPC_CLK clocks

Re: [U-Boot] u-boot-arm pull request

2008-08-31 Thread Wolfgang Denk
Dear Jean-Christophe PLAGNIOL-VILLARD, In message [EMAIL PROTECTED] you wrote: Hi Wolfgang, please pull The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4: Wolfgang Denk (1): Merge branch 'master' of /home/wd/git/u-boot/custodians are available in the

Re: [U-Boot] Makefile Pull Request

2008-08-31 Thread Wolfgang Denk
Dear Jean-Christophe PLAGNIOL-VILLARD, In message [EMAIL PROTECTED] you wrote: The following changes since commit 33aa4eac66b71c797bbc13b3afe432a2132947d4: Wolfgang Denk (1): Merge branch 'master' of /home/wd/git/u-boot/custodians are available in the git repository at:

Re: [U-Boot] [PATCH 7/7 v7] ARM: Add support for S3C6400 based SMDK6400 board

2008-08-31 Thread Wolfgang Denk
Dear Guennadi Liakhovetski, In message [EMAIL PROTECTED] you wrote: SMDK6400 can only boot U-Boot from NAND-flash. This patch adds a nand_spl driver for it too. The board can also boot from the NOR flash, but due to hardware limitations it can only address 64KiB on it, which is not enough for

[U-Boot] [PATCH 1/1] ap325rxa/favr-32-ezkit: Use CONFIG_FLASH_CFI_DRIVER

2008-08-31 Thread Jean-Christophe PLAGNIOL-VILLARD
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD [EMAIL PROTECTED] --- include/configs/ap325rxa.h |2 +- include/configs/favr-32-ezkit.h |2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/include/configs/ap325rxa.h b/include/configs/ap325rxa.h index 81a118d..3db609b

Re: [U-Boot] [PATCH 1/6] tsec: Move tsec.h to include/

2008-08-31 Thread Ben Warren
Andy Fleming wrote: This is to prepare the way for board code passing in the tsec_info structure Signed-off-by: Andy Fleming [EMAIL PROTECTED] --- Thanks Andy. Nice work! Patches 1-6 applied to the net tree. regards, Ben ___ U-Boot mailing list

[U-Boot] [PATCH v2 02/17] Moved initialization of Ethernet controllers on Atmel AT91 to board_eth_init()

2008-08-31 Thread Ben Warren
Removed at91sam9_eth_initialize() from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/atmel/at91cap9adk/at91cap9adk.c | 11 + board/atmel/at91sam9260ek/at91sam9260ek.c | 11 + board/atmel/at91sam9263ek/at91sam9263ek.c | 11 +

[U-Boot] [PATCH v2 01/17] Introduce netdev.h header file and remove externs

2008-08-31 Thread Ben Warren
This addresses all drivers whose initializers have already been moved to board_eth_init()/cpu_eth_init(). Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/atmel/atngw100/atngw100.c |3 +- board/atmel/atstk1000/atstk1000.c|3 +-

[U-Boot] [PATCH v2 03/17] Moved initialization of RTL8169 Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: linkstation r7780mp Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/linkstation/linkstation.c |6 ++ board/r7780mp/r7780mp.c |6 ++ drivers/net/rtl8169.c |1 +

[U-Boot] [PATCH v2 04/17] Moved initialization of RTL8139 Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: hidden_dragon MPC8544DS MPC8610HPCN R2DPLUS TB0229 Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] --- board/freescale/mpc8544ds/mpc8544ds.c |8

[U-Boot] [PATCH v2 06/17] Moved initialization of NS8382X Ethernet controller to board_eth_init()

2008-08-31 Thread Ben Warren
Affected boards: bc3450 cpci5200 mecp5200 pf2000 icecube o2dnt pm520 sandpoint8245 total5200 tqm5200 Removed initialization of the driver from net/eth.c Signed-off-by: Ben Warren [EMAIL PROTECTED] ---