Re: [U-Boot] [PATCH v2] drivers: usb: fsl-dt-fixup: Fix the dt for multiple USB nodes in single traversal of device tree

2016-09-16 Thread Sriram Dash
>From: Marek Vasut [mailto:ma...@denx.de] >On 09/16/2016 10:47 AM, Sriram Dash wrote: >>> From: Marek Vasut [mailto:ma...@denx.de] On 09/15/2016 12:29 AM, york >>> sun wrote: On 09/14/2016 02:35 PM, Marek Vasut wrote: > On 09/14/2016 07:22 AM, Sriram Dash wrote: >>> From: Sriram Dash

Re: [U-Boot] [PATCH] image-fit: switch ENOLINK to ENOENT

2016-09-16 Thread Mario Six
Hi Jonathan On Thu, Sep 15, 2016 at 11:27 PM, Jonathan Gray wrote: > > The callers of the proposed/rejected kwboot.c errno diff were all > checked but the test of the result in the caller of this one > seems to have been missed indeed. > > Sorry for missing this and > >

[U-Boot] [PATCH] x86: baytrail: Add 2nd eMMC controller to the PCI probe list

2016-09-16 Thread Stefan Roese
With this addition, the eMMC device available on the congatec and DFI BayTrail SoM is detected correctly. Signed-off-by: Stefan Roese Cc: Simon Glass Cc: Bin Meng --- arch/x86/cpu/baytrail/valleyview.c | 1 + include/pci_ids.h

[U-Boot] [PATCH] image: Fix expected return value

2016-09-16 Thread Mario Six
Commit bac17b7 ("image-fit: switch ENOLINK to ENOENT") changed the return value of fit_get_node_from_config from ENOLINK to ENOENT. This causes a problem in boot_get_ramdisk, which treats the return value -ENOLINK differently from other errors (namely, it does not signal a failure if -ENOLINK is

[U-Boot] [PATCH 2/2] usb: fsl: Renaming fdt_fixup_erratum and fdt_fixup_usb_erratum

2016-09-16 Thread Sriram Dash
The functions fdt_fixup_erratum and fdt_fixup_usb_erratum are fsl/nxp specific. So, make them explicit by renaming them fsl_fdt_fixup_erratum and fsl_fdt_fixup_usb_erratum Signed-off-by: Sriram Dash --- drivers/usb/common/fsl-dt-fixup.c | 45

[U-Boot] [RFC PATCH] arm, Makefile: set SPL_PAYLOAD according to the SoC architecture

2016-09-16 Thread Raghav Dogra
SPL_PAYLOAD should be .img in case of ARM architecture and .bin in case of other architectures. This patch takes care of the same by choosing the SPL_PAYLOAD as u-boot.img for ARM architecture and u-boot.bin for others. Signed-off-by: Raghav Dogra --- Makefile | 3 +++ 1

[U-Boot] [PATCH 0/2] Renaming the fsl/nxp specific functions

2016-09-16 Thread Sriram Dash
The functions fdt_fixup_dr_usb, fdt_fixup_erratum and fdt_fixup_usb_erratum are renamed to fsl_fdt_fixup_dr_usb, fsl_fdt_fixup_erratum and fsl_fdt_fixup_usb_erratum respectively.This makes more sense as these are not generic functions. Sriram Dash (2): usb: fsl: Rename fdt_fixup_dr_usb usb:

[U-Boot] [PATCH 1/2] usb: fsl: Rename fdt_fixup_dr_usb

2016-09-16 Thread Sriram Dash
The function fdt_fixup_dr_usb is specific to fsl/nxp. So, make the function name explicit and rename fdt_fixup_dr_usb into fsl_fdt_fixup_dr_usb. Signed-off-by: Sriram Dash --- board/Arcturus/ucp1020/ucp1020.c| 2 +- board/freescale/b4860qds/b4860qds.c |

Re: [U-Boot] [PATCH] ARM: Add register defines for am33xx ePWM registers

2016-09-16 Thread tomas.melin
On 09/16/2016 02:16 PM, Tom Rini wrote: > On Fri, Sep 16, 2016 at 10:21:39AM +, tomas.me...@vaisala.com wrote: > >> Register definitions needed for configuring the >> ePWM module. >> >> Signed-off-by: Tomas Melin >> --- >> arch/arm/include/asm/arch-am33xx/cpu.h

[U-Boot] Please pull ARC changes

2016-09-16 Thread Alexey Brodkin
Hi Tom, That's a minor change that accommodates changes in upcoming ARC GNU tools. The following changes since commit 8cbb389bb3da80cbf8911f8386cbff92c6a78afe:   Prepare v2016.09 (2016-09-12 10:05:51 -0400) are available in the git repository at:   git://git.denx.de/u-boot-arc.git  for you

Re: [U-Boot] [PATCH v2] drivers: usb: fsl-dt-fixup: Fix the dt for multiple USB nodes in single traversal of device tree

2016-09-16 Thread Sriram Dash
>From: Marek Vasut [mailto:ma...@denx.de] >On 09/15/2016 12:29 AM, york sun wrote: >> On 09/14/2016 02:35 PM, Marek Vasut wrote: >>> On 09/14/2016 07:22 AM, Sriram Dash wrote: > From: Sriram Dash [mailto:sriram.d...@nxp.com] > Hello Marek, Any comments? >>> >>> Waiting

[U-Boot] [PATCH] arc: Use -mcpu=XXX instead of obsolete -marcXXX

2016-09-16 Thread Alexey Brodkin
With newer ARC tools old way of CPU specification gets obsolete, so we're switching to newer and more common way of setting "-mcpu". Signed-off-by: Alexey Brodkin Cc: Anton Kolesov --- arch/arc/config.mk | 6 +++--- 1 file changed, 3 insertions(+),

Re: [U-Boot] [PATCH 1/2] ARM: keystone2: Add support for parsing monitor header

2016-09-16 Thread Tom Rini
On Fri, Sep 16, 2016 at 10:17:12AM +0530, Lokesh Vutla wrote: > Given that boot monitor image is being generated to a specific target location > depending on the SoC and U-boot relies on addr_mon env variable to be aligned > with boot monitor target location. When ever the target address gets

Re: [U-Boot] [PATCH 2/2] ti_armv7_keystone2: Update addr_mon variable

2016-09-16 Thread Tom Rini
On Fri, Sep 16, 2016 at 10:17:53AM +0530, Lokesh Vutla wrote: > As boot monitor contains a mkimage header, it can be loaded at any location. > So, have a common addr_mon address across all keystone2 SoCs. And also > making sure that boot monitor is installed early during default boot to > avoid

Re: [U-Boot] [PATCH] keystone2: k2g: add env script to load firmware initramfs as part of boot flow

2016-09-16 Thread Tom Rini
On Thu, Sep 15, 2016 at 07:14:32PM +0530, Lokesh Vutla wrote: > From: Murali Karicheri > > On K2G, the PCIe SerDes h/w is a re-use from other K2 devices and SerDes > driver requires a firmware image to initialize the SerDes h/w device. > This is firmware is part of the

Re: [U-Boot] [PATCH 6/6] ARM: OMAP5+: Override switch_to_hypervisor function

2016-09-16 Thread Tom Rini
On Wed, Sep 14, 2016 at 10:43:33AM +0530, Keerthy wrote: > Override the switch_to_hypervisor function to switch cpu to hypervisor > mode using the available ROM code hook early in the boot phase before > the boot loader checks for HYP mode. > > Based on the work done by Jonathan Bergsagel

Re: [U-Boot] [PATCH 4/6] configs: dra7xx_evm_defconfig: Enable LPAE mode

2016-09-16 Thread Tom Rini
On Wed, Sep 14, 2016 at 10:43:31AM +0530, Keerthy wrote: > Enable Linear Physical Address Extension mode which is a > prerequisite for hypervisor mode. > > Signed-off-by: Keerthy Reviewed-by: Tom Rini -- Tom signature.asc Description: Digital

Re: [U-Boot] [PATCH 5/6] ARM: Introduce function to switch to hypervisor mode

2016-09-16 Thread Tom Rini
On Wed, Sep 14, 2016 at 10:43:32AM +0530, Keerthy wrote: > On some of the SoCs one cannot enable hypervisor mode directly from the > u-boot because the ROM code puts the chip to supervisor mode after it > jumps to boot loader. Hence introduce a weak function which can be > overridden based on the

Re: [U-Boot] [PATCH 2/6] omap: Set appropriate cache configuration for LPAE and non-LAPE cases

2016-09-16 Thread Tom Rini
On Wed, Sep 14, 2016 at 10:43:29AM +0530, Keerthy wrote: > Cache configuration methods is different for LPAE and non-LPAE cases. > Hence the bits and the interpretaion is different for two cases. > In case of non-LPAE mode short descriptor format is used and we need > to set Cache and Buffer

Re: [U-Boot] [PATCH 1/6] omap: Remove hardcoding of mmu section shift to 20

2016-09-16 Thread Tom Rini
On Wed, Sep 14, 2016 at 10:43:28AM +0530, Keerthy wrote: > As of now the mmu section shift is hardcoded to 20 but with LPAE > coming into picture this can be different. Hence replacing 20 with > MMU_SECTION_SHIFT macro. > > Signed-off-by: Keerthy Reviewed-by: Tom Rini

Re: [U-Boot] [PATCH 3/6] configs: am57xx_evm_defconfig: Enable LPAE mode

2016-09-16 Thread Tom Rini
On Wed, Sep 14, 2016 at 10:43:30AM +0530, Keerthy wrote: > Enable Linear Physical Address Extension mode which is a > prerequisite for hypervisor mode. > > Signed-off-by: Keerthy Reviewed-by: Tom Rini -- Tom signature.asc Description: Digital

Re: [U-Boot] [PATCH] ARM: Add register defines for am33xx ePWM registers

2016-09-16 Thread Tom Rini
On Fri, Sep 16, 2016 at 10:21:39AM +, tomas.me...@vaisala.com wrote: > Register definitions needed for configuring the > ePWM module. > > Signed-off-by: Tomas Melin > --- > arch/arm/include/asm/arch-am33xx/cpu.h | 36 > ++ >

[U-Boot] [PATCH] ARM: Add register defines for am33xx ePWM registers

2016-09-16 Thread tomas.melin
Register definitions needed for configuring the ePWM module. Signed-off-by: Tomas Melin --- arch/arm/include/asm/arch-am33xx/cpu.h | 36 ++ arch/arm/include/asm/arch-am33xx/hardware_am33xx.h | 1 + 2 files changed, 37 insertions(+) diff

Re: [U-Boot] [PATCH v3] drivers: usb: xhci-fsl: Implement Erratum A-010151 for FSL USB3 controller

2016-09-16 Thread Sriram Dash
>From: Marek Vasut [mailto:ma...@denx.de] >On 09/16/2016 07:50 AM, Sriram Dash wrote: >>> From: Marek Vasut [mailto:ma...@denx.de] On 09/15/2016 08:31 AM, >>> Sriram Dash wrote: > From: Marek Vasut [mailto:ma...@denx.de] On 09/14/2016 07:15 AM, > Sriram Dash wrote: >> Currently the

Re: [U-Boot] [PATCH v3] drivers: usb: xhci-fsl: Implement Erratum A-010151 for FSL USB3 controller

2016-09-16 Thread Marek Vasut
On 09/16/2016 11:35 AM, Sriram Dash wrote: [...] >>> I agree to your point. We can set the bit from fsl specific file with >>> the function setbits_le32(fsl_xhci->dwc3_reg->g_usb3pipectl[0], >>> DWC3_GUSB3PIPECTL_DISRXDETP3); >>> If any other Soc, other than fsl/nxp wants the functionality, they

Re: [U-Boot] [PATCH v2] drivers: usb: fsl-dt-fixup: Fix the dt for multiple USB nodes in single traversal of device tree

2016-09-16 Thread Marek Vasut
On 09/16/2016 10:47 AM, Sriram Dash wrote: >> From: Marek Vasut [mailto:ma...@denx.de] >> On 09/15/2016 12:29 AM, york sun wrote: >>> On 09/14/2016 02:35 PM, Marek Vasut wrote: On 09/14/2016 07:22 AM, Sriram Dash wrote: >> From: Sriram Dash [mailto:sriram.d...@nxp.com] >> > >

[U-Boot] [PATCH] ML: SPL: NOR: Add CONFIG_SPL_NOR_COPY_ENTIRE_IMAGE define to enable whole image copy from NOR

2016-09-16 Thread Lukasz Majewski
This define gives the possibility to copy entire image (including header) from NOR parallel memory to e.g. SDRAM. The legacy behavior is preserved, since other board don't enabled this option. Signed-off-by: Lukasz Majewski --- Kconfig | 10 ++ README

Re: [U-Boot] [PATCH v3] drivers: usb: xhci-fsl: Implement Erratum A-010151 for FSL USB3 controller

2016-09-16 Thread Marek Vasut
On 09/16/2016 07:50 AM, Sriram Dash wrote: >> From: Marek Vasut [mailto:ma...@denx.de] >> On 09/15/2016 08:31 AM, Sriram Dash wrote: From: Marek Vasut [mailto:ma...@denx.de] On 09/14/2016 07:15 AM, Sriram Dash wrote: > Currently the controller by default enables the Receive Detect

Re: [U-Boot] [PATCH v3] drivers: usb: xhci-fsl: Implement Erratum A-010151 for FSL USB3 controller

2016-09-16 Thread Sriram Dash
>From: Marek Vasut [mailto:ma...@denx.de] >On 09/15/2016 08:31 AM, Sriram Dash wrote: >>> From: Marek Vasut [mailto:ma...@denx.de] On 09/14/2016 07:15 AM, >>> Sriram Dash wrote: Currently the controller by default enables the Receive Detect feature in P3 mode in USB 3.0 PHY. However, USB

Re: [U-Boot] [ANN] U-Boot v2016.09 is released

2016-09-16 Thread Michal Simek
On 15.9.2016 13:24, Tom Rini wrote: > On Wed, Sep 14, 2016 at 11:32:07PM +0200, Daniel Schwierzeck wrote: >> Hi Tom, >> >> Am 12.09.2016 um 18:21 schrieb Tom Rini: >>> >>> Another thing I'd like to call out, and ask for a little help with too >>> is automated testing. The framework in

Re: [U-Boot] [PATCH v4 3/5] regulator: fixed: honour optionality of enable gpio

2016-09-16 Thread Marcel Ziswiler
On Fri, 2016-09-16 at 09:33 +0200, Marcel Ziswiler wrote: > According to the binding documentation the fixed regulator enable > GPIO > is optional. However so far registration thereof failed if no enable > GPIO was specified. Fix this by making it entirely optional whether > an > enable GPIO is

[U-Boot] [PATCH v4 0/5] various fixes mainly for colibri_t20

2016-09-16 Thread Marcel Ziswiler
This series addresses various issues as seen on Colibri T20. Please note that for successful Ethernet operation not only on Colibri T20 but also on Colibri T30 the following patch will still be required already waiting in Marek's usb tree: [PATCH v2] net: asix: Fix ASIX 88772B with driver model

[U-Boot] [PATCH v4 1/5] tegra: usb gadget: fix ci udc operation if not hostpc capable

2016-09-16 Thread Marcel Ziswiler
The Tegra 2 aka T20 is not host PC capable. Therefore gate the define CONFIG_CI_UDC_HAS_HOSTPC in tegra-common-usb-gadget.h in case of CONFIG_TEGRA20. Signed-off-by: Marcel Ziswiler Acked-by: Stephen Warren --- Changes in v4: None Changes in

[U-Boot] [PATCH v4 5/5] colibri_t20: fix usb operation and controller order

2016-09-16 Thread Marcel Ziswiler
Without this patch the following error will be shown: Colibri T20 # usb start starting USB... No controllers found This patch fixes USB operation and also the controller order as the CI UDC driver may only be instantiated on the first aka OTG port. Signed-off-by: Marcel Ziswiler

[U-Boot] [PATCH v4 2/5] simple panel: fix spelling of debug message

2016-09-16 Thread Marcel Ziswiler
Fix spelling of debug message from cnnot to cannot. Signed-off-by: Marcel Ziswiler Acked-by: Anatolij Gustschin --- Changes in v4: None Changes in v3: None Changes in v2: - Add Anatolij's ack. drivers/video/simple_panel.c | 2 +- 1 file changed, 1

[U-Boot] [PATCH v4 3/5] regulator: fixed: honour optionality of enable gpio

2016-09-16 Thread Marcel Ziswiler
According to the binding documentation the fixed regulator enable GPIO is optional. However so far registration thereof failed if no enable GPIO was specified. Fix this by making it entirely optional whether an enable GPIO is used. Signed-off-by: Marcel Ziswiler ---

[U-Boot] [PATCH v4 4/5] colibri_t20: fix display configuration

2016-09-16 Thread Marcel Ziswiler
Without this patch the following error will be shown: stdio_add_devices: Video device failed (ret=-22) As commit ec5507707a1d1e84056a6c864338f95f6118d3ca (video: tegra: Move to using simple-panel and pwm-backlight) states the Colibri T20 needs updating too which this patch finally attempts

<    1   2