[PATCH] Change keyboard input from CrOS EC keyboard to a USB keyboard

2020-03-01 Thread Peter Robinson
These boards aren't ChromeOS devices so won't have a cros-ec-keyb input as it's the keyboard available via the ChromeOS Embedded Controller. Update them to use a USB keyboard which would actually be available. Also enable the usb keyboard option for those devices that don't have it enabled

Re: [PATCH] common: update_tftp: remove unnecessary build check

2020-03-01 Thread AKASHI Takahiro
On Mon, Mar 02, 2020 at 08:12:09AM +0100, Heinrich Schuchardt wrote: > On 3/2/20 1:11 AM, AKASHI Takahiro wrote: > > On Fri, Feb 28, 2020 at 07:26:25PM +0100, Heinrich Schuchardt wrote: > > > On 2/28/20 1:06 AM, AKASHI Takahiro wrote: > > > > Logically, the current update_tftp() should and does

RE: [PATCH] arm: socfpga: arria10: Add save_boot_params()

2020-03-01 Thread Tan, Ley Foon
> -Original Message- > From: Marek Vasut > Sent: Sunday, March 1, 2020 11:12 PM > To: Tan, Ley Foon ; u-boot@lists.denx.de > Cc: Simon Goldschmidt ; Ley Foon Tan > ; See, Chin Liang ; Chee, > Tien Fong > Subject: Re: [PATCH] arm: socfpga: arria10: Add save_boot_params() > > On 2/26/20

[GIT PULL] Xilinx fixes for v2020.04-rc4

2020-03-01 Thread Michal Simek
Hi Tom, please pull these fixes to your tree. There is one rename patch I am considering more as a fix and will be used much more in next version when I am going to remove xilinx zynq board defconfig and use generic configuration instead. Gitlab and travis look good.

Re: [PATCH] common: update_tftp: remove unnecessary build check

2020-03-01 Thread Heinrich Schuchardt
On 3/2/20 1:11 AM, AKASHI Takahiro wrote: On Fri, Feb 28, 2020 at 07:26:25PM +0100, Heinrich Schuchardt wrote: On 2/28/20 1:06 AM, AKASHI Takahiro wrote: Logically, the current update_tftp() should and does compile and work correctly even without satisfying the following condition: #if

Re: Fix for build error /uboot/driver/video/simplefb.c

2020-03-01 Thread Chris Packham
On Mon, Mar 2, 2020 at 7:25 PM ARJUN C R wrote: > > the fix still not added in git > Most likely because it's not been submitted as a proper patch. If you're keen to see it fixed have a look at http://www.denx.de/wiki/U-Boot/Patches and submit a patch to address the issue. > On Sun, Feb 2,

Re: Fix for build error /uboot/driver/video/simplefb.c

2020-03-01 Thread ARJUN C R
the fix still not added in git On Sun, Feb 2, 2020, 4:35 PM ARJUN C R wrote: > Hi, > > diff: > > --- u-boot-2020.04-rc1_new/drivers/video/simplefb.c 2020-02-02 > 16:31:57.416168719 +0530 > +++ u-boot-2020.04-rc1/drivers/video/simplefb.c 2020-01-29 > 03:29:30.0 +0530 > @@ -26,7 +26,7 @@

Re: [PATCH v5 15/33] gpio: dw: Fix warnings about casting int to pointer

2020-03-01 Thread Sean Anderson
On 3/1/20 9:27 PM, Bin Meng wrote: > Hi Sean, > > On Sat, Feb 29, 2020 at 5:06 AM Sean Anderson wrote: >> >> Explicitly cast fdt_addr_t to a void pointer, since we pass it to readl. > > Explicitly cast => Change? > > As what the patch does The compiler was giving a warning since readl

Re: [PATCH v5 15/33] gpio: dw: Fix warnings about casting int to pointer

2020-03-01 Thread Bin Meng
Hi Sean, On Sat, Feb 29, 2020 at 5:06 AM Sean Anderson wrote: > > Explicitly cast fdt_addr_t to a void pointer, since we pass it to readl. Explicitly cast => Change? As what the patch does > > Signed-off-by: Sean Anderson > --- > > Changes in v5: > - New > > drivers/gpio/dwapb_gpio.c | 4

Re: [PATCH v5 12/33] lib: Always set errno in hcreate_r

2020-03-01 Thread Bin Meng
On Sat, Feb 29, 2020 at 5:06 AM Sean Anderson wrote: > > This could give a confusing error message if it failed and didn't set > errno. > > Signed-off-by: Sean Anderson > --- > > Changes in v5: > - New > > lib/hashtable.c | 8 ++-- > 1 file changed, 6 insertions(+), 2 deletions(-) >

Re: [PATCH v5 14/33] gpio: sifive: Use generic reg read function

2020-03-01 Thread Bin Meng
On Sat, Feb 29, 2020 at 5:06 AM Sean Anderson wrote: > > Using an fdt-specific function causes problems with a live tree. > > Signed-off-by: Sean Anderson > --- > > Changes in v5: > - New > > drivers/gpio/sifive-gpio.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > Reviewed-by: Bin

Re: [PATCH v5 10/33] dm: Fix error handling for dev_read_addr_ptr

2020-03-01 Thread Bin Meng
On Sat, Feb 29, 2020 at 5:06 AM Sean Anderson wrote: > > dev_read_addr_ptr had different semantics depending on whether OF_LIVE was > enabled. This patch converts both implementations to return NULL on error, > and converts all call sites which check for FDT_ADDR_T_NONE to check for > NULL

Re: [PATCH v5 08/33] doc: Fix typo in FIT documentation

2020-03-01 Thread Bin Meng
On Sat, Feb 29, 2020 at 5:06 AM Sean Anderson wrote: > > u_boot should be u-boot > > Signed-off-by: Sean Anderson > --- > > Changes in v5: > - New > > doc/uImage.FIT/source_file_format.txt | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > Reviewed-by: Bin Meng

Re: [PATCH] efi_loader: file: set a backend block device for file operations

2020-03-01 Thread AKASHI Takahiro
On Fri, Feb 28, 2020 at 07:13:42PM +0100, Heinrich Schuchardt wrote: > On 2/28/20 1:05 AM, AKASHI Takahiro wrote: > > In the current implementation, set_blk_dev() is called in opening a file, > > but not in opening a directory. This will cause failures at succeeding > > directory operations as the

Re: [PATCH] usb: ehci: Fix "EHCI timed out on TD - token=XXXX" error on ehci-hcd

2020-03-01 Thread Marek Vasut
On 3/2/20 12:04 AM, Tom Rini wrote: [...] >>> 3 USB Device(s) found >>>scanning usb for ethernet devices... 0 Ethernet Device(s) found >>> Hit any key to stop autoboot: 2  0 >>> BeagleBoard # usb tree >>> USB device tree: >>> 1 Hub (480 Mb/s, 0mA) >>> | u-boot EHCI Host

Re: [PATCH] common: update_tftp: remove unnecessary build check

2020-03-01 Thread AKASHI Takahiro
On Fri, Feb 28, 2020 at 07:26:25PM +0100, Heinrich Schuchardt wrote: > On 2/28/20 1:06 AM, AKASHI Takahiro wrote: > > Logically, the current update_tftp() should and does compile and work > > correctly even without satisfying the following condition: > > > > > #if defined(CONFIG_UPDATE_TFTP) &&

Re: [PATCH] cmd: efidebug: fix a failure of "boot rm" sub-command

2020-03-01 Thread AKASHI Takahiro
On Fri, Feb 28, 2020 at 07:05:39PM +0100, Heinrich Schuchardt wrote: > On 2/28/20 1:05 AM, AKASHI Takahiro wrote: > > There is a wrong usage of utf8_utf16_strncpy() in "boot rm" command, and > > then it will end up with a failure of this command due to a wrong > > value of an interim variable

Re: [PATCH] usb: ehci: Fix "EHCI timed out on TD - token=XXXX" error on ehci-hcd

2020-03-01 Thread Tom Rini
On Sat, Feb 29, 2020 at 08:20:57AM +0100, Marek Vasut wrote: > On 2/29/20 4:20 AM, Tom Rini wrote: > > On Sat, Feb 29, 2020 at 12:32:57AM +0100, Marek Vasut wrote: > >> On 2/26/20 12:29 PM, Lukasz Majewski wrote: > >>> This patch aims to improve robustness of 'usb' command operation on the > >>>

Re: [PATCH] usb: ehci: Fix "EHCI timed out on TD - token=XXXX" error on ehci-hcd

2020-03-01 Thread Marek Vasut
On 3/1/20 6:59 PM, Lukasz Majewski wrote: > Hi Marek, Hi, [...] >>> The description of the fix written by the original author: >>> https://forum.doozan.com/read.php?3,35295,35295#msg-35295 >>> >>> states that the reduction of the transfer is done just for "spin >>> up"/"detection" of the pen

Re: [PATCH] image.h: use uint32_t instead of u32 in android_image_get_dtb*

2020-03-01 Thread Heinrich Schuchardt
On 2/20/20 12:45 PM, Sam Protsenko wrote: Hi Eugeniu, On Mon, Feb 17, 2020 at 12:24 PM Eugeniu Rosca wrote: Replace 'u32' by 'uint32_t' in image.h, since the former may lead to build failures in U-Boot tooling (see [1]). Avoid using 'uint', since it is not a fixed-width type [2],

[PATCH] mkimage: fit: don't create image with 0700 permissions

2020-03-01 Thread Thomas Hebb
commit 7298e422504e ("mkimage: fit: add support to encrypt image with aes") added a new copyfile() function as part of the FIT image creation flow. This function as currently written creates the final image with a mode of 0700 (before umask), differing from the old behavior of 0666. Since there

Re: [PATCH] usb: ehci: Fix "EHCI timed out on TD - token=XXXX" error on ehci-hcd

2020-03-01 Thread Lukasz Majewski
Hi Marek, > On 3/1/20 6:19 PM, Lukasz Majewski wrote: > > Hi Marek, > > Hi, > > >> On 2/26/20 12:29 PM, Lukasz Majewski wrote: > >>> This patch aims to improve robustness of 'usb' command operation > >>> on the ehci-hcd IP block as it ports to contemporary U-Boot the > >>> patch described

Re: Fixing low-speed USB keyboard detection

2020-03-01 Thread Soeren Moch
Hi Stefan, please do not top-post. On 29.02.20 13:42, Stefan wrote: > Hello Soeren! > > It will take me some time to prepare a proper patch, I just found the > documentation of your patman tool. I am using Guix and created a package > definition for U-Boot with these three fixes using regexp

Re: [PATCH] usb: ehci: Fix "EHCI timed out on TD - token=XXXX" error on ehci-hcd

2020-03-01 Thread Marek Vasut
On 3/1/20 6:19 PM, Lukasz Majewski wrote: > Hi Marek, Hi, >> On 2/26/20 12:29 PM, Lukasz Majewski wrote: >>> This patch aims to improve robustness of 'usb' command operation on >>> the ehci-hcd IP block as it ports to contemporary U-Boot the patch >>> described and provided in [1] (originally

Re: [PATCH] usb: ehci: Fix "EHCI timed out on TD - token=XXXX" error on ehci-hcd

2020-03-01 Thread Lukasz Majewski
Hi Marek, > On 2/26/20 12:29 PM, Lukasz Majewski wrote: > > This patch aims to improve robustness of 'usb' command operation on > > the ehci-hcd IP block as it ports to contemporary U-Boot the patch > > described and provided in [1] (originally applicable to U-Boot > > 2016.05). > > > >

Re: [cmd] Notation for "mandatory" and "optional" parameters in "help shell_cmd" output

2020-03-01 Thread Wolfgang Denk
Dear Adarsh Babu Kalepalli, In message you wrote: > > When we type "help shell_command" at u-boot console. > The syntax for the command usage is displayed. > > In most of the cases I noticed parameters enclosed in '[]' or/and '<>' > or just the sub-command string is provided. > > From the help

Re: [PATCH] arm: socfpga: arria10: Add save_boot_params()

2020-03-01 Thread Marek Vasut
On 2/26/20 8:01 PM, Ley Foon Tan wrote: [...] > +#define BOOTROM_SHARED_MEM_ADDR (CONFIG_SYS_INIT_RAM_ADDR + > 0x4 \ > + - 0x800) > +#define RST_STATUS_SHARED_ADDR (BOOTROM_SHARED_MEM_ADDR + > 0x438) Are all these magic values

Re: [PATCH][v4 5/6] board: tbs2910: Enable distro_boot support.

2020-03-01 Thread Soeren Moch
On 27.02.20 01:37, Denis 'GNUtoo' Carikli wrote: > This keeps the compatibility with the old bootcmd. > > The fdtfile environment variable also needed to be set to > imx6q-tbs2910.dtb to enable booting mainline kernels > otherwise with extlinux.conf it tries to load > mx6-tbs2910.dtb instead. > >

Re: [PATCH][v4 6/6] board: tbs2910: add documentation

2020-03-01 Thread Soeren Moch
On 27.02.20 01:37, Denis 'GNUtoo' Carikli wrote: > This documents the u-boot installation procedure and the > hardware in order to get started. Thanks for adding this documentation! Since you added SYSBOOT support in this series, it also might be good to mention this (and maybe how to use it) in

Re: [PATCH][v4 4/6] board: tbs2910: enable CONFIG_DISTRO_DEFAULTS

2020-03-01 Thread Soeren Moch
On 27.02.20 01:37, Denis 'GNUtoo' Carikli wrote: > The side effect is that it increase the size of the > resultimg image, which is already very close to the > size limit. Please also mention the main purpose, preparation for distro_boot support, not only the side effect of this patch. > > With

Re: [PATCH][v4 1/6] board: tbs2910: disable loadb and loads commands

2020-03-01 Thread Soeren Moch
On 27.02.20 01:36, Denis 'GNUtoo' Carikli wrote: > The loadb and loads commands are not needed for booting. > > There are also more reliable and faster alternatives to > loadb and loads that can be used with the current configuration. > > As that the resulting image is already very close to the >

Re: [PATCH][v4 2/6] board: tbs2910: disable CONFIG_GZIP

2020-03-01 Thread Soeren Moch
On 27.02.20 01:36, Denis 'GNUtoo' Carikli wrote: > As that the resulting image is already very close to the > size limit, and that CONFIG_GZIP is not strictly required, > removing it shouldn't hurt. > > With arm-linux-gnueabi-gcc 9.2.0-1 from the Parabola > GNU/Linux distribution we have the

Re: [PATCH][v4 3/6] board: tbs2910: move CONFIG_BOOTCOMMAND from header to defconfig

2020-03-01 Thread Soeren Moch
On 27.02.20 01:36, Denis 'GNUtoo' Carikli wrote: > This doesn't affect the size of the image: with > arm-linux-gnueabi-gcc 9.2.0-1 from the Parabola GNU/Linux > distribution, the text, data, bss and total sizes remain > unchanged. > > Signed-off-by: Denis 'GNUtoo' Carikli Reviewed-by: Soeren Moch

[cmd] Notation for "mandatory" and "optional" parameters in "help shell_cmd" output

2020-03-01 Thread Adarsh Babu Kalepalli
Hi, When we type "help shell_command" at u-boot console. The syntax for the command usage is displayed. In most of the cases I noticed parameters enclosed in '[]' or/and '<>' or just the sub-command string is provided. >From the help of most of the commands, and on using them I observed that