Re: "copy files", specialfolderpath("resources") and missing files = SHOWSTOPPER

2019-08-09 Thread Brian Milby via use-livecode
Some files are moved to a different location based on type.  I can’t recall the details and would need to look at the source.  It is related to binary code though.  Stuff is copied first and then moved on a second pass.  That would explain the presence of the empty folders. Thanks, Brian On

Experiments with the container layerMode and Animation Engine

2019-08-09 Thread Derek Bump via use-livecode
Hello List, I hope all of you have been well. It's been a while since I've experimented with Animation Engine--or LiveCode in general--and the recent addition of the "container" layerMode in 9.5 had me thinking that it might be a good time to revisit animation and gaming. However, I've been

Re: "copy files", specialfolderpath("resources") and missing files = SHOWSTOPPER

2019-08-09 Thread Klaus major-k via use-livecode
Maybe noone got the point of my posting? The point is, that I add files and folder to the standalone via the "Copy files" tab in the "Standalone Application Settings", however some of these files are missing in the final runtime. However instead they can be found in ->

Re: not building standalone due to password protected stack LC950Indy

2019-08-09 Thread JJS via use-livecode
added https://quality.livecode.com/show_bug.cgi?id=22308 Op 9-8-2019 om 18:57 schreef JJS via use-livecode: Yep, that was it. For this stack i had automatically search inclusions set to true. So when the stack is encrypted it does not work. Manually it works ok. Damn, that i did not

Re: not building standalone due to password protected stack LC950Indy

2019-08-09 Thread JJS via use-livecode
Yep, that was it. For this stack i had automatically search inclusions set to true. So when the stack is encrypted it does not work. Manually it works ok. Damn, that i did not check it in the first place. The error was obvious. So it is a bug, as it should also work. Will report it.

Re: not building standalone due to password protected stack LC950Indy

2019-08-09 Thread JJS via use-livecode
Hi, this build was for windows 32 and 64 bit, and building on win10-64bits. i can not recall this issue with a lc950dp or rc version when building an encrypted stack for Android. Perhaps the difference is that for that i selected inclusions mannually i'm now thinking. I will check if

Re: not building standalone due to password protected stack LC950Indy

2019-08-09 Thread Pi Digital via use-livecode
Hi I’ve only noticed this when building for HTML5. For everything else the stacks get directly included and don’t care that they are password protected. For html they have to get re-coded through emscripten which is where I believe the issue arises. Which platform/s are you trying to deploy

not building standalone due to password protected stack LC950Indy

2019-08-09 Thread JJS via use-livecode
Hi, i've not seen this before: Could not auto-detect inclusions or security categories because stack is password protected It seems like setting the password for stacks in the standalone setting is not working. If i set it and save the stack, then open the stack in notepad++ i can read

Re: Should the scope of WholeMatches be expanded?

2019-08-09 Thread hh via use-livecode
There is already truewordOffset available but you have to check whether the search string is the next trueword. So matchChunk is faster. ___ use-livecode mailing list use-livecode@lists.runrev.com Please visit this url to subscribe, unsubscribe and

Re: Should the scope of WholeMatches be expanded?

2019-08-09 Thread dunbarxx via use-livecode
Hi. Not sure, because I have never used one, but would a "trueWordOffset" help? Craig -- Sent from: http://runtime-revolution.278305.n4.nabble.com/Revolution-User-f278306.html ___ use-livecode mailing list use-livecode@lists.runrev.com Please

"copy files", specialfolderpath("resources") and missing files = SHOWSTOPPER

2019-08-09 Thread Klaus major-k via use-livecode
Hi friends, I am currently making an existing app "64Bit safe" for a customer with LC 9.5 on macOS 10.14.6. In this app there are some "compiled shell scripts" (? I guess, have no infor about this) which changes the keyboard layout (chinese and back) to german depending of the target fields

Re: load app to ios device for testing??

2019-08-09 Thread scott--- via use-livecode
Hello Alan, I’m running LC 9.5.0 business, Mac OS 10.14.6 & Xcode 10.1 I am seeing both android and iOS actual devices (as well as the iOS and android simulator, which is an awesome addition) Did you select the correct platform in “Standalone Application Settings”? Is "Mobile Support” configured

load app to ios device for testing??

2019-08-09 Thread Alan Stenhouse via use-livecode
Just wondering how we can download an ios build to our own local device for testing these days? It used to be easy with iTunes to just attach your phone and download the app to the connected device inside iTunes, but that no longer seems possible (though possibly I'm missing something?). I