Re: Scripting what should be a simple loop...

2010-07-09 Thread Kay C Lan
On Sat, Jul 10, 2010 at 11:37 AM, David C. wrote: > > Column1--corresponds to->Field1--corresponds to--->tVar1--> is used by. > etc > Of course there's no reason you couldn't col1 - original data fCol1 - field lfCol1 - label field bCol1 - button tCol1 - temp var lCol1 - script local var gCo

Re: Scripting what should be a simple loop...

2010-07-09 Thread Mark Wieder
David- Friday, July 9, 2010, 8:37:44 PM, you wrote: >>It is recommendable to use arrays in this case: >> >>repeat for i = 1 to 10 >> put fld i of grp "AllFields" into tVar[i] >>end repeat > I'll really consider that to see if it will fit the need, Mark. > Question: Is getting data into or out of

Re: Scripting what should be a simple loop...

2010-07-09 Thread David C.
Hey folks, I've tried to keep this to less than "small book" scale, but here we go... Bob, Sarah, & Alex all concurred in one form or another that: >Setting variables whose names are construct dynamically requires using "do". Got it! ...the missing link. :) To be honest, I never really even consi

Re: [OT] G4 goes West

2010-07-09 Thread Kay C Lan
On Fri, Jul 9, 2010 at 11:43 PM, Jeff Reynolds wrote: > > you might want to think about grabbing a little temperature probe. > This might be an easier option: http://www.bresink.de/osx/0TemperatureMonitor/issues.html note the hardware support for older models is trial and error. Not for the G4

Re: Scripting what should be a simple loop...

2010-07-09 Thread David C.
Well, I guess that problem kind of opened up a can of worms... to which this reply is pointed to *all* who contributed. Thank you so much for the help! It's really appreciated. Let me digest some of the replies and I'll be back a bit later with a question or two. That should help clarify some thin

Re: Timer Pause script

2010-07-09 Thread Jerry Daniels
You can REALLY see with either method. Every iteration. Best, Jerry Daniels Join the Rodeo discussion: http://rodeoapps.com/rodeo-discuss-among-yourselves On Jul 9, 2010, at 6:48 PM, Bob Sneidar wrote: > This is why I like step debuggers (Sorry Jerry, still love tRev too). You can > see what

Re: Scripting what should be a simple loop...

2010-07-09 Thread Alex Tweedly
On 10/07/2010 00:43, Alex Tweedly wrote: put (fld "field" & i) into temp do "put temp into quote & "tVar" & quote & i Sorry - it doesn't need to be that complicated. you can just do put (fld "field" & i) into temp do "put temp into tVar" & i (And just in case there are more silly

Re: Scripting what should be a simple loop...

2010-07-09 Thread Mark Schonewille
HI BOB, It doesn't matter, because David writes he got only 10 fields in that group. Besides, it is really a bad idea to call a field "field 1". -- Best regards, Mark Schonewille Economy-x-Talk Consulting and Software Engineering Homepage: http://economy-x-talk.com Twitter: http://twitter.c

Re: Timer Pause script

2010-07-09 Thread Bob Sneidar
This is why I like step debuggers (Sorry Jerry, still love tRev too). You can see what the variables REALLY are (not what you THINK they are) at each step of the way. Bob On Jul 9, 2010, at 4:38 PM, Sarah Reichelt wrote: > The problem is that the global variable startSeconds keeps the same v

Re: Scripting what should be a simple loop...

2010-07-09 Thread Bob Sneidar
Hi Mark. That won't work because the fields themselves are named "Field1 Field2". He is not referencing the fields by their numbers but rather by their names. A bit confusing but I got it. Bob On Jul 9, 2010, at 4:37 PM, Mark Schonewille wrote: > Hi David, > > Whenever you discuss somethin

Re: Scripting what should be a simple loop...

2010-07-09 Thread Scott Rossi
Hi David: One way to dynamically create a variable on the fly is using the "do" command. repeat with i = 1 to 10 get fld ("Field" & i) of grp Allfields -- put the value into "it" do "put it into tVar" & i end repeat Two additional things to consider: 1) When referring to an object nam

Re: Scripting what should be a simple loop...

2010-07-09 Thread Alex Tweedly
You do indeed need a 'do' statement - but the first half of the statement (dealing with the field) doesn't need it, only the second half. So I would find it more readable to do put (fld "field" & i) into temp do "put temp into quote & "tVar" & quote & i OK, it's marginally inefficient,

Re: Scripting what should be a simple loop...

2010-07-09 Thread Bob Sneidar
As an aside, what Macro Substitution would be able to do is dereference variables at runtime. Assuming an amperstand was the dereference character: put "field" into theObject put "tVar" into theVar put 1 into i put field &theObject.&i of group "AllFields" into &theVar.&i This was how dBase and o

Re: Timer Pause script

2010-07-09 Thread Sarah Reichelt
The problem is that the global variable startSeconds keeps the same value so when you restart the timer after a pause, you need to reset the startSeconds to the current seconds less the time already on the timer. Cheers, Sarah Sent from my iPad On 10/07/2010, at 8:34 AM, JosepM wrote: > >

Re: Scripting what should be a simple loop...

2010-07-09 Thread Mark Schonewille
Hi David, Whenever you discuss something that involved an error, you really should post the error message together with your question. It helps. Really, it does. Now to your answer. I am not exactly sure what to answer, because I don't know the error message, but I can make a guess. It

Re: Scripting what should be a simple loop...

2010-07-09 Thread Sarah Reichelt
Setting variables whose names are construct dynamically requires using "do". So this should work: put "Field" & i into tFieldName put "put fld tFieldName of grp AllFields into tVar" & i into tCommand do tCommand Probably an easier solution is to use an array: put fld "Field" & i of grp "AllFields

Re: Scripting what should be a simple loop...

2010-07-09 Thread Bob Sneidar
You need a do statement. Otherwise you would need Macro Substitution which Runrev does not support. put "put fld" && quote & "Field" & i & quote && "of group" & quote & AllFields & quote && "into tvar" & i into theCommand do theCommand -- careful of line wraps Easier to read is: put "put fld f

Scripting what should be a simple loop...

2010-07-09 Thread David C.
Good grief! Will someone be so kind as to show me the proper way to format my script... Let's say I have the following 1 group named "AllFields" containing: 10 text fields, named Field1...Field10 10 temporary variables named tVar1...tVar10 All I want to do, using a loop, is to put the user suppl

[ANN] revIgniter v1.3.5b released

2010-07-09 Thread Ralf Bitter
Added Gzip output compression for faster page loads. Info and download at: http://revigniter.com/ Ralf ___ use-revolution mailing list use-revolution@lists.runrev.com Please visit this url to subscribe, unsubscribe and manage your subscription prefer

Timer Pause script

2010-07-09 Thread JosepM
Hi, I'm blocked :( with this... I try to start and stop a timer but with a pause button to pause the time and continue again once the pause button is pressed again. I have two buttons, button "b_timming" and button "b_pause" Also some graphics to show the button icons and display. The start and

Re: DataGrid Stuff

2010-07-09 Thread zryip theSlug
At start the Data Grid object is not the easiest thing to understand. You have to do effort to use it, but it's worth the trouble. The object is powerful, flexible and well design. I'm trying to help a little with DataGrid manipulation by designing the Data Grid helper tool. For example, this pict

Re: WAV without QT revisited

2010-07-09 Thread Scott Rossi
Recently, spencerlearning wrote: > Back in November, Richard Gaskin > http://runtime-revolution.278305.n4.nabble.com/WAV-without-QT-td786452.html#a7 > 86455 > asked : > > I just tried playing a WAV file on a Win XP system which doesn't have > QuickTime. No go. MP3 played well, but I couldn't get

Re: DataGrid Stuff

2010-07-09 Thread Richmond
On 07/09/2010 10:49 PM, zryip theSlug wrote: Hi Roger, In fact the Data Grid is not a native object in Revolution. It's a complex group of objects with properties, events and templates to customize it. This is true! You will find, if you bother to take the time to fiddle about a bit, that

Re: DataGrid Stuff

2010-07-09 Thread Jeff Massung
On Fri, Jul 9, 2010 at 2:49 PM, zryip theSlug wrote: > Hi Roger, > > In fact the Data Grid is not a native object in Revolution. > It's a complex group of objects with properties, events and templates to > customize it. > > While definit

Re: DataGrid Stuff

2010-07-09 Thread Richmond
On 07/09/2010 09:37 PM, Roger Guay wrote: I'm probably doing something stupid again, but with all the hoopla about data grids, I finally decided to delve into them. So, I went to the Data Grid lessons on lessons.runrev.com and to my surprise, my dictionary in Rev 4.0.0 does not contain any of

Re: DataGrid Stuff

2010-07-09 Thread Bob Sneidar
Best to go to http://revolution.screenstepslive.com/spaces/revolution_tools/manuals/datagrid and view those lessons there. He keeps that pretty up to date. Bob On Jul 9, 2010, at 11:37 AM, Roger Guay wrote: > I'm probably doing something stupid again, but with all the hoopla about data > gri

Re: DataGrid Stuff

2010-07-09 Thread zryip theSlug
Hi Roger, In fact the Data Grid is not a native object in Revolution. It's a complex group of objects with properties, events and templates to customize it. A good starting is to read the pdf documentation: Download Manual PDF And do

ChartMaker download omission

2010-07-09 Thread FlexibleLearning
ChartMaker If you have recently download a copy of ChartMaker from RevSelect at www.runrev.com or from www.FlexibleLearning.com/xtalk, you will have found that the Utility wizard is missing. You can download the missing file at www.flexibleLearning.com/xtalk/chartmaker/ChartMakerUtility.zip and p

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread zryip theSlug
You forget nothing André, but I have forget something in my previous script! ;) In fact the new value edited in a cell will be updated in the data of the column after the execution of the closeFieldEditor. So when we execute the sum, the uSumOfColumn will take the old value of the cell, not the upd

WAV without QT revisited

2010-07-09 Thread spencerlearning
Back in November, Richard Gaskin http://runtime-revolution.278305.n4.nabble.com/WAV-without-QT-td786452.html#a786455 asked : I just tried playing a WAV file on a Win XP system which doesn't have QuickTime. No go. MP3 played well, but I couldn't get the WAV file to play. ... Anyone know a workar

DataGrid Stuff

2010-07-09 Thread Roger Guay
I'm probably doing something stupid again, but with all the hoopla about data grids, I finally decided to delve into them. So, I went to the Data Grid lessons on lessons.runrev.com and to my surprise, my dictionary in Rev 4.0.0 does not contain any of the data grid properties like dgText and dgD

Re: Build settings for Mac OSX - feedback

2010-07-09 Thread J. Landman Gay
Steve King wrote: I declared the types in both the Document type and document extension part of the standalone builder, using comma separated SAC, SACp for both. Maybe this is not correct? The entries in the standalone builder just tell Rev what to put in the plist it makes. It has no affect

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread Andre.Bisseret
Le 9 juil. 10 à 16:25, zryip theSlug a écrit : The correct usage of the closeFieldEditor is to use it in the default column behavior or the column behavior of thecolumns to sum (Débit and Crédit) Add a column behavior to the first column (Débit), and edit the behavior. In the script, c

Re: Build settings for Mac OSX - feedback

2010-07-09 Thread Bob Sneidar
It is my understanding that Revolution translates the file path format on the fly, so yes. Bob On Jul 9, 2010, at 9:14 AM, Steve King wrote: > Is the "/" in the script the same way round in all platforms? ___ use-revolution mailing list use-revolut

Re: [OT] G4 goes West

2010-07-09 Thread Richmond
On 07/09/2010 06:43 PM, Jeff Reynolds wrote: Richmond, nice frankensteining! did you scream its alive when you turned the power back on? No; bit I remember the part in "young Frankenstein" when 'Eye-Gor' comes back with a brain in a jar labelled "A. B. Normal". . . :) you might want to

Re: Build settings for Mac OSX - feedback

2010-07-09 Thread Steve King
Hi Jacqueline & Bob I think the version is 10.5.3? But this was just from a very quick glance and I will have to check again. It was very lpeasing it just ran though. Yes, I meant Answer file (not ask). I do use qualifier extensions in answer dialogue but I will check exactly how I have defined t

Re: [OT] G4 goes West

2010-07-09 Thread Jeff Reynolds
Richmond, nice frankensteining! did you scream its alive when you turned the power back on? you might want to think about grabbing a little temperature probe. you can get these for less than $10 these days and they usually fit in a bay cover space and have an in-line drive vampire plug fo

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread Andre.Bisseret
Le 9 juil. 10 à 16:12, zryip theSlug a écrit : but instead to have a Sum button outside the Data Grid, you try to refresh the Sum with the closeFieldEditor, right? Yes, up to now I have a button outside the data grid but I would have like to re calculate the sums automatically as soon as th

Re: [OT] G4 goes West

2010-07-09 Thread Richmond
On 07/09/2010 02:21 PM, viktoras d. wrote: b.t.w. may I ask (as a non native English speaker) what is the difference between "going West" (is it good?) and "going South" (the later seems quite negative) ? Are the any other ways like "going North", "going East" or "going SouthEast" with some ver

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread zryip theSlug
The correct usage of the closeFieldEditor is to use it in the default column behavior or the column behavior of thecolumns to sum (Débit and Crédit) Add a column behavior to the first column (Débit), and edit the behavior. In the script, change the closeFieldEditor like this: on closeFieldEditor

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread zryip theSlug
You follow this lesson: http://lessons.runrev.com/spaces/lessons/manuals/datagrid/lessons/7321-How-Do-I-Get-Aggregate-Values-for-Columns- but instead to have a Sum button outside the Data Grid, you try to refresh the Sum with the closeFieldEditor, right? 2010/7/9 Andre.Bisseret > Bonjour TheS

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread Andre.Bisseret
Bonjour TheSlug, Thank you for your reply. Seems I am missing something I have 2 fields under the datagrid where I want to put the total of 2 columns of the datagrid (fldTotDébit and fldTotCrédit) In the script of the datagrid, I put: on closeFieldEditor pFieldEditor set the text of f

Re: [OT] G4 goes West

2010-07-09 Thread Mike Bonner
My guess as to the americanized meaning of "gone west" is from the colonial days. Actually had 2 connotations. First connotation was that to the west (unexplored areas) was a land of opportunity. "Head west young man" meant, go and seek your fortune. Due to the same usage it also had a negative

Re: [OT] G4 goes West

2010-07-09 Thread Peter W A Wood
This may help - http://www.encyclo.co.uk/define/Gone%20West On 9 Jul 2010, at 21:12, Colin Holgate wrote: > I hadn't seen anyone use the expression "going west" before, so I just took > it to mean "going south", with some misdirection (as it were) for the sake of > humor. ___

Re: [OT] G4 goes West

2010-07-09 Thread Colin Holgate
I hadn't seen anyone use the expression "going west" before, so I just took it to mean "going south", with some misdirection (as it were) for the sake of humor. ___ use-revolution mailing list use-revolution@lists.runrev.com Please visit this url to sub

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread zryip theSlug
Bonjour André, You have to use the CloseFieldEditor event. Have a look to this lesson: http://lessons.runrev.com/manuals/datagrid/lessons/7335 Regards, 2010/7/9 Andre.Bisseret > Bonjour, > > I have quite small editable data grids. > > I would like to re-calculate the totals of the columns aft

(DataGrid) is there a message when the user has edited a cell ?

2010-07-09 Thread Andre.Bisseret
Bonjour, I have quite small editable data grids. I would like to re-calculate the totals of the columns after the user has changed the value of any cell. I don't need to know what cell was edited. What message should I use ? Thanks in advance for any advice Best regards from Grenoble (ver

Re: [OT] G4 goes West

2010-07-09 Thread viktoras d.
b.t.w. may I ask (as a non native English speaker) what is the difference between "going West" (is it good?) and "going South" (the later seems quite negative) ? Are the any other ways like "going North", "going East" or "going SouthEast" with some very special meanings in them :-)? Viktoras