Re: Scripting what should be a simple loop...

2010-07-10 Thread Kay C Lan
On Sat, Jul 10, 2010 at 11:37 AM, David C. davidoco...@gmail.com wrote: Column1--corresponds to-Field1--corresponds to---tVar1-- is used by. etc Of course there's no reason you couldn't col1 - original data fCol1 - field lfCol1 - label field bCol1 - button tCol1 - temp var lCol1 -

Re: Scripting what should be a simple loop...

2010-07-10 Thread Richmond
On 07/10/2010 02:23 AM, David C. wrote: Good grief! Will someone be so kind as to show me the proper way to format my script... 'the proper way . . . Um; that is slightly funny as, unlike Fortran IV (what a pain it was) there is no strict set of rules as to how to format a script. This

Re: Scripting what should be a simple loop...

2010-07-10 Thread Mark Schonewille
David and Mark, Yet, repeat for each rules. Whether using arrays is faster than using regular variables depends on whether your repeat loop is written smartly. -- Best regards, Mark Schonewille Economy-x-Talk Consulting and Software Engineering Homepage: http://economy-x-talk.com

Re: [OT] G4 goes West

2010-07-10 Thread Richmond
On 07/10/2010 05:10 AM, Kay C Lan wrote: On Fri, Jul 9, 2010 at 11:43 PM, Jeff Reynoldsj...@siphonophore.comwrote: you might want to think about grabbing a little temperature probe. This might be an easier option: http://www.bresink.de/osx/0TemperatureMonitor/issues.html I

Re: Scripting what should be a simple loop...

2010-07-10 Thread René Micout
Hello Bob, Sarah, Mark, Alex, Scott, Kay, Very good lesson !!! Yes ! Better than documentation ! It is a good example for witch I appreciate How to use Revolution I imagine that many silent readers appreciate like me and I thank you on their behalf... PS : pity not have English lessons like that

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-10 Thread Andre.Bisseret
Bonjour TheSlug, Great help and learning for me! I just played with your demo stack! Magnifique ;-)) Thank you very much for your time and for sharing your high knowledge about data grid! very much appreciated. Seems you are the best as for Data Grid (after Trevor ;-O))) I am a bit

Re: Scripting what should be a simple loop...

2010-07-10 Thread Richmond
On 07/10/2010 11:49 AM, Mark Schonewille wrote: David and Mark, Yet, repeat for each rules. Whether using arrays is faster than using regular variables depends on whether your repeat loop is written smartly. Quite; but that looks a bit like circular logic. Everytime I have to write some

Re: Scripting what should be a simple loop...

2010-07-10 Thread René Micout
I like Richmond's disillusioned vision of life ! ;-) René Le 10 juil. 2010 à 10:45, Richmond a écrit : On 07/10/2010 02:23 AM, David C. wrote: Good grief! Will someone be so kind as to show me the proper way to format my script... 'the proper way . . . Um; that is slightly funny as,

Re: (DataGrid) is there a message when the user has edited a cell ?

2010-07-10 Thread zryip theSlug
2010/7/10 Andre.Bisseret andre.bisse...@inria.fr Bonjour TheSlug, Bonjour André ;) Great help and learning for me! I just played with your demo stack! Magnifique ;-)) Thank you very much for your time and for sharing your high knowledge about data grid! very much appreciated. You're

Re: Scripting what should be a simple loop...

2010-07-10 Thread zryip theSlug
Richmond, I'm not sure to appreciated your humor. However, with less talent and other circumstances, I had probably write something similar somewhere in the net, so I forgive you for this time. 2010/7/10 Richmond richmondmathew...@gmail.com On 07/10/2010 11:49 AM, Mark Schonewille wrote:

Re: Scripting what should be a simple loop...

2010-07-10 Thread David C.
Column1--corresponds to-Field1--corresponds to---tVar1-- is used by. etc Of course there's no reason you couldn't col1 - original data fCol1 - field lfCol1 - label field bCol1 - button tCol1 - temp var lCol1 - script local var gCol1 - global var cCol1 - custom prop makes the

Re: Scripting what should be a simple loop...

2010-07-10 Thread Richmond
On 07/10/2010 12:52 PM, zryip theSlug wrote: Richmond, I'm not sure to appreciated your humor. However, with less talent and other circumstances, I had probably write something similar somewhere in the net, so I forgive you for this time. 2010/7/10 Richmondrichmondmathew...@gmail.com On

Re: Scripting what should be a simple loop...

2010-07-10 Thread Richmond
On 07/10/2010 01:00 PM, David C. wrote: Column1--corresponds to-Field1--corresponds to---tVar1-- is used by. etc Of course there's no reason you couldn't col1 - original data fCol1 - field lfCol1 - label field bCol1 - button tCol1 - temp var lCol1 - script local var gCol1 -

My naming convention

2010-07-10 Thread Richmond
For what it is worth; I always start a field's name with a lowercase 'f' - the rest in uppercase: e.g. fSTUFF so, similarly with other objects: gSTUFF will be a group, ggSTUFF will be a group containing subordinate groups, iSTUFF is an image, pSTUFF is (oddly enough) a graphic object

Re: Timer Pause script

2010-07-10 Thread JosepM
Hi, After debug, still without see the solution, the time is paused but still running... and when I resume after the pause get the whole time. --reset the startSeconds to the current seconds less the time already on the timer. put the seconds into tSeconds subtract tElapsed

Re: Timer Pause script

2010-07-10 Thread Mark Schonewille
Hi Josep, You might want to read about the cancel command and the pendingMessages function in the dictionary. -- Best regards, Mark Schonewille Economy-x-Talk Consulting and Software Engineering Homepage: http://economy-x-talk.com Twitter: http://twitter.com/xtalkprogrammer KvK: 50277553

Re: Scripting what should be a simple loop...

2010-07-10 Thread David C.
In regard to my question about using arrays, Mark W. said: Well, it's not regular variables that are the issue here. An array is *MUCH* faster than a do statement. Do statements are very slow, and I only use them sparingly and when there's no alternative. But when you gotta, you gotta. In this

Re: Timer Pause script

2010-07-10 Thread JosepM
Hi, When I press the pause button, the updateProgress message is stoped and no more call until I resume it... No message pending... Salut, Josep -- View this message in context: http://runtime-revolution.278305.n4.nabble.com/Timer-Pause-script-tp2284161p2284483.html Sent from the

RE: My naming convention

2010-07-10 Thread Damien Girard
Personnally I am using this naming convention: - first letter in lowercase, then Uppercase for the first letter of each word. - tMyVariable - Variable available in the handler - sMyVariable - Variable available in the script (local) - gMyVariable - Global variable (global) - kMyVariable -

Re: My naming convention

2010-07-10 Thread René Micout
Mine (sorry in French) : Prefix of 2 chars for constant, variable, custom prop, handler, command, function Prefix of 3 chars for objects : button, field, group, slider, label, image, graphic -- PRÉFIXES (types des objets) : -- ku = constante (unitaire) kt = constante (tableau)

Re: My naming convention

2010-07-10 Thread Richmond
On 07/10/2010 02:20 PM, Damien Girard wrote: Personnally I am using this naming convention: - first letter in lowercase, then Uppercase for the first letter of each word. - tMyVariable - Variable available in the handler - sMyVariable - Variable available in the script (local) - gMyVariable -

Re: My naming convention

2010-07-10 Thread Richmond
On 07/10/2010 02:52 PM, René Micout wrote: Mine (sorry in French) : Prefix of 2 chars for constant, variable, custom prop, handler, command, function Prefix of 3 chars for objects : button, field, group, slider, label, image, graphic -- PRÉFIXES (types des objets) : -- ku = constante

Re: My naming convention

2010-07-10 Thread Jim Ault
On Jul 10, 2010, at 3:18 AM, Richmond wrote: vSTUFF is a variable cSTUFF is a constant sSTUFF is a string aSTUFF is an array - needless-to-say; I almost NEVER adhere to this convention . . . :) so what you mean to say is

Re: My naming convention

2010-07-10 Thread Richmond
On 07/10/2010 03:57 PM, Jim Ault wrote: On Jul 10, 2010, at 3:18 AM, Richmond wrote: vSTUFF is a variable cSTUFF is a constant sSTUFF is a string aSTUFF is an array - needless-to-say; I almost NEVER adhere to this convention . . . :)

Re: My naming convention

2010-07-10 Thread Mark Wieder
Richmond- Saturday, July 10, 2010, 5:10:33 AM, you wrote: I think this is great and we really out to carry on this htread with as many poeple submitting their naming conventions as possible; we might then be able to abstract some sort of commonality which would allow us to develop a more

Re: DataGrid Stuff

2010-07-10 Thread Roger Guay
Many thanks to all who responded to my previous post. Can anyone tell me why this script doesn't work? on mouseUp ## Create tab delimited data. ## Note that first line has name of columns. ## Providing names tells Data Grid how to map ## data to appropriate columns. put

Teetotal RunRev

2010-07-10 Thread Richmond
I have just upgraded WINE: http://www.winehq.org/ to 1.2-rc7 on my main Lunux box (Ubuntu 10.04) and thought 'just for run' I'd have a bash at running the Windows build of my Devawriter Pro Demo 3.30: http://andregarzia.on-rev.com/richmond/dwriterpro.html AND: 1. All images with any sort of

Re: Teetotal RunRev

2010-07-10 Thread Pierre Sahores
Hello Richmond, Try VirtualBox instead. A great tool ! http://www.virtualbox.org/wiki/Downloads Best, Pierre Le 10 juil. 2010 à 17:53, Richmond a écrit : I have just upgraded WINE: http://www.winehq.org/ to 1.2-rc7 on my main Lunux box (Ubuntu 10.04) and thought 'just for run' I'd

Go to a web page automatically

2010-07-10 Thread Tim Selander
Hi, Using the on-rev.com server scripting, is there a ?rev command that will open a specified web page? 'launch' URL didn't seem to do it for me. Thanks, Tim Selander Tokyo, Japan ___ use-revolution mailing list use-revolution@lists.runrev.com

Re: Go to a web page automatically

2010-07-10 Thread Michael Kann
Tim, Not quite sure what you mean by open? Mike --- On Sat, 7/10/10, Tim Selander selan...@tkf.att.ne.jp wrote: From: Tim Selander selan...@tkf.att.ne.jp Subject: Go to a web page automatically To: How to use Revolution use-revolution@lists.runrev.com Date: Saturday, July 10, 2010, 11:23

Re: Go to a web page automatically

2010-07-10 Thread Pierre Sahores
Try : get url http://yoururl ; put it Best, P. Le 10 juil. 2010 à 18:23, Tim Selander a écrit : Hi, Using the on-rev.com server scripting, is there a ?rev command that will open a specified web page? 'launch' URL didn't seem to do it for me. Thanks, Tim Selander Tokyo, Japan

Re: DataGrid Stuff

2010-07-10 Thread zryip theSlug
Hi Roger, In fact you have to create the columns first as it was discussed in this interesting tread: http://www.mail-archive.com/use-revolution@lists.runrev.com/msg127457.html http://www.mail-archive.com/use-revolution@lists.runrev.com/msg127457.htmlSo you have to create a column State and a

Re: Go to a web page automatically

2010-07-10 Thread Michael Kann
Greetings Pierre, The following works: ?rev get url http://www.runrev.com; put it ? But the script loses some images and formatting along the way. If we just want the html source then it works fine. Mike --- On Sat, 7/10/10, Pierre Sahores psaho...@free.fr wrote: From: Pierre Sahores

Re: Scripting what should be a simple loop...

2010-07-10 Thread J. Landman Gay
Richmond wrote: However, when I tried to run the script it threw a bluey and opened the script editor in that rather unhelpful way where it marks the problem but doesn't allow you to edit it. It's opening in debug mode, which I find to be one of the most helpful features of the script

Re: Scripting what should be a simple loop...

2010-07-10 Thread zryip theSlug
Hum, I understand now why I have not found your post funny (or not). It's like a flashback. 2010/7/10 Richmond richmondmathew...@gmail.com On 07/10/2010 12:52 PM, zryip theSlug wrote: Richmond, I'm not sure to appreciated your humor. However, with less talent and other circumstances, I had

Re: Go to a web page automatically

2010-07-10 Thread Pierre Sahores
Mike, To get all the associated files (images, css, javascripts) fine loading along the main html file, you need to replace the relative path of those ones by the absolutes ones, if they are not loading from the same path than your irev script including the get url ; put it commands. ?rev get

RE: My naming convention

2010-07-10 Thread Francis Nugent Dixon
Hi from Beautiful Brittany, Sorry to put the proverbial cat among the pigeons ! Wonderful ! I have never seen so many complex naming conventions that I am sure you don't follow. If you do, then it is for who ? If it is for you, this means that your organizational solutions prime upon your

Re: Scripting what should be a simple loop...

2010-07-10 Thread Richmond
On 07/10/2010 08:27 PM, J. Landman Gay wrote: Richmond wrote: However, when I tried to run the script it threw a bluey and opened the script editor in that rather unhelpful way where it marks the problem but doesn't allow you to edit it. It's opening in debug mode, which I find to be one

Re: My naming convention

2010-07-10 Thread Richmond
On 07/10/2010 08:44 PM, Francis Nugent Dixon wrote: snip Naming conventions are personal. They are mostly designed to help YOU, maintain and modify YOUR scripts in the future, if you ever NEED to return to them ! 1. Good point. Forget naming conventions, and spend a little time with

Re: Teetotal RunRev

2010-07-10 Thread Richmond
On 07/10/2010 07:10 PM, Pierre Sahores wrote: Hello Richmond, Try VirtualBox instead. A great tool ! http://www.virtualbox.org/wiki/Downloads Thank you Pierre for your suggestion. I have, previously, played around with VirtualBox. However; the very, very few Windows programs I 'need'

Re: Go to a web page automatically

2010-07-10 Thread Michael Kann
Pierre, Thanks as always. Mike --- On Sat, 7/10/10, Pierre Sahores psaho...@free.fr wrote: From: Pierre Sahores psaho...@free.fr Subject: Re: Go to a web page automatically To: How to use Revolution use-revolution@lists.runrev.com Date: Saturday, July 10, 2010, 12:42 PM Mike, To get

Re: Teetotal RunRev

2010-07-10 Thread Pierre Sahores
Richmond, I use the full free and GPL ClamWin antivirus on all my windows boxes without any sad event for years. If you did'nt try it before, have an eye on this interesting solution ;-) http://www.clamwin.com/ Best, Pierre Le 10 juil. 2010 à 21:17, Richmond a écrit : On 07/10/2010 07:10

Re: Teetotal RunRev

2010-07-10 Thread Richmond
On 07/10/2010 10:51 PM, Pierre Sahores wrote: Richmond, I use the full free and GPL ClamWin antivirus on all my windows boxes without any sad event for years. If you did'nt try it before, have an eye on this interesting solution ;-) http://www.clamwin.com/ What with Jacque's posting

RE: My naming convention

2010-07-10 Thread Damien Girard
Hi, I totally disagree with you, having a naming convention in an enterprise helps to produce faster application, but I am talking here about real application, not a funny stack that display few funny effects... In my other life (a life without RunRev), I am working in a team of 6 developers,

Non linear undo in Rev IDE

2010-07-10 Thread Alejandro Tejada
Hi all, I am gathering some ideas about: How should work a Non linear Undo in Rev? Please, participate with your experiences, ideas and questions. Your collaboration is indispensable to create this library. Notice that after we implement sucessfully this project using revTalk scripts, it will

Re: Go to a web page automatically

2010-07-10 Thread Tim Selander
Good morning! Thanks for the reply. Sorry for not being clear. By 'open' I mean I just want to take the user to another page, as if they had clicked a link. I'm trying to write a simple form to get user input (based on Sarah's revForm.irev script) and want to take them to a 'Thank you'

Re: Go to a web page automatically

2010-07-10 Thread Tim Selander
Hi again, Mike That code works for me! Thanks. The page I want to call up is in the same directory, so all the graphics, etc., come in fine too. Thank you! Tim Selander Tokyo, Japan On 7/11/10 2:10 AM, Michael Kann wrote: Greetings Pierre, The following works: ?rev get url

Re: Go to a web page automatically

2010-07-10 Thread Sarah Reichelt
On Sun, Jul 11, 2010 at 10:20 AM, Tim Selander selan...@tkf.att.ne.jp wrote: Good morning! Thanks for the reply. Sorry for not being clear. By 'open' I mean I just want to take the user to another page, as if they had clicked a link. I'm trying to write a simple form to get user input (based

Re: Timer Pause script

2010-07-10 Thread Sarah Reichelt
After debug, still without see the solution, the time is paused but still running... and when I resume after the pause get the whole time. --reset the startSeconds to the current seconds less the time already on the timer.         put the seconds into tSeconds         subtract tElapsed from

Re: Go to a web page automatically

2010-07-10 Thread Jim Ault
On Jul 10, 2010, at 5:56 PM, Sarah Reichelt wrote: On Sun, Jul 11, 2010 at 10:20 AM, Tim Selander selan...@tkf.att.ne.jp wrote: Thanks for the reply. Sorry for not being clear. By 'open' I mean I just want to take the user to another page, as if they had clicked a link. I'm trying to

Re: Go to a web page automatically

2010-07-10 Thread Mike Bonner
YOu can also use meta refresh to redirect to a new page. See here: http://webdesign.about.com/od/metataglibraries/a/aa080300a.htm Or conversly, a javascript method can be found here: http://www.web-source.net/javascript_redirect.htm Also, if you have a set of criteria on the first page you load

Re: Go to a web page automatically

2010-07-10 Thread Michael Kann
Tim, Redirect that thanks eastward to Pierre. I just checked out what he proposed. Mike --- On Sat, 7/10/10, Tim Selander selan...@tkf.att.ne.jp wrote: From: Tim Selander selan...@tkf.att.ne.jp Subject: Re: Go to a web page automatically To: How to use Revolution

Re: My naming convention

2010-07-10 Thread David C.
Hello Francis, Revolution scripting is not to be pondered upon. Just write it, as it flows out of your brain. Heh... good, bad or otherwise, I seem to have mastered that part of your message all too well. ;-) Best regards, David C. ___

Language learning stacks

2010-07-10 Thread Mark Swindell
Has anyone developed any vocabulary/ language learning stacks in Rev? Seems like an apt application for the tool, but I didn't see anything in revOnLine. Picture dictionary type things with rollovers for different languages? Remember those First Thousand Words books with contextualized

Re: Language learning stacks

2010-07-10 Thread Mike Bonner
Not sure this is the direction you want to go, but I have a very simple set of stacks that i'm using to help me (attempt) to learn spanish. Not pictures, different method. Basically its 1 stack with a field that you can paste into (or theres a button where you can paste the text to work with)

Re: Language learning stacks

2010-07-10 Thread Mark Swindell
I've got a page set up on iGoogle that has various back and forth translators between different languages I know or am interested in. It's pretty quick and easy, adding a Rev interface wouldn't save me much, I don't think. But I was interested in graphical interfaces for simple vocabulary,

Re: Language learning stacks

2010-07-10 Thread Mike Bonner
Well in your quest, you might find this site useful. http://www.ilovelanguages.com/idp/IDPfiles.html Has some flat files from and to various languages, might save you some work if you decide to have a real go at this. Still no graphics involved but still a pretty useful resource. On Sun, Jul