Re: toString( ) and naming conventions in Component class

2009-03-26 Thread Ricky
I tried to implement something like: // java docs removed for clarity public abstract class Change implements IClusterable { private static final long serialVersionUID = 1L; // former type public FORMER former; protected Change(final FORMER former) { setFormer(former);

Re: toString( ) and naming conventions in Component class

2009-03-26 Thread Ricky
https://issues.apache.org/jira/browse/WICKET-2187 done. thank you. On Thu, Mar 26, 2009 at 11:40 AM, Ricky wrote: > thanks, i'll create a JIRA issue and submit a patch tonight, appreciate > your time! > > > On Thu, Mar 26, 2009 at 8:31 AM, Johan Compagner wrote: > >> if you have a patch for bet

Re: toString( ) and naming conventions in Component class

2009-03-26 Thread Ricky
thanks, i'll create a JIRA issue and submit a patch tonight, appreciate your time! On Thu, Mar 26, 2009 at 8:31 AM, Johan Compagner wrote: > if you have a patch for better toString() impl be my guest and attach it to > jira > > Those Changes classes are internal to component, they are inner class

Re: toString( ) and naming conventions in Component class

2009-03-26 Thread Johan Compagner
if you have a patch for better toString() impl be my guest and attach it to jira Those Changes classes are internal to component, they are inner classes of Component so they dont have to specify that extra name.. Its just verbose. Also those 2 are protected final but i think they could be private

Re: toString( ) and naming conventions in Component class

2009-03-25 Thread Ricky
or better have a something like IChange, that would simply the change "component" type hierarchy and make our naming conventions more apparent ... is that a valid opinion? Regards Vyas, Anirudh On Wed, Mar 25, 2009 at 9:49 PM, Ricky wrote: > Hi, > > This concerns Wicket Version : 1.4-rc2 > > >

toString( ) and naming conventions in Component class

2009-03-25 Thread Ricky
Hi, This concerns Wicket Version : 1.4-rc2 In componentModelChange class, we see the following : @Override public String toString() { return "ComponentModelChange[component: " + getPath() + "]"; } "ComponentModelChange[" piece of it, in toString( ) sh