Re: [xwiki-users] Does XWiki support markdown syntax?

2016-03-24 Thread Dan T
Hello Chetan,

To do this, you have to edit your « xwiki.cfg » file and look for « 
xwiki.rendering.syntaxes ». 

You will have a list of available syntaxes just before that line.

This is what i have : 

xwiki.rendering.syntaxes = xwiki/2.0, xwiki/2.1, markdown/1.1, html/4.01, 
xhtml/1.0, plain/1.0

Restart Xwiki after that and you should have the new syntaxe(s) available in 
your editor.
 
Daniel

Le 24 mars 2016 à 15:53:27, Chetan Kumar (chetankumar.i...@gmail.com) a écrit:

Thank you for the reply, Thomas.

Going by this syntax report, it looks like markdown syntax is supported but
somehow I don't how to enable the syntax format in the editor.
http://rendering.xwiki.org/xwiki/bin/view/Main/SyntaxReport

Any insight you can provide is greatly appreciated.

On Thu, Mar 24, 2016 at 4:28 AM, Chetan Kumar 
wrote:

> Does XWiki support markdown syntax?
>
> This commit-history link makes it seem so:
> https://github.com/xwiki/xwiki-rendering/pull/1. But I don’t remember
> reading about markdown syntax on the XWiki Syntax guide.
>
> Thanks,
> Chetan
>
>
>



--  

"Whether you think you can or think you can't, you're right." -- Henry Ford

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Does XWiki support markdown syntax?

2016-03-24 Thread Chetan Kumar
Thank you for the reply, Thomas.

Going by this syntax report, it looks like markdown syntax is supported but
somehow I don't how to enable the syntax format in the editor.
http://rendering.xwiki.org/xwiki/bin/view/Main/SyntaxReport

Any insight you can provide is greatly appreciated.

On Thu, Mar 24, 2016 at 4:28 AM, Chetan Kumar 
wrote:

> Does XWiki support markdown syntax?
>
> This commit-history link makes it seem so:
> https://github.com/xwiki/xwiki-rendering/pull/1. But I don’t remember
> reading about markdown syntax on the XWiki Syntax guide.
>
> Thanks,
> Chetan
>
>
>



-- 

"Whether you think you can or think you can't, you're right." -- Henry Ford

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Creating Nested Page Hierarchies

2016-03-24 Thread Personal
I am attempting to utilize the example code from the links I mentioned earlier 
but update it to reflect that the parent-child relationship is deprecated under 
the new Nested Pages concept. This is the code I have so far:

{{velocity}}
#set($query="where doc.space='$doc.getSpace()'")
#set($results = false)
#set($results = $xwiki.searchDocuments($query, 10, 0))
#set($first = true)
#foreach($docname in $results)
#set($rdoc = $xwiki.getDocument($docname).getTranslatedDocument())
[[$rdoc.getDisplayTitle()>>$rdoc.fullName]]
#end
{{/velocity}}

It works to a point but the results look like this:

Test Child 2 
Test Child 6 
Test 
Test Child 1 
Test Child 3 
Test Child 5 
Test Child 0 
Test Child 4 

The ‘Test’ page listed represents the page containing the code which I would 
consider the parent or container page and the nested pages are in no 
discernible order. These nested pages were all generated with a script (if 
helpful I can provide the code) using an array of names and a foreach loop, so 
I would expect that they were created in the order the names were provided in 
the array which was ascending order. Also I notice that alphanumeric sort order 
seems to be the default in Xwiki so I am a little surprised by these results.

Any helpful advice you can provide to remove the container page and sort the 
results would be appreciated.

Regards,

Jesse Bright


> On Mar 20, 2016, at 5:26 PM, Jesse Bright  wrote:
> 
> Never mind, I found these after I posted:
> 
> http://platform.xwiki.org/xwiki/bin/view/DevGuide/APIGuide#HCreateanewDocument
> http://extensions.xwiki.org/xwiki/bin/view/Extension/Immediate+Children+Pages
> 
> I had search for this before but without including 'velocity' in the search I 
> was only getting the more basic instructions. 
> 
> Regards,
> 
> Jesse
> 
>> On Mar 19, 2016, at 1:55 PM, Personal  wrote:
>> 
>> I am creating a knowledge base for a local municipal code which follows a 
>> typical book hierarchy. I plan on using nested pages to create a pages 
>> hierarchy for navigating and searching the code text at different levels. 
>> For example each end page would have a space path like so:
>> 
>> Title 19.Part 2.Chapter 4.Section 100
>> Title 19.Part 2.Chapter 4.Section 200
>> etc.
>> 
>> Currently I am using a Velocity macro to create links to each child page and 
>> at the chapter level I also start including the child pages. I then follow 
>> the links to make the child pages. This works relatively well but has a 
>> couple of disadvantages. 1) It is slow to create each page by repeatedly 
>> following the links, selecting the template and pasting the next tier of 
>> code. 2) It hardcodes the child page names which if changed (say due to a 
>> typo) must be updated by hand each time.
>> 
>> I am wondering if there is a more efficient way that I can automate the page 
>> and link creation process. Ideally I would have a way to create the complete 
>> page hierarchy by providing the names and levels of each page with the same 
>> code in each page providing a link to each child of that page. Then I could 
>> paste the content text into each page at the end of the branch. I have done 
>> something similar to this using Jeykell but that is much simpler as it is 
>> static content based on the file structure. If I am going about this all the 
>> wrong way I am open to other suggestions.
>> 
>> Regards,
>> 
>> Jesse
>> 
>> ___
>> users mailing list
>> users@xwiki.org
>> http://lists.xwiki.org/mailman/listinfo/users
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Nested pages livetable

2016-03-24 Thread CarlJ
Hi,

I hate to bug but is there no way to display the children of a page in a
livetable, because if there isn't I am going to have restore my wiki back to
before I upgraded from our backup.

Thanks and sorry to bug. 
- Carl



--
View this message in context: 
http://xwiki.475771.n2.nabble.com/Nested-pages-livetable-tp7598571p7598627.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Does XWiki support markdown syntax?

2016-03-24 Thread Thomas Mortagne
There is indeed nothing in
http://www.xwiki.org/xwiki/bin/view/XWiki/XWikiSyntax but you can look
at http://rendering.xwiki.org/xwiki/bin/view/Main/Markdown11.

On Thu, Mar 24, 2016 at 12:28 PM, Chetan Kumar
 wrote:
> Does XWiki support markdown syntax?
>
> This commit-history link makes it seem so:
> https://github.com/xwiki/xwiki-rendering/pull/1. But I don’t remember
> reading about markdown syntax on the XWiki Syntax guide.
>
> Thanks,
> Chetan
> ___
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users



-- 
Thomas Mortagne
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


[xwiki-users] Does XWiki support markdown syntax?

2016-03-24 Thread Chetan Kumar
Does XWiki support markdown syntax?

This commit-history link makes it seem so:
https://github.com/xwiki/xwiki-rendering/pull/1. But I don’t remember
reading about markdown syntax on the XWiki Syntax guide.

Thanks,
Chetan
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XAR-Import

2016-03-24 Thread Bruno

Hello,
I also had problems with importing XAR (a big one).
In the end, I adjusted some parameters in my config.
Here is what I did :
- in /etc/mysql/my.cnf I set the parameter key_buffer_size from 16 M to 
64M and max_allowed_packet 16 M to 128 M
- in /etc/xwiki/xwiki.cfg I increased the value of the parameter 
xwiki.store.cache.capacity to 1500
- I increased the memory assigned to Java. My config (one processor) : 
JAVA_OPTS='-Djava.awt.headless true -Xmx2g -XX MaxPermSize 256m 
-Dfile.encoding utf-8 -XX -XX UseConcMarkSweepGC CMSIncrementalMode'


I hope it can help.

Regards,
Signature mails
_

Bruno Joffredo

Ecole Centrale de Nantes

Centre de Ressources Informatiques - Bur. D019

1 rue de la Noë

BP 92101

F-44321 Nantes cedex 3

Tél. 02.40.37.68.06
Mail : bruno.joffr...@ec-nantes.fr 
_


Le 22/03/2016 09:56, Thomas Mortagne a écrit :

On Mon, Mar 21, 2016 at 8:28 PM, Matthias Wegner  wrote:

Ha, ha. I just build a custom xar for you to reproduce the bug and compared
it to an export from xwiki with the same content. And now i see the problem.
I had the following structure:

THIS IS NOT WORKING
book.xar
  |_ package.xml
  |_Book
 |_article1
 |   |_WebHome.xml
 |_article2
 |_WebHome.xml

THIS IS WORKING
book.xar
  |_ package.xml
  |_Book
 |_article1
 |   |_WebHome.xml
 |_article2
 |   |_WebHome.xml
 |_WebHome.xml

I missed the WebHome.xml of the "Space". In my Wiki this is empty, so it is
in my opinion useless to import. But it seems that the importer can not
handle the missing WebHome.xml of the space. I thought about an
encoding-problem or something like that, but it was only a missing file.
Maybe some exception would be great if the integrity of mandatory files or
fields is not there. I had no clue where to look because no log shows any
exception.

So, thanks for assistence. Your questions lead me the way ;)

The missing WebHome.xml should not prevent the import from working
since its not mandatory to have a WebHome associated to a space, you
should definitely create an issue on jira.xwiki.org/jira/browse/XWIKI
with detail on how to reproduce it.


Regards,
Matthias


Am 21.03.2016 um 15:33 schrieb Thomas Mortagne:

Do you see anything in the log ?

If that's a XAR you can safely share and its not too big you should
probably create an issue on http://jira.xwiki.org so that we could
reproduce it.

On Mon, Mar 21, 2016 at 3:30 PM, Matthias Wegner 
wrote:

IT teils Nothing. The right Circle Moves and it seems that it can not
read. It shows no files.

Regards, Matthias

Von unterwegs gesendet


Am 21.03.2016 um 11:51 schrieb Thomas Mortagne
:

What dos the UI tells you when you try to import ? Does it find
documents in the XAR ?


On Sun, Mar 20, 2016 at 9:58 PM, Matthias Wegner
 wrote:
Hi Users,

i made a custom xar-file because i want to import some content into
XWiki
8.0. But it seems to stuck. i can upload the file but it is never
imported.

The request.log show only
127.0.0.1 - - [20/Mrz/2016:20:51:39 +] "POST
/xwiki/bin/upload/XWiki/XWikiPreferences HTTP/1.1" 302 -
127.0.0.1 - - [20/Mrz/2016:20:51:40 +] "GET

/xwiki/bin/get/XWiki/XWikiPreferences?xpage=packagelist=1
HTTP/1.1" 200 946
127.0.0.1 - - [20/Mrz/2016:20:51:41 +] "POST

/xwiki/bin/get/XWiki/XWikiPreferences?xpage=packagedescriptor=B.xar
HTTP/1.1" 200 133

so i have no clue whats wrong. My created xml-files seem correct. Can i
send
you an example, so you can test why it is not working? I have no idea.

Regards,
Matthias



--
View this message in context:
http://xwiki.475771.n2.nabble.com/XAR-Import-tp7598556.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users



--
Thomas Mortagne
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users




___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users





___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users