Hello,
I also had problems with importing XAR (a big one).
In the end, I adjusted some parameters in my config.
Here is what I did :
- in /etc/mysql/my.cnf I set the parameter key_buffer_size from 16 M to 64M and max_allowed_packet 16 M to 128 M - in /etc/xwiki/xwiki.cfg I increased the value of the parameter xwiki.store.cache.capacity to 1500 - I increased the memory assigned to Java. My config (one processor) : JAVA_OPTS='-Djava.awt.headless true -Xmx2g -XX MaxPermSize 256m -Dfile.encoding utf-8 -XX -XX UseConcMarkSweepGC CMSIncrementalMode'

I hope it can help.

Regards,
Signature mails
_________________________________________________

Bruno Joffredo

Ecole Centrale de Nantes

Centre de Ressources Informatiques - Bur. D019

1 rue de la Noë

BP 92101

F-44321 Nantes cedex 3

Tél. 02.40.37.68.06
Mail : bruno.joffr...@ec-nantes.fr <mailto:bruno.joffr...@ec-nantes.fr>
_________________________________________________


Le 22/03/2016 09:56, Thomas Mortagne a écrit :
On Mon, Mar 21, 2016 at 8:28 PM, Matthias Wegner <mic.mat.weg...@web.de> wrote:
Ha, ha. I just build a custom xar for you to reproduce the bug and compared
it to an export from xwiki with the same content. And now i see the problem.
I had the following structure:

THIS IS NOT WORKING
book.xar
  |_ package.xml
  |_Book
     |_article1
     |   |_WebHome.xml
     |_article2
         |_WebHome.xml

THIS IS WORKING
book.xar
  |_ package.xml
  |_Book
     |_article1
     |   |_WebHome.xml
     |_article2
     |   |_WebHome.xml
     |_WebHome.xml

I missed the WebHome.xml of the "Space". In my Wiki this is empty, so it is
in my opinion useless to import. But it seems that the importer can not
handle the missing WebHome.xml of the space. I thought about an
encoding-problem or something like that, but it was only a missing file.
Maybe some exception would be great if the integrity of mandatory files or
fields is not there. I had no clue where to look because no log shows any
exception.

So, thanks for assistence. Your questions lead me the way ;)
The missing WebHome.xml should not prevent the import from working
since its not mandatory to have a WebHome associated to a space, you
should definitely create an issue on jira.xwiki.org/jira/browse/XWIKI
with detail on how to reproduce it.

Regards,
Matthias


Am 21.03.2016 um 15:33 schrieb Thomas Mortagne:
Do you see anything in the log ?

If that's a XAR you can safely share and its not too big you should
probably create an issue on http://jira.xwiki.org so that we could
reproduce it.

On Mon, Mar 21, 2016 at 3:30 PM, Matthias Wegner <mic.mat.weg...@web.de>
wrote:
IT teils Nothing. The right Circle Moves and it seems that it can not
read. It shows no files.

Regards, Matthias

Von unterwegs gesendet

Am 21.03.2016 um 11:51 schrieb Thomas Mortagne
<thomas.morta...@xwiki.com>:

What dos the UI tells you when you try to import ? Does it find
documents in the XAR ?

On Sun, Mar 20, 2016 at 9:58 PM, Matthias Wegner
<mic.mat.weg...@web.de> wrote:
Hi Users,

i made a custom xar-file because i want to import some content into
XWiki
8.0. But it seems to stuck. i can upload the file but it is never
imported.

The request.log show only
127.0.0.1 - - [20/Mrz/2016:20:51:39 +0000] "POST
/xwiki/bin/upload/XWiki/XWikiPreferences HTTP/1.1" 302 -
127.0.0.1 - - [20/Mrz/2016:20:51:40 +0000] "GET

/xwiki/bin/get/XWiki/XWikiPreferences?xpage=packagelist&forceTestRights=1
HTTP/1.1" 200 946
127.0.0.1 - - [20/Mrz/2016:20:51:41 +0000] "POST

/xwiki/bin/get/XWiki/XWikiPreferences?xpage=packagedescriptor&package=B.xar
HTTP/1.1" 200 133

so i have no clue whats wrong. My created xml-files seem correct. Can i
send
you an example, so you can test why it is not working? I have no idea.

Regards,
Matthias



--
View this message in context:
http://xwiki.475771.n2.nabble.com/XAR-Import-tp7598556.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


--
Thomas Mortagne
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users



_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to