Re: [PATCH 2/2] input: Warn if the touch point up and down events get out of sync

2013-09-24 Thread Bill Spitzak
Neil Roberts wrote: Bill Spitzak writes: I really really think this idea should be changed. Clients should just be prepared for excess up and down events, and excess focus in/out. Avoiding them becomes nearly impossible as you are probably noticing, and pretty much means the compositor mu

[xkbcommon] Make C++ happy.

2013-09-24 Thread Wander Lairson Costa
C++ has a stronger type system than C and will not implicitly convert int's to enum's. If we do not want to give any flags to xkb_context_new, we must pass 0 as its argument. Therefore, we create a valid xkb_context_flags enum 0 value to avoid ugly casts in C++. Signed-off-by: Wander Lairson Cost

[xkbcommon] How to distinguish left-shift and right-shift

2013-09-24 Thread Wander Lairson Costa
Hi, I am working for some time porting Blender to wayland [1] and I am now adding keyboard handing support. For that, I am following weston clients code as reference and using libxkbcommon. To make a long history short, I need to differentiate left-shift and right-shift modifiers, but I didn't fi

Re: [PATCH 2/2] input: Warn if the touch point up and down events get out of sync

2013-09-24 Thread Neil Roberts
Bill Spitzak writes: > I really really think this idea should be changed. Clients should just > be prepared for excess up and down events, and excess focus in/out. > Avoiding them becomes nearly impossible as you are probably noticing, > and pretty much means the compositor must maintain the stat

Re: [RFC DRAFT] graphics tablet protocol extension

2013-09-24 Thread Peter Hutterer
On Tue, Sep 24, 2013 at 12:41:50PM -0700, Bill Spitzak wrote: > > > Peter Hutterer wrote: > >Thanks for testing this. I'm currently tempted to have the pad buttons > >(that's the terminology we use in the xorg wacom driver, so let's use it > >here too) should have a separate focus, and a separate

Re: [PATCH 2/2] input: Warn if the touch point up and down events get out of sync

2013-09-24 Thread Bill Spitzak
Neil Roberts wrote: The weston_seat struct now keeps a bit mask of the touch points that are pressed so that it can give a warning if it gets a down event for a finger that is already down or an up event for one that is already up. --- I was using this patch to test bug 67563 but I think it co

Re: [PATCH] version.h: Add version check macro

2013-09-24 Thread Bill Spitzak
Kristian Høgsberg wrote: On Tue, Sep 24, 2013 at 12:54 AM, Marc Chalain wrote: But the WESTON_VERSION_AT_LEAST macro is wrong. You can check only the minor and not the rest of the version. No, we don't guarantee plugin API stability between x.y releases, only micro releases 1.2.x ma

Re: [RFC DRAFT] graphics tablet protocol extension

2013-09-24 Thread Bill Spitzak
Peter Hutterer wrote: Thanks for testing this. I'm currently tempted to have the pad buttons (that's the terminology we use in the xorg wacom driver, so let's use it here too) should have a separate focus, and a separate event. so the interface expands to: wl_tablet::proximity in ::pr

Re: [RFC wayland] scanner: provide convenience defines for NULL handlers

2013-09-24 Thread Peter Hutterer
On Thu, Sep 19, 2013 at 12:50:23PM +0300, Pekka Paalanen wrote: > On Thu, 19 Sep 2013 13:54:34 +1000 > Peter Hutterer wrote: > > > Instead of NULL, a client that doesn't implement all callbacks of a listener > > can use named defines to increase readability of the code. For example: > > > > cons

Re: [PATCH] version.h: Add version check macro

2013-09-24 Thread Kristian Høgsberg
On Tue, Sep 24, 2013 at 12:54 AM, Marc Chalain wrote: > But the WESTON_VERSION_AT_LEAST macro is wrong. You can check only the minor > and not the rest of the version. No, we don't guarantee plugin API stability between x.y releases, only micro releases 1.2.x maintain that interface. Something d

Re: [RFC DRAFT] graphics tablet protocol extension

2013-09-24 Thread Peter Hutterer
On Sat, Sep 21, 2013 at 10:09:25AM -0700, Bill Spitzak wrote: > On 09/20/2013 03:35 AM, Peter Hutterer wrote: > > >* focus handling for the stylus is easy. focus handling for the buttons on > > the pad isn't. they could technically be focused elsewhere, like a > > keyboard focus. some buttons

[PATCH 2/2] input: Warn if the touch point up and down events get out of sync

2013-09-24 Thread Neil Roberts
The weston_seat struct now keeps a bit mask of the touch points that are pressed so that it can give a warning if it gets a down event for a finger that is already down or an up event for one that is already up. --- I was using this patch to test bug 67563 but I think it could be a good idea to la

[PATCH 1/2] Fix a typo in a log message

2013-09-24 Thread Neil Roberts
Without the space it would end up printing ‘downbut’. --- src/input.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/input.c b/src/input.c index 1313b52..0c3e480 100644 --- a/src/input.c +++ b/src/input.c @@ -1115,7 +1115,7 @@ notify_touch(struct weston_seat *seat, uint32_

Re: [PATCH] version.h: Add version check macro

2013-09-24 Thread Marc Chalain
But the WESTON_VERSION_AT_LEAST macro is wrong. You can check only the minor and not the rest of the version. 2013/9/23 Kristian Høgsberg > On Mon, Sep 23, 2013 at 10:39:08AM -0700, Kristian Høgsberg wrote: > > On Mon, Sep 23, 2013 at 07:26:03AM +0200, Pier Luigi Fiorini wrote: > > > Make it ea