[webkit-changes] [179621] trunk/Source/JavaScriptCore

2015-02-04 Thread saambarati1
Title: [179621] trunk/Source/_javascript_Core Revision 179621 Author saambara...@gmail.com Date 2015-02-04 12:03:52 -0800 (Wed, 04 Feb 2015) Log Message TypeSet can use 1 byte instead of 4 bytes for its m_seenTypes member variable https://bugs.webkit.org/show_bug.cgi?id=141204 Reviewed

[webkit-changes] [179682] trunk

2015-02-05 Thread saambarati1
Title: [179682] trunk Revision 179682 Author saambara...@gmail.com Date 2015-02-05 00:58:38 -0800 (Thu, 05 Feb 2015) Log Message Crash in uninitialized deconstructing variable. https://bugs.webkit.org/show_bug.cgi?id=141070 Reviewed by Michael Saboff. Source/_javascript_Core:

[webkit-changes] [179479] trunk

2015-02-02 Thread saambarati1
Title: [179479] trunk Revision 179479 Author saambara...@gmail.com Date 2015-02-02 11:05:46 -0800 (Mon, 02 Feb 2015) Log Message Create tests for JSC's Control Flow Profiler https://bugs.webkit.org/show_bug.cgi?id=141123 Reviewed by Filip Pizlo. Source/_javascript_Core: This patch

[webkit-changes] [179865] trunk/Source/JavaScriptCore

2015-02-09 Thread saambarati1
Title: [179865] trunk/Source/_javascript_Core Revision 179865 Author saambara...@gmail.com Date 2015-02-09 23:40:53 -0800 (Mon, 09 Feb 2015) Log Message JSC's Type Profiler doesn't profile the type of the looping variable in ForOf/ForIn loops

[webkit-changes] [179873] trunk/Source/JavaScriptCore

2015-02-10 Thread saambarati1
Title: [179873] trunk/Source/_javascript_Core Revision 179873 Author saambara...@gmail.com Date 2015-02-10 11:01:41 -0800 (Tue, 10 Feb 2015) Log Message Parser::parseVarDeclarationList gets the wrong JSToken for the last identifier https://bugs.webkit.org/show_bug.cgi?id=141272 Reviewed

[webkit-changes] [181331] trunk/Source/WebInspectorUI

2015-03-10 Thread saambarati1
Title: [181331] trunk/Source/WebInspectorUI Revision 181331 Author saambara...@gmail.com Date 2015-03-10 11:47:04 -0700 (Tue, 10 Mar 2015) Log Message Web Inspector: Destructuring function parameters should show type information https://bugs.webkit.org/show_bug.cgi?id=142233 Reviewed by

[webkit-changes] [182114] trunk/Source

2015-03-28 Thread saambarati1
Title: [182114] trunk/Source Revision 182114 Author saambara...@gmail.com Date 2015-03-28 10:28:11 -0700 (Sat, 28 Mar 2015) Log Message Web Inspector: ES6: Better support for Symbol types in Type Profiler https://bugs.webkit.org/show_bug.cgi?id=141257 Reviewed by Joseph Pecoraro.

[webkit-changes] [180518] trunk/Source/JavaScriptCore

2015-02-23 Thread saambarati1
Title: [180518] trunk/Source/_javascript_Core Revision 180518 Author saambara...@gmail.com Date 2015-02-23 14:10:51 -0800 (Mon, 23 Feb 2015) Log Message Adjust the ranges of basic block statements in JSC's control flow profiler to be mutually exclusive

[webkit-changes] [180526] trunk/Source/WebInspectorUI

2015-02-23 Thread saambarati1
Title: [180526] trunk/Source/WebInspectorUI Revision 180526 Author saambara...@gmail.com Date 2015-02-23 15:18:29 -0800 (Mon, 23 Feb 2015) Log Message Web Inspector: BasicBlockAnnotator ranges should be inclusive of both the start and end offset

[webkit-changes] [182083] trunk/Source/JavaScriptCore

2015-03-27 Thread saambarati1
Title: [182083] trunk/Source/_javascript_Core Revision 182083 Author saambara...@gmail.com Date 2015-03-27 14:56:35 -0700 (Fri, 27 Mar 2015) Log Message Add back previously broken assert from bug 141869 https://bugs.webkit.org/show_bug.cgi?id=143005 Reviewed by Michael Saboff. *

[webkit-changes] [181889] trunk

2015-03-24 Thread saambarati1
Title: [181889] trunk Revision 181889 Author saambara...@gmail.com Date 2015-03-24 00:30:05 -0700 (Tue, 24 Mar 2015) Log Message Improve error messages in JSC https://bugs.webkit.org/show_bug.cgi?id=141869 Reviewed by Geoffrey Garen. Source/_javascript_Core: _javascript_Core has some

[webkit-changes] [182109] trunk

2015-03-28 Thread saambarati1
Title: [182109] trunk Revision 182109 Author saambara...@gmail.com Date 2015-03-27 23:01:33 -0700 (Fri, 27 Mar 2015) Log Message Deconstruction parameters are bound too late https://bugs.webkit.org/show_bug.cgi?id=143148 Reviewed by Filip Pizlo. Source/_javascript_Core: Currently, a

[webkit-changes] [179390] trunk/Source/WebInspectorUI

2015-01-29 Thread saambarati1
Title: [179390] trunk/Source/WebInspectorUI Revision 179390 Author saambara...@gmail.com Date 2015-01-29 20:02:25 -0800 (Thu, 29 Jan 2015) Log Message Web Inspector: Make BasicBlockAnnotator lessen the saturation of syntax highlighting instead of graying out unexecuted code

[webkit-changes] [179396] trunk/Source/WebInspectorUI

2015-01-29 Thread saambarati1
Title: [179396] trunk/Source/WebInspectorUI Revision 179396 Author saambara...@gmail.com Date 2015-01-29 23:24:20 -0800 (Thu, 29 Jan 2015) Log Message Web Inspector: Allow text selection when the BasicBlockAnnotator is enabled https://bugs.webkit.org/show_bug.cgi?id=140987 Reviewed by

[webkit-changes] [183754] trunk/Source/JavaScriptCore

2015-05-04 Thread saambarati1
Title: [183754] trunk/Source/_javascript_Core Revision 183754 Author saambara...@gmail.com Date 2015-05-04 11:47:33 -0700 (Mon, 04 May 2015) Log Message JSCallbackObject does not maintain symmetry between accesses for getOwnPropertySlot and put

[webkit-changes] [183789] trunk/Source/JavaScriptCore

2015-05-04 Thread saambarati1
Title: [183789] trunk/Source/_javascript_Core Revision 183789 Author saambara...@gmail.com Date 2015-05-04 20:27:09 -0700 (Mon, 04 May 2015) Log Message Global functions should be initialized as JSFunctions in byte code https://bugs.webkit.org/show_bug.cgi?id=144178 Reviewed by Geoffrey

[webkit-changes] [183962] trunk

2015-05-07 Thread saambarati1
Title: [183962] trunk Revision 183962 Author saambara...@gmail.com Date 2015-05-07 17:20:58 -0700 (Thu, 07 May 2015) Log Message exceptionFuzz tests should explicitly initialize the exceptionFuzz boolean in _javascript_ code through a function in jsc.cpp

[webkit-changes] [183972] trunk/Source/JavaScriptCore

2015-05-07 Thread saambarati1
Title: [183972] trunk/Source/_javascript_Core Revision 183972 Author saambara...@gmail.com Date 2015-05-07 18:59:14 -0700 (Thu, 07 May 2015) Log Message Global functions should be initialized as JSFunctions in byte code https://bugs.webkit.org/show_bug.cgi?id=144178 Reviewed by Geoffrey

[webkit-changes] [185699] trunk

2015-06-18 Thread saambarati1
Title: [185699] trunk Revision 185699 Author saambara...@gmail.com Date 2015-06-18 05:35:32 -0700 (Thu, 18 Jun 2015) Log Message [ES6] support default values in deconstruction parameter nodes https://bugs.webkit.org/show_bug.cgi?id=142679 Reviewed by Darin Adler.

[webkit-changes] [185596] trunk/Source/JavaScriptCore

2015-06-16 Thread saambarati1
Title: [185596] trunk/Source/_javascript_Core Revision 185596 Author saambara...@gmail.com Date 2015-06-16 11:34:24 -0700 (Tue, 16 Jun 2015) Log Message LLInt's code path for get_from_scope with case GlobalVarWithVarInjectionChecks has dead code

[webkit-changes] [186246] trunk

2015-07-02 Thread saambarati1
Title: [186246] trunk Revision 186246 Author saambara...@gmail.com Date 2015-07-02 16:53:10 -0700 (Thu, 02 Jul 2015) Log Message Rename Deconstruction to Destructuring throughout JSC https://bugs.webkit.org/show_bug.cgi?id=146100 Reviewed by Mark Lam. Source/_javascript_Core: It is

[webkit-changes] [186379] trunk

2015-07-06 Thread saambarati1
Title: [186379] trunk Revision 186379 Author saambara...@gmail.com Date 2015-07-06 15:18:58 -0700 (Mon, 06 Jul 2015) Log Message JSC's parser should follow the ES6 spec with respect to parsing Declarations https://bugs.webkit.org/show_bug.cgi?id=146621 Reviewed by Mark Lam.

[webkit-changes] [184747] trunk/Source/JavaScriptCore

2015-05-21 Thread saambarati1
Title: [184747] trunk/Source/_javascript_Core Revision 184747 Author saambara...@gmail.com Date 2015-05-21 19:39:25 -0700 (Thu, 21 May 2015) Log Message Object allocation sinking phase should explicitly create bottom values for CreateActivation sink candidates and CreateActivation should

[webkit-changes] [188789] trunk/Websites/webkit.org

2015-08-21 Thread saambarati1
Title: [188789] trunk/Websites/webkit.org Revision 188789 Author saambara...@gmail.com Date 2015-08-21 15:12:53 -0700 (Fri, 21 Aug 2015) Log Message Add resources for type profiler and code coverage profiler blog post. * blog-files/type-profiler-and-code-coverage-profiler: Added. *

[webkit-changes] [188794] trunk/Websites/webkit.org

2015-08-21 Thread saambarati1
Title: [188794] trunk/Websites/webkit.org Revision 188794 Author saambara...@gmail.com Date 2015-08-21 16:16:48 -0700 (Fri, 21 Aug 2015) Log Message Edit a resource for type profiler and code coverage profiler blog post. *

[webkit-changes] [188830] trunk/Websites/webkit.org

2015-08-22 Thread saambarati1
Title: [188830] trunk/Websites/webkit.org Revision 188830 Author saambara...@gmail.com Date 2015-08-22 15:46:53 -0700 (Sat, 22 Aug 2015) Log Message Add 1x/2x resources for type profiler and code coverage profiler blog post. *

[webkit-changes] [188832] trunk/Websites/webkit.org

2015-08-22 Thread saambarati1
Title: [188832] trunk/Websites/webkit.org Revision 188832 Author saambara...@gmail.com Date 2015-08-22 19:28:09 -0700 (Sat, 22 Aug 2015) Log Message Change image for type profiler and code coverage profiler blog post. *

[webkit-changes] [188831] trunk/Websites/webkit.org

2015-08-22 Thread saambarati1
Title: [188831] trunk/Websites/webkit.org Revision 188831 Author saambara...@gmail.com Date 2015-08-22 16:05:36 -0700 (Sat, 22 Aug 2015) Log Message Change video for type profiler and code coverage profiler blog post. *

[webkit-changes] [188538] trunk/Tools

2015-08-17 Thread saambarati1
Title: [188538] trunk/Tools Revision 188538 Author saambara...@gmail.com Date 2015-08-17 13:29:09 -0700 (Mon, 17 Aug 2015) Log Message Change email address from saambara...@gmail.com to sbar...@apple.com * Scripts/webkitpy/common/config/contributors.json: Modified Paths

[webkit-changes] [188847] trunk/Websites/webkit.org

2015-08-23 Thread saambarati1
Title: [188847] trunk/Websites/webkit.org Revision 188847 Author saambara...@gmail.com Date 2015-08-23 22:27:59 -0700 (Sun, 23 Aug 2015) Log Message Change compiler-pipeline image for type profiler and code coverage profiler blog post. *

[webkit-changes] [187524] trunk/Source/JavaScriptCore

2015-07-28 Thread saambarati1
Title: [187524] trunk/Source/_javascript_Core Revision 187524 Author saambara...@gmail.com Date 2015-07-28 15:39:12 -0700 (Tue, 28 Jul 2015) Log Message Make the type profiler work with lexical scoping and add tests https://bugs.webkit.org/show_bug.cgi?id=145438 Reviewed by Geoffrey

[webkit-changes] [187717] trunk/Source/JavaScriptCore

2015-08-01 Thread saambarati1
Title: [187717] trunk/Source/_javascript_Core Revision 187717 Author saambara...@gmail.com Date 2015-08-01 08:27:11 -0700 (Sat, 01 Aug 2015) Log Message Unreviewed. Remove unintentional print statement in test case. https://bugs.webkit.org/show_bug.cgi?id=142567 *

[webkit-changes] [187680] trunk

2015-07-31 Thread saambarati1
Title: [187680] trunk Revision 187680 Author saambara...@gmail.com Date 2015-07-31 14:05:19 -0700 (Fri, 31 Jul 2015) Log Message ES6 class syntax should use block scoping https://bugs.webkit.org/show_bug.cgi?id=142567 Reviewed by Geoffrey Garen. Source/_javascript_Core: We treat class

[webkit-changes] [187515] trunk/Source/JavaScriptCore

2015-07-28 Thread saambarati1
Title: [187515] trunk/Source/_javascript_Core Revision 187515 Author saambara...@gmail.com Date 2015-07-28 14:39:34 -0700 (Tue, 28 Jul 2015) Log Message Implement catch scope using lexical scoping constructs introduced with let scoping patch https://bugs.webkit.org/show_bug.cgi?id=146979

[webkit-changes] [188136] trunk/Source/JavaScriptCore

2015-08-07 Thread saambarati1
Title: [188136] trunk/Source/_javascript_Core Revision 188136 Author saambara...@gmail.com Date 2015-08-07 10:41:22 -0700 (Fri, 07 Aug 2015) Log Message Interpreter::unwind shouldn't be responsible for assigning the correct scope. https://bugs.webkit.org/show_bug.cgi?id=147666 Reviewed

[webkit-changes] [187969] trunk/Source/JavaScriptCore

2015-08-05 Thread saambarati1
Title: [187969] trunk/Source/_javascript_Core Revision 187969 Author saambara...@gmail.com Date 2015-08-05 11:29:25 -0700 (Wed, 05 Aug 2015) Log Message Replace JSFunctionNameScope with JSLexicalEnvironment for the function name scope. https://bugs.webkit.org/show_bug.cgi?id=147657

[webkit-changes] [187991] trunk/Source/JavaScriptCore

2015-08-05 Thread saambarati1
Title: [187991] trunk/Source/_javascript_Core Revision 187991 Author saambara...@gmail.com Date 2015-08-05 14:45:20 -0700 (Wed, 05 Aug 2015) Log Message Bytecodegenerator emits crappy code for returns in a lexical scope. https://bugs.webkit.org/show_bug.cgi?id=147688 Reviewed by Mark

[webkit-changes] [187437] trunk/Source/JavaScriptCore

2015-07-27 Thread saambarati1
Title: [187437] trunk/Source/_javascript_Core Revision 187437 Author saambara...@gmail.com Date 2015-07-27 11:52:19 -0700 (Mon, 27 Jul 2015) Log Message Added a comment explaining that all addVar()s should happen before emitting bytecode for a function's default parameter expressions

[webkit-changes] [187460] trunk/Source/JavaScriptCore

2015-07-27 Thread saambarati1
Title: [187460] trunk/Source/_javascript_Core Revision 187460 Author saambara...@gmail.com Date 2015-07-27 16:04:43 -0700 (Mon, 27 Jul 2015) Log Message Reduce execution time for let and const tests https://bugs.webkit.org/show_bug.cgi?id=147291 Reviewed by Geoffrey Garen. We don't

[webkit-changes] [187111] trunk/Source/JavaScriptCore

2015-07-21 Thread saambarati1
Title: [187111] trunk/Source/_javascript_Core Revision 187111 Author saambara...@gmail.com Date 2015-07-21 12:18:47 -0700 (Tue, 21 Jul 2015) Log Message DestructuringPatternNode and DestructuringAssignmentNode should be ParserArenaFreeable https://bugs.webkit.org/show_bug.cgi?id=147140

[webkit-changes] [187119] trunk/Source/JavaScriptCore

2015-07-21 Thread saambarati1
Title: [187119] trunk/Source/_javascript_Core Revision 187119 Author saambara...@gmail.com Date 2015-07-21 13:22:37 -0700 (Tue, 21 Jul 2015) Log Message ObjectPatternNode's entry should use const Identifier instead of Identifier https://bugs.webkit.org/show_bug.cgi?id=147156 Reviewed by

[webkit-changes] [187351] trunk

2015-07-24 Thread saambarati1
Title: [187351] trunk Revision 187351 Author saambara...@gmail.com Date 2015-07-24 11:40:58 -0700 (Fri, 24 Jul 2015) Log Message [ES6] Add support for default parameters https://bugs.webkit.org/show_bug.cgi?id=38409 Reviewed by Filip Pizlo. Source/_javascript_Core: This patch

[webkit-changes] [186996] trunk/Source/JavaScriptCore

2015-07-18 Thread saambarati1
Title: [186996] trunk/Source/_javascript_Core Revision 186996 Author saambara...@gmail.com Date 2015-07-18 13:12:14 -0700 (Sat, 18 Jul 2015) Log Message lexical scoping is broken with respect to break and continue https://bugs.webkit.org/show_bug.cgi?id=147063 Reviewed by Filip Pizlo.

[webkit-changes] [187003] trunk/Source/JavaScriptCore

2015-07-18 Thread saambarati1
Title: [187003] trunk/Source/_javascript_Core Revision 187003 Author saambara...@gmail.com Date 2015-07-18 17:36:45 -0700 (Sat, 18 Jul 2015) Log Message lexical scoping is broken with respect to break and continue https://bugs.webkit.org/show_bug.cgi?id=147063 Reviewed by Filip Pizlo.

[webkit-changes] [187014] trunk

2015-07-19 Thread saambarati1
Title: [187014] trunk Revision 187014 Author saambara...@gmail.com Date 2015-07-19 12:31:36 -0700 (Sun, 19 Jul 2015) Log Message Parser::parseFunctionInfo hits RELEASE_ASSERT for Arrow Functions https://bugs.webkit.org/show_bug.cgi?id=147090 Reviewed by Yusuke Suzuki.

[webkit-changes] [187033] trunk/Source/JavaScriptCore

2015-07-20 Thread saambarati1
Title: [187033] trunk/Source/_javascript_Core Revision 187033 Author saambara...@gmail.com Date 2015-07-20 14:16:41 -0700 (Mon, 20 Jul 2015) Log Message let scoping introduced incoherent story about symbol table cloning https://bugs.webkit.org/show_bug.cgi?id=147046 Reviewed by Filip

[webkit-changes] [188904] trunk/Websites/webkit.org

2015-08-24 Thread saambarati1
Title: [188904] trunk/Websites/webkit.org Revision 188904 Author saambara...@gmail.com Date 2015-08-24 22:31:49 -0700 (Mon, 24 Aug 2015) Log Message Add mp4 version of types-changing video. * blog-files/type-profiler-and-code-coverage-profiler/types-changing.mp4: Added. Modified Paths

[webkit-changes] [188926] trunk/Source/JavaScriptCore

2015-08-25 Thread saambarati1
Title: [188926] trunk/Source/_javascript_Core Revision 188926 Author saambara...@gmail.com Date 2015-08-25 11:40:14 -0700 (Tue, 25 Aug 2015) Log Message Callee can be incorrectly overridden when it's captured https://bugs.webkit.org/show_bug.cgi?id=148400 Reviewed by Filip Pizlo. We

[webkit-changes] [189012] trunk/Source/JavaScriptCore

2015-08-26 Thread saambarati1
Title: [189012] trunk/Source/_javascript_Core Revision 189012 Author saambara...@gmail.com Date 2015-08-26 22:54:21 -0700 (Wed, 26 Aug 2015) Log Message MarkedBlock::allocateBlock will have the wrong allocation size when (sizeof(MarkedBlock) + bytes) is divisible by WTF::pageSize()

[webkit-changes] [188932] trunk/Source/JavaScriptCore

2015-08-25 Thread saambarati1
Title: [188932] trunk/Source/_javascript_Core Revision 188932 Author saambara...@gmail.com Date 2015-08-25 12:40:46 -0700 (Tue, 25 Aug 2015) Log Message Lets rename codeOriginIndex to callSiteIndex and get rid of CallFrame::Location. https://bugs.webkit.org/show_bug.cgi?id=148213

[webkit-changes] [189920] trunk/Source

2015-09-17 Thread saambarati1
Title: [189920] trunk/Source Revision 189920 Author saambara...@gmail.com Date 2015-09-17 11:30:04 -0700 (Thu, 17 Sep 2015) Log Message Interpreter::unwind() shouldn't be responsible for filtering out uncatchable exceptions https://bugs.webkit.org/show_bug.cgi?id=149228 Reviewed by Mark

[webkit-changes] [189544] trunk

2015-09-09 Thread saambarati1
Title: [189544] trunk Revision 189544 Author saambara...@gmail.com Date 2015-09-09 13:18:57 -0700 (Wed, 09 Sep 2015) Log Message DFG should have a debugging option that runs a phase that flushes all locals https://bugs.webkit.org/show_bug.cgi?id=148916 Reviewed by Filip Pizlo.