Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFooclearStyleResolver

2013-06-18 Thread Gavin Barraclough
On Jun 18, 2013, at 10:16 PM, Ryosuke Niwa wrote: > On Tue, Jun 18, 2013 at 7:20 PM, Simon Fraser wrote: > On Jun 18, 2013, at 7:11 PM, Darin Adler wrote: > >> On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa wrote: >> >>> Why don't we call it requireStyleResolver() instead? >> >> I’m warming to t

Re: [webkit-dev] There is a linking error when build webkit on windows 7

2013-06-18 Thread ビリゴ スチン
It works! The Conclusion is : We must copy all lib files from WebKitLibraries/win/lib to WebKitLibraries/win/lib32 before first build. It is better to set it default. Thank you. > There is a script that runs at the start of the WTFGenerated build > (build-generated-files.sh) that checks for th

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Ryosuke Niwa
On Tue, Jun 18, 2013 at 7:20 PM, Simon Fraser wrote: > On Jun 18, 2013, at 7:11 PM, Darin Adler wrote: > > On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa wrote: > > Why don't we call it requireStyleResolver() instead? > > > I’m warming to this idea. Maybe we can use “require” as a term of art, > anal

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Maciej Stachowiak
If the semantic is essentially that of a getter that just happens to lazily create what it gets on demand, then I don't think "require" or "required" is needed. It can just be named as a getter. If the side effect is very important and especially if clients ever call the function only for its si

Re: [webkit-dev] There is a linking error when build webkit on windows 7

2013-06-18 Thread Brent Fulgham
Hi Siqinbilige: On Jun 18, 2013, at 8:31 PM, ビリゴ スチン wrote: > Yes, There is a WebKitLibraries/win/lib32 folder and also have > WebKitLibraries/win/lib folder. > first, there is one file WebKitSystemInterface.lib. > I copied the all of the files which including libicuuc.lib from > WebKitLibrari

Re: [webkit-dev] There is a linking error when build webkit on windows 7

2013-06-18 Thread ビリゴ スチン
Hi brent, Thank you for your response. > All of that should be fine... > >> When I run build-webkit, first failed with libs. >> 1>LINK : fatal error LNK1181: 入力ファイル 'libicuuc.lib' を開けません。 > > First clue above... > >>1>Base64.obj : error LNK2019: 未解決の外部シンボル _u_charDirection_46 が関数 "enum >>

Re: [webkit-dev] There is a linking error when build webkit on windows 7

2013-06-18 Thread Brent Fulgham
Hi SiqinBilige: On Jun 18, 2013, at 8:03 PM, siqinbilige wrote: > I wan to build webkit on Windows. > My environment is : > Windows 7 Ultimate (Service Pack1) 64bit (japanese) > Intel(R) Core(TM) i7 CPU / 12.0GB Memory > VC++ 2010 Express > Microsoft Windows SDK for windows 7(7.1) > Safari

[webkit-dev] There is a linking error when build webkit on windows 7

2013-06-18 Thread siqinbilige
Hi, I wan to build webkit on Windows. My environment is : Windows 7 Ultimate (Service Pack1) 64bit (japanese) Intel(R) Core(TM) i7 CPU / 12.0GB Memory VC++ 2010 Express Microsoft Windows SDK for windows 7(7.1) Safari 5.1.7 When I run build-webkit, first failed with libs. 1>LINK : fata

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Simon Fraser
On Jun 18, 2013, at 7:11 PM, Darin Adler wrote: > On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa wrote: > >> Why don't we call it requireStyleResolver() instead? > > I’m warming to this idea. Maybe we can use “require” as a term of art, > analogous to the way we use “create”, to mean “create if no

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Darin Adler
On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa wrote: > Why don't we call it requireStyleResolver() instead? I’m warming to this idea. Maybe we can use “require” as a term of art, analogous to the way we use “create”, to mean “create if not already created”. -- Darin ___

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Darin Adler
On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa wrote: > requiredStyleResolver sounds as if it's a special (required) type of a style > resolver as opposed to the caller requiring it. That is true. > Why don't we call it requireStyleResolver() instead? Functions with return values don’t read well w

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Ryosuke Niwa
On Tue, Jun 18, 2013 at 6:38 PM, Darin Adler wrote: > Lets bike shed! > > For some time, functions with names like fooIfExists and ensureFoo have > been bothering me. I find both names kind of opaque and unpleasant. Here’s > an example: > > StyleResolver* styleResolverIfExists(); > StyleR

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Emil A Eklund
On Tue, Jun 18, 2013 at 6:38 PM, Darin Adler wrote: > What do you think of these names instead? > > StyleResolver* optionalStyleResolver(); > StyleResolver& requiredStyleResolver(); +1, much clearer and the pointer vs reference makes it even more so. Perhaps enough so that the required pr

[webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Darin Adler
Lets bike shed! For some time, functions with names like fooIfExists and ensureFoo have been bothering me. I find both names kind of opaque and unpleasant. Here’s an example: StyleResolver* styleResolverIfExists(); StyleResolver* ensureStyleResolver() What do you think of these names i

[webkit-dev] Functionality of create_activation and tear_off_activation

2013-06-18 Thread Abhishek Bichhawat
Hi, We are working on a research project involving webkit. We are currently using Webkit-r122160 and trying to understand the functionality of two of the opcodes  (op_create_activation and op_tear_off_activation), which are a part of the classical interpreter. Although, the classical interpreter