Re: [webkit-dev] Clarifying 3D feature defines

2015-04-24 Thread Martin Robinson
On Thu, Apr 23, 2015 at 4:48 PM, Simon Fraser simon.fra...@apple.com wrote:
 USE(3D_GRAPHICS) appears to surround WebGL code in general. I don’t see any 
 non-WebGL bits in a quick search.

It seems that USE(3D_GRAPHICS) simply enables GraphicsContext3D and
its helper classes, so I propose that we rename this to
ENABLE_GRAPHICS_CONTEXT_3D.

--Martin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Clarifying 3D feature defines

2015-04-23 Thread Simon Fraser
On Apr 23, 2015, at 4:39 PM, Martin Robinson mrobin...@webkit.org wrote:
 
 In the process of cleaning up and dusting off the GTK+ cmake build
 system, we have rediscovered the pair of somewhat confusing feature
 defines WTF_USE_3D_GRAPHICS and ENABLE_3D_RENDERING. From a brief
 audit, it appears that WTF_USE_3D_GRAPHICS is a generic flag for any
 kind of 3D rendering at all (including WebGL), while
 ENABLE_3D_RENDERING refers specifically to perspective
 transformations.
 
 Would it be worthwhile to clarify these flags slightly? My proposal is
 to rename ENABLE_3D_RENDERING to either ENABLE_3D_TRANSFORMS or
 ENABLE_PERSPECTIVE_TRANSFORMS, though I support any names that reduce
 the possible confusion between these flags.

USE(3D_GRAPHICS) appears to surround WebGL code in general. I don’t see any 
non-WebGL bits in a quick search.

ENABLE(3D_RENDERING) means “turn on the ability to support and render 3D CSS 
transforms)”. I would be OK with  ENABLE_3D_TRANSFORMS, which is more accurate 
than ENABLE_PERSPECTIVE_TRANSFORMS.

Simon

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


[webkit-dev] Clarifying 3D feature defines

2015-04-23 Thread Martin Robinson
In the process of cleaning up and dusting off the GTK+ cmake build
system, we have rediscovered the pair of somewhat confusing feature
defines WTF_USE_3D_GRAPHICS and ENABLE_3D_RENDERING. From a brief
audit, it appears that WTF_USE_3D_GRAPHICS is a generic flag for any
kind of 3D rendering at all (including WebGL), while
ENABLE_3D_RENDERING refers specifically to perspective
transformations.

Would it be worthwhile to clarify these flags slightly? My proposal is
to rename ENABLE_3D_RENDERING to either ENABLE_3D_TRANSFORMS or
ENABLE_PERSPECTIVE_TRANSFORMS, though I support any names that reduce
the possible confusion between these flags.

--Martin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Clarifying 3D feature defines

2015-04-23 Thread Martin Robinson
Thanks for bringing up the point about perspective versus 3D
transforms. For the sake of clarity, one reason 3D_GRAPHICS may be
different from WebGL is that GraphicsContext3D is used to render
accelerated compositing contents when using the TextureMapper and not
simply WebGL.

--Martin

On Thu, Apr 23, 2015 at 4:48 PM, Simon Fraser simon.fra...@apple.com wrote:
 On Apr 23, 2015, at 4:39 PM, Martin Robinson mrobin...@webkit.org wrote:

 In the process of cleaning up and dusting off the GTK+ cmake build
 system, we have rediscovered the pair of somewhat confusing feature
 defines WTF_USE_3D_GRAPHICS and ENABLE_3D_RENDERING. From a brief
 audit, it appears that WTF_USE_3D_GRAPHICS is a generic flag for any
 kind of 3D rendering at all (including WebGL), while
 ENABLE_3D_RENDERING refers specifically to perspective
 transformations.

 Would it be worthwhile to clarify these flags slightly? My proposal is
 to rename ENABLE_3D_RENDERING to either ENABLE_3D_TRANSFORMS or
 ENABLE_PERSPECTIVE_TRANSFORMS, though I support any names that reduce
 the possible confusion between these flags.

 USE(3D_GRAPHICS) appears to surround WebGL code in general. I don’t see any 
 non-WebGL bits in a quick search.

 ENABLE(3D_RENDERING) means “turn on the ability to support and render 3D CSS 
 transforms)”. I would be OK with  ENABLE_3D_TRANSFORMS, which is more 
 accurate than ENABLE_PERSPECTIVE_TRANSFORMS.

 Simon

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev