Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2019-02-21 Thread Ryosuke Niwa
For those who joined webkit-dev after June 2013, see https://lists.webkit.org/pipermail/webkit-dev/2013-June/thread.html#25056 On Thu, Feb 21, 2019 at 7:54 PM Ryosuke Niwa wrote: > I guess we never remembered to update our style guideline back in 2013. > > I've uploaded a patch to do this: >

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2019-02-21 Thread Ryosuke Niwa
I guess we never remembered to update our style guideline back in 2013. I've uploaded a patch to do this: https://bugs.webkit.org/show_bug.cgi?id=194930 - R. Niwa ___ webkit-dev mailing list webkit-dev@lists.webkit.org

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-07-03 Thread Bem Jones-Bey
On Jul 2, 2013, at 17:06, Maciej Stachowiak m...@apple.commailto:m...@apple.com wrote: On Jul 1, 2013, at 7:31 PM, Brady Eidson beid...@apple.commailto:beid...@apple.com wrote: On Jul 1, 2013, at 5:27 PM, Ryosuke Niwa rn...@webkit.orgmailto:rn...@webkit.org wrote: I concur. Maybe

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-07-02 Thread Maciej Stachowiak
On Jul 1, 2013, at 7:31 PM, Brady Eidson beid...@apple.com wrote: On Jul 1, 2013, at 5:27 PM, Ryosuke Niwa rn...@webkit.org wrote: I concur. Maybe StyleResolver* styleResolverIfExists() StyleResolver styleResolver() ? I concur with this. For this entire discussion, this is where

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-07-01 Thread Ryosuke Niwa
On Sun, Jun 30, 2013 at 9:39 PM, Filip Pizlo fpi...@apple.com wrote: On Jun 19, 2013, at 9:41 AM, Dan Bernstein m...@apple.com wrote: On Jun 19, 2013, at 7:37 PM, Timothy Hatcher timo...@apple.com wrote: What about? StyleResolver* existingStyleResolver() StyleResolver

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-07-01 Thread Brady Eidson
On Jul 1, 2013, at 5:27 PM, Ryosuke Niwa rn...@webkit.org wrote: On Sun, Jun 30, 2013 at 9:39 PM, Filip Pizlo fpi...@apple.com wrote: On Jun 19, 2013, at 9:41 AM, Dan Bernstein m...@apple.com wrote: On Jun 19, 2013, at 7:37 PM, Timothy Hatcher timo...@apple.com wrote: What about?

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-07-01 Thread Dan Bernstein
On Jul 1, 2013, at 7:31 PM, Brady Eidson beid...@apple.com wrote: On Jul 1, 2013, at 5:27 PM, Ryosuke Niwa rn...@webkit.org wrote: On Sun, Jun 30, 2013 at 9:39 PM, Filip Pizlo fpi...@apple.com wrote: On Jun 19, 2013, at 9:41 AM, Dan Bernstein m...@apple.com wrote: On Jun 19, 2013,

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-30 Thread Dan Bernstein
On Jun 19, 2013, at 7:37 PM, Timothy Hatcher timo...@apple.com wrote: What about? StyleResolver* existingStyleResolver() StyleResolver styleResolver() I like it. — Timothy Hatcher On Jun 19, 2013, at 11:49 AM, Balazs Kelemen kbal...@webkit.org wrote: For me optional seems very

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-30 Thread Filip Pizlo
Sent from my PDP-11 On Jun 19, 2013, at 9:41 AM, Dan Bernstein m...@apple.com wrote: On Jun 19, 2013, at 7:37 PM, Timothy Hatcher timo...@apple.com wrote: What about? StyleResolver* existingStyleResolver() StyleResolver styleResolver() I like it. — Timothy Hatcher On

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-21 Thread Maciej Stachowiak
On Jun 19, 2013, at 4:22 PM, Elliott Sprehn espr...@chromium.org wrote: On Wed, Jun 19, 2013 at 9:46 AM, Andreas Kling akl...@apple.com wrote: On Jun 19, 2013, at 6:37 PM, Timothy Hatcher timo...@apple.com wrote: What about? StyleResolver* existingStyleResolver() StyleResolver

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Gavin Barraclough
I find ‘requireStyleResolver()’ a little confusing. My first expectation is often that a method is an imperative command on the receiver, so I first read 'requireStyleResolver()’ as mandating that the document now requires a StyleResolver, rather than referring to the need of the caller. In a

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Maciej Stachowiak
On Jun 18, 2013, at 10:16 PM, Ryosuke Niwa rn...@webkit.org wrote: On Tue, Jun 18, 2013 at 7:20 PM, Simon Fraser simon.fra...@apple.com wrote: On Jun 18, 2013, at 7:11 PM, Darin Adler da...@apple.com wrote: On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa rn...@webkit.org wrote: Why don't we

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Balazs Kelemen
For me optional seems very misleading and generally different prefixes suggests that those objects are not the same. Maybe IfExists does not sound nicely but at least it's clear. I would choose to have a pointer version with IfExists and a reference version which is a noun, like:

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Timothy Hatcher
What about? StyleResolver* existingStyleResolver() StyleResolver styleResolver() — Timothy Hatcher On Jun 19, 2013, at 11:49 AM, Balazs Kelemen kbal...@webkit.org wrote: For me optional seems very misleading and generally different prefixes suggests that those objects are not the same.

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Andreas Kling
On Jun 19, 2013, at 6:37 PM, Timothy Hatcher timo...@apple.com wrote: What about? StyleResolver* existingStyleResolver() StyleResolver styleResolver() +1 to these two. -Kling AKA the guy who named the methods we’re bike shedding about. :|___

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Geoffrey Garen
On Jun 18, 2013, at 7:03 PM, Emil A Eklund e...@chromium.org wrote: +1, much clearer and the pointer vs reference makes it even more so. Perhaps enough so that the required prefix could be dropped: StyleResolver* optionalStyleResolver(); StyleResolver styleResolver(); I love this! On Jun

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Elliott Sprehn
On Wed, Jun 19, 2013 at 9:46 AM, Andreas Kling akl...@apple.com wrote: On Jun 19, 2013, at 6:37 PM, Timothy Hatcher timo...@apple.com wrote: What about? StyleResolver* existingStyleResolver() StyleResolver styleResolver() This doesn't make sense since calling styleResolver() again won't

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Emil A Eklund
On Tue, Jun 18, 2013 at 6:38 PM, Darin Adler da...@apple.com wrote: What do you think of these names instead? StyleResolver* optionalStyleResolver(); StyleResolver requiredStyleResolver(); +1, much clearer and the pointer vs reference makes it even more so. Perhaps enough so that the

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Ryosuke Niwa
On Tue, Jun 18, 2013 at 6:38 PM, Darin Adler da...@apple.com wrote: Lets bike shed! For some time, functions with names like fooIfExists and ensureFoo have been bothering me. I find both names kind of opaque and unpleasant. Here’s an example: StyleResolver* styleResolverIfExists();

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Darin Adler
On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa rn...@webkit.org wrote: requiredStyleResolver sounds as if it's a special (required) type of a style resolver as opposed to the caller requiring it. That is true. Why don't we call it requireStyleResolver() instead? Functions with return values

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Darin Adler
On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa rn...@webkit.org wrote: Why don't we call it requireStyleResolver() instead? I’m warming to this idea. Maybe we can use “require” as a term of art, analogous to the way we use “create”, to mean “create if not already created”. -- Darin

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Simon Fraser
On Jun 18, 2013, at 7:11 PM, Darin Adler da...@apple.com wrote: On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa rn...@webkit.org wrote: Why don't we call it requireStyleResolver() instead? I’m warming to this idea. Maybe we can use “require” as a term of art, analogous to the way we use

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Maciej Stachowiak
If the semantic is essentially that of a getter that just happens to lazily create what it gets on demand, then I don't think require or required is needed. It can just be named as a getter. If the side effect is very important and especially if clients ever call the function only for its side

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-18 Thread Ryosuke Niwa
On Tue, Jun 18, 2013 at 7:20 PM, Simon Fraser simon.fra...@apple.comwrote: On Jun 18, 2013, at 7:11 PM, Darin Adler da...@apple.com wrote: On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa rn...@webkit.org wrote: Why don't we call it requireStyleResolver() instead? I’m warming to this idea. Maybe