Re: [whatwg] Event handlers - Pointer Devices

2010-02-26 Thread Olli Pettay
This kind of discussion should happen in W3C WebApps WG, using DOM mailing list (www-...@w3.org). There as been some discussion about this subject and I hope there would be a draft spec somewhat soon. (This all may depend on patent nonsense.) -Olli On 2/26/10 12:37 AM, dpenk...@gmail.com

Re: [whatwg] HTML Cookie API

2010-02-26 Thread Diogo Resende
What about something like: document.pushCookies(function () { // cookies have been pushed to the js process var x = document.getCookie(x); // whatever... }); This seems similar to Adam's proposed

Re: [whatwg] Drag-and-drop feedback

2010-02-26 Thread Dmitry Titov
On Mon, Feb 22, 2010 at 6:06 PM, Daniel Cheng dch...@google.com wrote: Several questions about the proposal: How does DataTransferItems interact with the original DataTransfer object? I'm assuming changes in one should be reflected in the other. If that's the case, what should happen if I do

Re: [whatwg] Adding FormData support to form

2010-02-26 Thread Michael Nordman
On Fri, Feb 19, 2010 at 8:52 AM, Dmitry Titov dim...@google.com wrote: On Thu, Feb 18, 2010 at 8:45 PM, Maciej Stachowiak m...@apple.com wrote: On Feb 17, 2010, at 3:15 PM, Jonas Sicking wrote: The reason this is a function rather than a read-only attribute is to allow the return FormData

Re: [whatwg] HTML Cookie API

2010-02-26 Thread Darin Fisher
On Fri, Feb 26, 2010 at 10:56 AM, Diogo Resende drese...@thinkdigital.ptwrote: What about something like: document.pushCookies(function () { // cookies have been pushed to the js process var x = document.getCookie(x); //

Re: [whatwg] HTML Cookie API

2010-02-26 Thread Diogo Resende
No. pushCookies would be a way of pushing cookies to the current js and then you could call getCookie several times without defining a callback. It would be almost like: document.observe(cookieload, myAppLoad)

Re: [whatwg] HTML Cookie API

2010-02-26 Thread Darin Fisher
On Fri, Feb 26, 2010 at 12:04 PM, Diogo Resende drese...@thinkdigital.ptwrote: No. pushCookies would be a way of pushing cookies to the current js and then you could call getCookie several times without defining a callback. It would be almost

Re: [whatwg] Adding FormData support to form

2010-02-26 Thread Maciej Stachowiak
On Feb 26, 2010, at 11:37 AM, Michael Nordman wrote: Sure, but a better name could help a bit. For example, this produces a 'shared' object: document.getElementById(foo) while this creates a new one: myFormElement.getFormData() It might be ok, but it is a bit inconsistent. Why not:

Re: [whatwg] HTML Cookie API

2010-02-26 Thread Jonas Sicking
On Fri, Feb 26, 2010 at 12:20 PM, Darin Fisher da...@chromium.org wrote: On Fri, Feb 26, 2010 at 12:04 PM, Diogo Resende drese...@thinkdigital.pt wrote:         No. pushCookies would be a way of pushing cookies to the         current js and         then you could call getCookie several

Re: [whatwg] Adding FormData support to form

2010-02-26 Thread Anne van Kesteren
On Fri, 26 Feb 2010 23:28:12 +0100, Maciej Stachowiak m...@apple.com wrote: On Feb 26, 2010, at 11:37 AM, Michael Nordman wrote: Sure, but a better name could help a bit. For example, this produces a 'shared' object: document.getElementById(foo) while this creates a new one: