[PATCH xf86-video-ati] configure: Include xorg-server.h before glamor.h

2014-07-28 Thread Hans de Goede
glamor.h cannot be included without first including xorg-server.h, this also applies to including it from configure snippets. Without this the configure glamor checks fail on systems with the latest glibc, throwing this error: In file included from /usr/include/xorg/misc.h:115:0,

[PATCH] glamor: Eliminate diagonal tearing in xv

2014-07-28 Thread Keith Packard
This uses a single large triangle and a scissor to draw the video instead of two triangles. Signed-off-by: Keith Packard kei...@keithp.com --- glamor/glamor_xv.c | 13 - 1 file changed, 8 insertions(+), 5 deletions(-) diff --git a/glamor/glamor_xv.c b/glamor/glamor_xv.c index

Re: [PATCH] randr: fix primary setting of slave outputs

2014-07-28 Thread Keith Packard
Dave Airlie airl...@gmail.com writes: From: Fedora X Ninjas x...@fedoraproject.org If the user wants to set one of the slave devices as the primary output, we shouldn't fail to do so, we were returning BadMatch which was tripping up gnome-settings-daemon and bad things ensues. Fix all the

Re: [PATCH] DIX/ConfineTo: Improve algorithm to jump to the nearest point inside

2014-07-28 Thread Keith Packard
Egbert Eich e...@freenet.de writes: Hi Keith, sorry for delaying this. I was occupied with other things and therefore wanted to wait for a bigger time window. This patch doesn't appear to have been merged yet; do you want to try and figure out what the status is? -- keith.pack...@intel.com

[PATCH 1/1] ListenOnOpenFD: Remove Resets since this is intended to be for hotplugging connections

2014-07-28 Thread Jeremy Huddleston Sequoia
pharris says that the resets should not be done in the hotplugging case. This may fix a crash reported against XQuartz: http://xquartz.macosforge.org/trac/ticket/869 Signed-off-by: Jeremy Huddleston Sequoia jerem...@apple.com CC: Peter Harris phar...@opentext.com CC: Kristian Høgsberg

Re: [PATCH] xserver: don't call struct members bool.

2014-07-28 Thread Keith Packard
Dave Airlie airl...@gmail.com writes: From: Dave Airlie airl...@redhat.com When you include files from mesa that might want to use stdbool things get messed up. This is an API break I think and I've no idea what drivers might use this, so we can hold off on it. Did you want to fix up this

Re: [PATCH][V4][xserver] configure.ac: add option for xshmfence

2014-07-28 Thread Keith Packard
Ross Burton ross.bur...@intel.com writes: xshmfence is usable outside of DRI3, and is currently autodetected which isn't good for distributions where deterministic builds are desired. Merged (with review). 2172714..4afedf5 master - master -- keith.pack...@intel.com pgp9vg3u8E9q_.pgp

[PATCH] xfree86: [v2] Remove duplicate InputInfoPtr typedef from xf86Xinput.h

2014-07-28 Thread Keith Packard
GCC 4.2 doesn't accept 2 typedef declarations of the same type, so remove the extra one from xf86Xinput.h and have xf86Xinput.h #include xf86.h to make sure everyone using just that file gets the typedef. Signed-off-by: Keith Packard kei...@keithp.com --- hw/xfree86/common/xf86Xinput.h | 5 +++--

RE: [PATCH] randr: Fix logic in RRPointerToNearestCrtc

2014-07-28 Thread Keith Packard
David Ung dav...@nvidia.com writes: ping? From: David Ung [dav...@nvidia.com] Sent: Thursday, July 17, 2014 5:19 PM To: xorg-devel@lists.x.org Cc: David Ung Subject: [PATCH] randr: Fix logic in RRPointerToNearestCrtc RRPointerToNearestCrtc is

Re: [PATCH 09/16] xv: Move xf86 XV color key helper to core.

2014-07-28 Thread Keith Packard
Eric Anholt e...@anholt.net writes: Color key overlay implementations want to reuse this code, and XF86's had bugs. It might be helpful to describe which bugs were in the xf86 code so that these two implementations could be compared. -- keith.pack...@intel.com pgp8LOItOGuFH.pgp

Re: [PATCH 00/21] Rewrite hw/xfree86/common/compiler.h (v2)

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Resend of the equivalent series from May. I'm sure I had to touch up some of it to account for whatever arch patches we added between then and now, but I forget which, so the individual patches lack versioning; sorry about that. Between this, the

Re: [PATCH] mi: Remove semi-arbitrary arch awareness in packed coordinate macros

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: The majority of arches end up on the right-shift path here. I can't think of any arch where that'd be slower than a divide, and semantically it makes more sense to think of this as a shift operation anyway. Signed-off-by: Adam Jackson a...@redhat.com

Re: [PATCH 02/22] dix: Make some LBX-era code more obvious

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: isItTimeToYield in the conditional effectively didn't do anything here. Take it out, and remove the comment since LBX proxies aren't a thing for us anymore. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgp78FdZE9mK6.pgp

Re: [PATCH 03/22] kdrive: Remove some dead bits of the man page

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgp4rQekOkWX7.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development

Re: [PATCH 04/22] mi: Remove apparently unused miSegregateChildren

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: This came in between XFree86 4.3 and 4.4, I'm not entirely sure what it was meant to do. It constructs a region for all windows in a tree of a specific depth. Use this to compute window clipping in hardware that has multiple planes of different depths.

Re: [PATCH 05/22] miext/shadow: Remove ancient backwards-compatibility hack

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Here's a trip down memory lane. Back when we merged kdrive we adopted kdrive's version of shadow, which used damage directly instead of hand-rolling it. However a couple of Xorg drivers referred to the accumulated damage region in the shadow private

Re: [PATCH 06/22] miext/shadow: Remove shadowInit

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: This code is nonsensical. You end up creating a screen-sized pixmap that's totally detached from everything else, which you then listen for damage on, which means you'll never hear any damage, which means your shadow update hooks will never get called.

Re: [PATCH 09/22] render: Remove unused CopyPicture

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Arguably this would be useful API, but it's never called, and a careful reading of the CPClipMask path reveals that callers would be fairly disappointed. Yeah, kinda misses setting the actual clip rects. Reviewed-by: Keith Packard kei...@keithp.com --

Re: [PATCH 10/22] saver: Don't open-code IsMapInstalled

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com Also eliminates a bug where the open-coded version wasn't checking the return value from malloc. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpnbGzaFadP9.pgp Description: PGP

Re: [PATCH 11/22] vgahw: Nuke unused vgaCmap.c

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Never been built since m12n, can't be needed. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgp18RQog7qp1.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development

RE: [PATCH] randr: Fix logic in RRPointerToNearestCrtc

2014-07-28 Thread David Ung
RRPointerToNearestCrtc is suppose to snap to the nearest Crtc, but the code is buggy. Correct the calculation of delta x/y values and choose the closest Crtc. This comment isn't terribly descriptive of the problems it's solving. There are two -- one where the dx/dy values end up off-by-one

Re: [PATCH 13/22] xfree86: Remove some unused pre-pciaccess types

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgp4LPhQfY8KL.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development

Re: [PATCH 14/22] xfree86: Remove deprecated PCI types

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpNHBHRbL3KK.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development

Re: [PATCH 15/22] xfree86: Remove unused xf86{Map,Unmap}LegacyIO

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: I ported these to pciaccess in: commit 858fbbb40d7c69540cd1fb5315cebf811c6e7b3f Author: Adam Jackson a...@redhat.com Date: Fri Sep 16 13:33:04 2011 -0400 pci: Port xf86MapLegacyIO to pciaccess As of yet there are still no drivers

Re: [PATCH 17/22] xfree86: Remove pointless xf86RandRCreateScreenResources

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Given the #if 0 this was wrapping for no effect. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgp2ZYpTEcPn0.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org

Re: [PATCH 18/22] xfree86: Remove useless #include fb.h

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Signed-off-by: Adam Jackson a...@redhat.com Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpURkFIeRuD2.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development

Re: [PATCH 16/22] xfree86: Remove protectMem from VidMemInfo

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Never filled in. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpr6pbpYmgXL.pgp Description: PGP signature ___ xorg-devel@lists.x.org: X.Org development Archives:

Re: [PATCH 21/22] xquartz: Remove unused DRI{,Post}ValidateTree

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Cargo-culted from DRI1, not actually used for anything. This also includes unrelated changes to pseudoramiX; if you split this into two patches, these are Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgp6aFPoSuXOk.pgp

Re: [PATCH 22/22] dri1: Remove unused DRI{,Post}ValidateTree

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: i810, mga, savage, and tdfx do reference these slots, but only to set them to NULL, so while this does have API impact it's not actually used. Reviewed-by: Keith Packard kei...@keithp.com -- keith.pack...@intel.com pgpJxzeNTSBrJ.pgp Description: PGP

Re: [PATCH 00/21] Misc dead code cleanup

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: No real unifying theme here besides cleanup. Two patches here do require trivial driver changes. 06/22 removes an interface that simply can't work; naturally, two drivers (trident and xgixp) do in fact use it. The fix requires no thought beyond

[PATCH] Make sure X_BYTE_ORDER is defined for servermd.h

2014-07-28 Thread Keith Packard
Use dix-config.h when present, otherwise use xorg-server.h Signed-off-by: Keith Packard kei...@keithp.com --- include/servermd.h | 4 include/xorg-server.h.in | 3 +++ 2 files changed, 7 insertions(+) diff --git a/include/servermd.h b/include/servermd.h index 0132d67..b3fe6df 100644

Re: [PATCH] glamor: Eliminate diagonal tearing in xv

2014-07-28 Thread Alex Deucher
On Mon, Jul 28, 2014 at 2:10 PM, Keith Packard kei...@keithp.com wrote: This uses a single large triangle and a scissor to draw the video instead of two triangles. Signed-off-by: Keith Packard kei...@keithp.com Reviewed-by: Alex Deucher alexander.deuc...@amd.com --- glamor/glamor_xv.c |

Re: [PATCH] composite: Optimize resizes of ForgetGravity windows

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: Per the spec: A bit-gravity of Forget indicates that the window contents are always discarded after a size change, even if backing-store or save-under has been requested. The window is tiled with its background (except, if no background

RE: [PATCH] randr: Fix logic in RRPointerToNearestCrtc

2014-07-28 Thread Keith Packard
David Ung dav...@nvidia.com writes: RRPointerToNearestCrtc is suppose to snap to the nearest Crtc, but the code is buggy. Correct the calculation of delta x/y values and choose the closest Crtc. This comment isn't terribly descriptive of the problems it's solving. There are two -- one

Re: [PATCH] glamor: Eliminate diagonal tearing in xv

2014-07-28 Thread Keith Packard
Alex Deucher alexdeuc...@gmail.com writes: On Mon, Jul 28, 2014 at 2:10 PM, Keith Packard kei...@keithp.com wrote: This uses a single large triangle and a scissor to draw the video instead of two triangles. Signed-off-by: Keith Packard kei...@keithp.com Reviewed-by: Alex Deucher

Re: [PATCH 21/22] xquartz: Remove unused DRI{,Post}ValidateTree

2014-07-28 Thread Jeremy Huddleston Sequoia
Reviewed-by: Jeremy Huddleston Sequoia jerem...@apple.com On Jul 22, 2014, at 08:46, Adam Jackson a...@redhat.com wrote: Cargo-culted from DRI1, not actually used for anything. Signed-off-by: Adam Jackson a...@redhat.com --- hw/xquartz/xpr/dri.c | 51

Re: [PATCH] composite: Optimize resizes of ForgetGravity windows

2014-07-28 Thread Adam Jackson
On Mon, 2014-07-28 at 13:04 -0700, Keith Packard wrote: Adam Jackson a...@redhat.com writes: For redirected windows, size changes hit compReallocPixmap, which normally attempts to preserve the previous pixmap in cw-pOldPixmap. For ForgetGravity windows we now destroy the old pixmap before

Re: [PATCH 09/16] xv: Move xf86 XV color key helper to core.

2014-07-28 Thread Eric Anholt
Keith Packard kei...@keithp.com writes: Eric Anholt e...@anholt.net writes: Color key overlay implementations want to reuse this code, and XF86's had bugs. It might be helpful to describe which bugs were in the xf86 code so that these two implementations could be compared. Just the ones

RE: [PATCH] randr: Fix logic in RRPointerToNearestCrtc

2014-07-28 Thread Keith Packard
David Ung dav...@nvidia.com writes: thanks, do you need me to re-upload another patch with the modify message? and will you be doing the actual commit? Yup, just send along another patch with a Signed-off-by: line and the new message and I'll merge it in to the X server repository. --

Re: [PATCH] composite: Optimize resizes of ForgetGravity windows

2014-07-28 Thread Keith Packard
Adam Jackson a...@redhat.com writes: [censored] borders. True enough. Okay, so we can still take this shortcut if either: a) pixmap is resizing but border width has not changed b) pixmap is not resizing but border width has changed c) pixmap is resizing by twice the change in border

Re: [PATCH 09/16] xv: Move xf86 XV color key helper to core.

2014-07-28 Thread Keith Packard
Eric Anholt e...@anholt.net writes: Keith Packard kei...@keithp.com writes: Eric Anholt e...@anholt.net writes: Color key overlay implementations want to reuse this code, and XF86's had bugs. It might be helpful to describe which bugs were in the xf86 code so that these two

[PATCH] randr: Fix logic in RRPointerToNearestCrtc

2014-07-28 Thread David Ung
RRPointerToNearestCrtc is suppose to snap to the nearest Crtc, but best_x and best_y is always positive, hence when calling SetCursorPosition it will make the cursor even further away. Correct delta x/y to allow negative values and also use width/height -1 in the calculation. Also choose the