Re: [PATCH] evdev: handle touchscreens without BTN_TOUCH

2011-05-24 Thread Peter Korsgaard
), we probably shouldn't label them as touchscreens. Yes, but all of this is in a has abs X/Y check. Keyboards presumably don't have absolute X/Y axes? -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org

Re: [PATCH] evdev: handle touchscreens without BTN_TOUCH

2011-05-24 Thread Peter Korsgaard
X/Y, no rel X/Y and BTN_LEFT? Or do you have other crazy devices doing that as well? -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg

Re: [PATCH] evdev: handle touchscreens without BTN_TOUCH

2011-05-24 Thread Peter Korsgaard
other devices. With the check for BTN_LEFT (or rather has_lmr) that shouldn't be an issue. I'l send an updated patch shortly. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info

[PATCHv2] evdev: handle touchscreens without BTN_TOUCH

2011-05-24 Thread Peter Korsgaard
work very well. We already internally translate BTN_TOUCH as BTN_LEFT, so accept this kind of devices as touchscreens by checking for devices with BTN_LEFT, absolute X/Y and NO relative X/Y axes. Signed-off-by: Peter Korsgaard jac...@sunsite.dk --- Changes since v1: - Add as seperate check

Re: [PATCH evdev v2] Export product/vendor ID through a property.

2011-05-24 Thread Peter Korsgaard
, Peter } else if (atom == prop_swap) Peter { Peter if (val-format != 8 || val-type != XA_INTEGER || val-size != 1) Peter + Peter return BadMatch; Why the extra empty line in the middle of the conditional? -- Bye, Peter Korsgaard

Re: [PATCHv2] evdev: handle touchscreens without BTN_TOUCH

2011-05-24 Thread Peter Korsgaard
Peter == Peter Hutterer peter.hutte...@who-t.net writes: Peter On Tue, May 24, 2011 at 09:44:05AM +0200, Peter Korsgaard wrote: Some touchscreens (like the Lumio crystaltouch in single touch mode) send BTN_LEFT rather than BTN_TOUCH: Peter merged, thanks. Thanks. Peter one more thing

Re: evdev: support for touchscreens not providing BTN_TOUCH

2011-05-23 Thread Peter Korsgaard
. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

[PATCH] evdev: handle touchscreens without BTN_TOUCH

2011-05-23 Thread Peter Korsgaard
work very well. We already internally translate BTN_TOUCH as BTN_LEFT, so accept this kind of devices as touchscreens by checking for devices with absolute X/Y and NO relative X/Y axes. Signed-off-by: Peter Korsgaard jac...@sunsite.dk --- src/evdev.c |6 -- 1 files changed, 4 insertions

Re: evdev: support for touchscreens not providing BTN_TOUCH

2011-05-23 Thread Peter Korsgaard
Tissoires benjamin.tissoi...@enac.fr Chase specifically. He's been writing the generic USB HID multitouch Chase driver, and he would know how to quirk things to work for your Chase device. Thanks. I'm already working with Benjamin to get the multitouch part working. -- Bye, Peter Korsgaard

Re: [PATCH] evdev: handle touchscreens without BTN_TOUCH

2011-05-23 Thread Peter Korsgaard
of the things I'd like to have in ABI 14/server Peter 1.12 are the proper driver hooks to change devices on-the-fly. That sounds good. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info

Re: evdev: support for touchscreens not providing BTN_TOUCH

2011-05-22 Thread Peter Korsgaard
Data wMaxPacketSize 0x0008 1x 8 bytes bInterval 1 Device Status: 0x0001 Self Powered -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel

Re: evdev: support for touchscreens not providing BTN_TOUCH

2011-05-22 Thread Peter Korsgaard
in this case, its really best to get kernel side working right. The controller uses the USB HID class, so there's no custom driver involved atm. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg

evdev: support for touchscreens not providing BTN_TOUCH

2011-05-20 Thread Peter Korsgaard
this working with multitouch using the hid-multitouch driver, but it would be good to atleast have it working as a normal dumb single touch touchscreen until then. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http

Re: [RFC PATCH] Add XI_PROP_ROTATION property to the server's properties.

2011-03-23 Thread Peter Korsgaard
feature? -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

Re: [PATCH evdev] Export device node as property.

2011-02-24 Thread Peter Korsgaard
applications figure it out? ;) -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

Re: [PATCH evdev] Export device node as property.

2011-02-16 Thread Peter Korsgaard
Peter == Peter Korsgaard jac...@sunsite.dk writes: Hi, Peter Ok, I missed that we're trying to solve two different use-cases. Peter Punting a unique device ID into the properties is be quite Peter useful, I've been struggling for a while with figuring out how Peter to make per-device

Re: [PATCH evdev] Export device node as property.

2011-02-08 Thread Peter Korsgaard
unfortunate. Not to mention that they probably don't have Daniel access to the devices. Indeed. My points exactly. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org

Re: [PATCH evdev] Export device node as property.

2011-02-08 Thread Peter Korsgaard
) to be able to handle the common case of USB devices without a unique serial number (so EVIOCGUNIQ doesn't give anything). The question is if we can come up with a sensible logic for choosing between name/phys/uniq? -- Bye, Peter Korsgaard ___ xorg-devel

Re: [PATCH evdev] Export device node as property.

2011-02-04 Thread Peter Korsgaard
unplug and replug a device while the system is active, but it doesn't help getting the same settings applied the next day when you boot your system again. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org

Re: [PATCH evdev] Export device node as property.

2011-02-04 Thread Peter Korsgaard
. Then gnome-settings-daemon can look Dan at the combination of DISPLAY hostname and Device UID to know Dan which cached settings to grab. What is the use case about 'Device Node'? Purely informational like I mentioned above, or is there another need for it? -- Bye, Peter Korsgaard

Re: [PATCH evdev] Export device node as property.

2011-02-02 Thread Peter Korsgaard
E.G. use something like usb-:00:1d.1-1/input0 rather than /dev/input/event14. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

[PATCH] evdev: rename EvdevCacheCompare() to EvdevCache()

2010-12-10 Thread Peter Korsgaard
Since 59056e656c64 (Remove the reopen timer logic) from last year, EvdevCacheCompare() is only used for caching ioctl values and not for comparing, so remove the unused compare logic and rename the function to EvdevCache(). Signed-off-by: Peter Korsgaard jac...@sunsite.dk --- src/evdev.c | 66

Re: [PATCH] evdev: rename EvdevCacheCompare() to EvdevCache()

2010-12-10 Thread Peter Korsgaard
of course - It seems like I forgot to ammend the commit after I changed that - Will resend. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg

[PATCHv2] evdev: rename EvdevCacheCompare() to EvdevCache()

2010-12-10 Thread Peter Korsgaard
Since 59056e656c64 (Remove the reopen timer logic) from last year, EvdevCacheCompare() is only used for caching ioctl values and not for comparing, so remove the unused compare logic and rename the function to EvdevCache(). Signed-off-by: Peter Korsgaard jac...@sunsite.dk --- - Fix stupid typo

Re: [PATCHv3] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-28 Thread Peter Korsgaard
-by: Peter Korsgaard peter.korsga...@barco.com PH thanks, I've finally had time to merge and test this. It's in my tree now, PH I'll get it pulled by keith asap. Great, thanks! -- Bye, Peter Korsgaard DISCLAIMER: Unless indicated otherwise, the information contained in this message is privileged

Re: [PATCHv3] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-28 Thread Peter Korsgaard
is probably the best code PH to look at and steal the approach. Yes, I'll try to find time to work on this (and the device node property stuff) this weekend. -- Bye, Peter Korsgaard DISCLAIMER: Unless indicated otherwise, the information contained in this message is privileged and confidential

Re: [PATCHv2] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-24 Thread Peter Korsgaard
are interesting if you want an absolue input device to span multiple screens for some kind of video wall with touchscreen setup? All in all, I would prefer to not hardcode any policy here in the server. Strange values doesn't really harm us. -- Bye, Peter Korsgaard

Re: [PATCHv2] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-23 Thread Peter Korsgaard
, the other static ones have lowercase first letters, so Peter transformAbsolute is preferable here. Ok, will fix and resend. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http

Re: [PATCHv2] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-11 Thread Peter Korsgaard
simon.t...@gmx.de Thanks! -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

Re: [PATCH] evdev: add phys property (EVIOCGPHYS) as stable identifier

2010-05-08 Thread Peter Korsgaard
Peter == Peter Korsgaard jac...@sunsite.dk writes: Hi, Really? That sounds like a bug in valgrind then. EVIOCGPHYS is correctly marked as an input ioctl (_IOC(_IOC_READ, 'E', 0x07, len)), so it should know that phys contains valid data after the ioctl. But I can certainly add

[PATCHv2] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-06 Thread Peter Korsgaard
can be handled. Signed-off-by: Peter Korsgaard peter.korsga...@barco.com --- This is equivalent to the evdev patch sent earlier: http://thread.gmane.org/gmane.comp.freedesktop.xorg.devel/7336 But moved into the server as requested as requested by Simon and Peter, so it's available for all input

Re: [PATCHv2] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-06 Thread Peter Korsgaard
transform on relative devices after they are converted to absolute coordinates, E.G. after moveRelative(). Unless I'm missing something? -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel

Re: [PATCHv2] evdev: add phys property (EVIOCGPHYS) as stable identifier

2010-05-05 Thread Peter Korsgaard
Peter == Peter Korsgaard peter.korsga...@barco.com writes: Peter xinput ids are not guaranteed to be stable between reboots (or hotplugs) Peter /* All devices the evdev driver has allocated and knows about. Peter @@ -2463,6 +2464,17 @@ EvdevInitProperty(DeviceIntPtr dev) Peter

[PATCHv3] evdev: add phys property (EVIOCGPHYS) as stable identifier

2010-05-05 Thread Peter Korsgaard
setups). EVIOCGPHYS is used rather than E.G. the device node or sysfs path, as it is (supposed to be) unique, simple to access and the remaining information can be retrieved through /proc/bus/input/devices, which doesn't require any special privileges. Signed-off-by: Peter Korsgaard peter.korsga

[PATCH] xf86ActivateDevice(): Add Device Node property to input devices

2010-05-05 Thread Peter Korsgaard
Add Device Node xinput property containing the device node path to all input devices with a device property. This is useful to figure out the relation between xinput ids and kernel devices. Signed-off-by: Peter Korsgaard peter.korsga...@barco.com --- As requested by Peter Hutterer during

Re: [PATCH] xf86ActivateDevice(): Add Device Node property to input devices

2010-05-05 Thread Peter Korsgaard
Peter == Peter Korsgaard peter.korsga...@barco.com writes: Peter Add Device Node xinput property containing the device node path to Peter all input devices with a device property. This is useful to figure out Ehhm, make that 'with a Device option' instead. -ENOCOFFE. -- Bye, Peter Korsgaard

[PATCH] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-05 Thread Peter Korsgaard
can be handled. Signed-off-by: Peter Korsgaard peter.korsga...@barco.com --- This is equivalent to the evdev patch sent earlier: http://thread.gmane.org/gmane.comp.freedesktop.xorg.devel/7336 But moved into the server as requested as requested by Simon and Peter, so it's available for all input

Re: [PATCH] dix: add 3x3 transformation matrix xinput property for multi-head handling

2010-05-05 Thread Peter Korsgaard
Keith == Keith Packard kei...@keithp.com writes: Keith On Wed, 5 May 2010 17:54:07 +0200, Peter Korsgaard peter.korsga...@barco.com wrote: + +/* 3x3 coordinate transformation matrix for abs devs in row major order */ +float transform[9]; Keith Please use a struct

[PATCHv2] evdev: add phys property (EVIOCGPHYS) as stable identifier

2010-05-04 Thread Peter Korsgaard
setups). EVIOCGPHYS is used rather than E.G. the device node or sysfs path, as it is (supposed to be) unique, simple to access and the remaining information can be retrieved through /proc/bus/input/devices, which doesn't require any special privileges. Signed-off-by: Peter Korsgaard peter.korsga

Re: [PATCH evdev] Read the device resolution from the kernel.

2010-04-29 Thread Peter Korsgaard
) - And the structure is initialized to zero before, so it should be fine. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

Re: [PATCH] evdev: add phys property (EVIOCGPHYS) as stable identifier

2010-04-28 Thread Peter Korsgaard
expect it would have to copy 256 bytes from somewhere to initialize unless gcc is clever. .. Which it is, it ends up doing a rep stos loop - Which adds something like 10-15 bytes. I'll add the initializer and resend. -- Bye, Peter Korsgaard ___ xorg

Re: [PATCH] evdev: add phys property (EVIOCGPHYS) as stable identifier

2010-04-28 Thread Peter Korsgaard
to this issue, though. It seems you could Dan carry the driver specific property for now until a server level Dan solution could be built up. True. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org

[PATCH] evdev: add phys property (EVIOCGPHYS) as stable identifier

2010-04-26 Thread Peter Korsgaard
setups). EVIOCGPHYS is used rather than E.G. the device node or sysfs path, as it is (supposed to be) unique, simple to access and the remaining information can be retrieved through /proc/bus/input/devices, which doesn't require any special privileges. Signed-off-by: Peter Korsgaard peter.korsga

Re: [PATCH] evdev: add 3x3 transformation matrix xinput property for multi-head handling

2010-04-21 Thread Peter Korsgaard
Oliver == Oliver McFadden oliver.mcfad...@nokia.com writes: Hi, Oliver Everything else looks fine; just the leaked storage issue. Great, can I add your Acked-by then when I resend? -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org

[PATCHv2] evdev: add 3x3 transformation matrix xinput property for multi-head handling

2010-04-21 Thread Peter Korsgaard
), but I have left them for now. Signed-off-by: Peter Korsgaard peter.korsga...@barco.com Acked-by: Oliver McFadden oliver.mcfad...@nokia.com --- Changes since V1: - Add missing xfree() noticed by Oliver include/evdev-properties.h |7 ++ man/evdev.man | 13 src/evdev.c

Re: [PATCHv2] evdev: add 3x3 transformation matrix xinput property for multi-head handling

2010-04-21 Thread Peter Korsgaard
they might be using. Thanks for your input. -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel

[PATCH] evdev: add 3x3 transformation matrix xinput property for multi-head handling

2010-04-20 Thread Peter Korsgaard
), but I have left them for now. Signed-off-by: Peter Korsgaard peter.korsga...@barco.com --- include/evdev-properties.h |7 ++ man/evdev.man | 13 src/evdev.c| 138 +++- src/evdev.h|2 + 4 files

Re: [PATCH] evdev: add 3x3 transformation matrix xinput property for multi-head handling

2010-04-20 Thread Peter Korsgaard
with this fixed and anything else you find. Oliver I'll apply the patch locally and do a full analysis after my Oliver coffee. :-) Great, thanks! -- Bye, Peter Korsgaard ___ xorg-devel@lists.x.org: X.Org development Archives: http://lists.x.org/archives