[Zope] Re:[SybDA]Connection : how does it work ?

2000-11-28 Thread Ralph Heinkel

Hi,

Which Zope version are you using? V 2.2.0 had a bug with the connection
of the DB. I just looked into V 2.2.4 and the problematic code seems to be
fixed although I've not tried this version yet. Maybe you should upgrade.
If this is not the case, then ... hmm no idea.

Ralph


On Fri, 24 Nov 2000, you wrote:
 Hello,
 
 I am running Zope 2.1.6 under Linux/RH6.2 on a PC. The Sybase server is
 version 11.9.2 on a Solaris station with DNS name "sybstat" on port 2040
 (or sybase server name "sybtest") and the database is named "picsou".
 When I try filling in the form to add a new Sybase DA connection, the
 result is always: Invalid connection string. I have try with this
 parameters :
 1-database: picsou, password: mypasswd, server: sybstat, user: myuser
 2-database: picsou, password: mypasswd, server: sybstat:2040, user:
 myuser
 But this give the same answer ...
 
 On Linux, I have the libraries, include files and all running client for
 Sybase and I can run isql from my PC on the Sybase server on the solaris
 station very well using the parameters of the (2-) set. So the
 connection to the Sybase server seems to work ...
 
 How could I check what happens inside Zope, or am I mistaken for the
 parameters values ?
 
 Thanks for any help.
 Tony
 
 
 
 ___
 Zope maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists - 
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope-dev )
-- 
------
Ralph Heinkel  Cenix Bioscience GmbH
Director of the IT-UnitTel  : +49 6221/387 915
Meyerhofstr. 1 Fax  : +49 6221/387 971
69117 Heidelberg, Germany  eMail: [EMAIL PROTECTED]

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] Sybase (again?)

2000-11-13 Thread Ralph Heinkel

Hi,

We are using 
Zope 2.1.6, Sybase 11.9.2, Sybase DA 2.00b2 on Suse Linux 6.4 and 7.0, 
stored procedures just work fine. Zope 2.2.x has a problem with
Sybase, a patch has been submitted and should come with the next
release.

Ralph 



On Fri, 10 Nov 2000, Chris McDonough wrote:
 SybaseDA AFAIK does not support stored procedures.
 
 "Manuel Amador (Rudd-O)" wrote:
  
  Well,
  
  After no one else answered my last email about zope, I've decided to
  summarize what's going on with the ZSybaseDA so as to see if someone
  takes interest.
  
  STORED PROCEDURES DO NOT WORK.  Anything else, however, does.  Once a
  stored procedure was called, the db object is blocked till zope
  restarts.
  
  Any patches, solutions, suggestions?
  
 Manuel
   
 -- 
 Chris McDonough
 Digital Creations, Publishers of Zope
 http://www.zope.org
 
-- 
------
Ralph Heinkel  Cenix Bioscience GmbH
Director of the IT-UnitTel  : +49 6221/387 915
Meyerhofstr. 1 Fax  : +49 6221/387 971
69117 Heidelberg, Germany  eMail: [EMAIL PROTECTED]

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] Zope and Sybase Stored Procedures

2000-11-06 Thread Ralph Heinkel

Hi,

we are using Zope 2.1.6 with Sybase 11.9.2 on Suse Linux, and calling
stored procedures just works fine. 

e.g. 
create procedure csp_add_barcode
@tableName varchar(12), @barcode numeric(8) OUT
AS
insert into BarcodeItem (tableName) values (@tableName)
select @barcode = @@identity

This is a stored procedure that inserts one row into the table 'BarcodeItem'
and returns an automatically created unique identity key as a result named
'barcode'.

The ZSQL methods takes one parameter 'tableName' and returns the resulting
'barcode' like a normal select statement does.

The query template simply is:

csp_add_barcode dtml-sqlvar tableName type=string


Hope that helps. Btw, Zope 2.2.0 has a bug in connecting to SybaseDA which
is reported to digicool. Should be fixed in the next release. If interested
for the fix, send me a mail.

Ralph



--
Ralph Heinkel  Cenix Bioscience GmbH
Director of the IT-UnitTel  : +49 6221/387 915
Meyerhofstr. 1 Fax  : +49 6221/387 971
69117 Heidelberg, Germany  eMail: [EMAIL PROTECTED]

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] SybaseDA and ASA

2000-10-12 Thread Ralph Heinkel

On Thu, 12 Oct 2000, you wrote:
 I've installed zope 2.2.2, and compiled sy_occ.so for SybaseDA against
 sybase-common-cantrememberversion.rpm from Sybase.  (I assume it's the
 latest one).  Loading python and importing sy_occ works perfectly.
 
 BUT, I can't create a SybaseDA SQL connection object .  Specifically,
 trying to create it sez connection failed.  I've tried EVERY POSSIBLE
 parameter combination on the creation form.  None worked.
 
 By the way, I'm using Adaptive Server Anywhere for linux, 6.0.3.  It is
 NOT ASE.  It is ASA.
 
 Does sy_occ work with ASA, or only with ASE?  Any experiences?


Last week I was trying to upgrade from Zope V 2.1.6 (with working sybase
adapter) to a 2.2.x version, and my sybase adapter stop working (yes I
recompiled it). We are using ASE 11.9.2 on a linux box. Seems like Zope has
introduced some incompatibilities which no one has discovered so far.

Ralph


--
Ralph Heinkel  Cenix Bioscience GmbH
Director of the IT-UnitTel  : +49 6221/387 915
Meyerhofstr. 1 Fax  : +49 6221/387 971
69117 Heidelberg, Germany  eMail: [EMAIL PROTECTED]

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




Re: [Zope] Integers in ZSQLMethod

2000-10-04 Thread Ralph Heinkel

On Wed, 04 Oct 2000, you wrote:
 Hi,
 
 Is it possible to use following code in ZSQLMethod :
 
   !--#sqlvar NMRSEQS.PAR_FLIPANGLE type=int --,
 
 But also allow null as value for the integer? (Thus not filled in)
 

use 
!--#sqlvar NMRSEQS.PAR_FLIPANGLE type=int optional--
or the newer syntax
dtml-sqlvar MRSEQS.PAR_FLIPANGLE type=int optional
Ralph


--
Ralph Heinkel  Cenix Bioscience GmbH
Director of the IT-UnitTel  : +49 6221/387 915
Meyerhofstr. 1 Fax  : +49 6221/387 971
69117 Heidelberg, Germany  eMail: [EMAIL PROTECTED]

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




[Zope] howto force rendering of a dtml doc

2000-09-19 Thread Ralph Heinkel

Hi,

having a structure like
FolderA
  DocA
FolderB
 DocB

I try to display DocA from within DocB using

dtml-var "FolderA.DocA"

which basically works, except that HTML code from DocA is not rendered but
printed as plain ascii (e.g. I can see the br statements as these 4
characters).
Is there a way to force rendering?

Thanks,

Ralph


 -- 
------
Ralph Heinkel
MPI-CBG, Group Echeverri
Meyerhofstr. 1
69012 Heidelberg
Tel. 06221/387 915
Fax. 06221/387 971
eMail: [EMAIL PROTECTED]

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )