[Zope-dev] Re: [Zope] IBM DB2/CLI Database Adapter

2002-02-15 Thread Matthew T. Kromer

[Removed extra Zope list CC]

Robin, if you haven't already been directed towards mxODBC, I suggest you
give that a try.


- Original Message -
From: Robin Smidsrod [EMAIL PROTECTED]
To: Zope User List [EMAIL PROTECTED]
Cc: [EMAIL PROTECTED]
Sent: Wednesday, February 13, 2002 10:31 AM
Subject: [Zope] IBM DB2/CLI Database Adapter


 Anybody know about the current status of this DA?

 I'm currently locked into using Perl ZDBI_DA to get access
 to a DB2 datasource. I've had some problems
 with connections being reset and the DBI_DA lacks a table browser.

 Any information would be appreciated.

 -- Robin


 ___
 Zope maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope-dev )



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] Error : exceptions.SystemExit

2002-02-15 Thread Pascal Samuzeau

Hi,   
  
I've got this error when I shutdown my Zope : 
  
  PAn error was encountered while publishing this resource. 
  /P
  PSTRONGexceptions.SystemExit/STRONG/P   
  
  Zope has exited normally.p
!--  
Traceback (innermost last):   
  File
/src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,   
line 223, in publish_module   
  File
/src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,   
line 187, in publish  
  File
/src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,   
line 171, in publish  
  File
/src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/mapply.py,
line 160, in mapply   
(Object: manage_shutdown) 
  File
/src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,   
line 112, in call_object  
(Object: manage_shutdown) 
  File
/src/Zope-2.4.1-solaris-2.6-sparc/lib/python/App/ApplicationManager.py
, line 411, in manage_shutdown
(Object: LockableItem)
SystemExit: 0 
  
--   
  
My Zope version is :  
Zope 2.4.1 (binary release, python 2.1, solaris-2.6-sparc), python
2.1.0, sunos5)
My Python Version  2.1 (#2, Jun 22 2001, 11:02:37) [GCC 2.8.1] .  
  
Any idea ?
  
Sincerily 
PS
--
Oreka ! Nous sommes l'internet moins cher !   
Surfez 25% moins cher avec http://www.oreka.com   

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] Error : exceptions.SystemExit

2002-02-15 Thread Jens Vagelpohl

it says zope has exited normally. i think that's a pretty clear 
explanation of what happened (meaning this error is completely benign).

jens


On Friday, February 15, 2002, at 09:30 , Pascal Samuzeau wrote:

 Hi,

 I've got this error when I shutdown my Zope :

   PAn error was encountered while publishing this resource.
   /P
   PSTRONGexceptions.SystemExit/STRONG/P

   Zope has exited normally.p
 !--
 Traceback (innermost last):
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 223, in publish_module
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 187, in publish
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 171, in publish
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/mapply.py,
 line 160, in mapply
 (Object: manage_shutdown)
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 112, in call_object
 (Object: manage_shutdown)
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/App/ApplicationManager.py
 , line 411, in manage_shutdown
 (Object: LockableItem)
 SystemExit: 0

 --

 My Zope version is :
 Zope 2.4.1 (binary release, python 2.1, solaris-2.6-sparc), python
 2.1.0, sunos5)
 My Python Version  2.1 (#2, Jun 22 2001, 11:02:37) [GCC 2.8.1] .

 Any idea ?

 Sincerily
 PS
 --
 Oreka ! Nous sommes l'internet moins cher !
 Surfez 25% moins cher avec http://www.oreka.com

 ___
 Zope-Dev maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope )


___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] Re: [Zope] IBM DB2/CLI Database Adapter

2002-02-15 Thread Robin Smidsrod

On Fri, 15 Feb 2002, Matthew T. Kromer wrote:

 Robin, if you haven't already been directed towards mxODBC, I suggest you
 give that a try.

Hmmm. The ZmxODBC DA is available in binary form for Win32. And SQLRelay
won't compile due to some weird libxml2 build problem...

 - Original Message -
 From: Robin Smidsrod [EMAIL PROTECTED]
 To: Zope User List [EMAIL PROTECTED]
 Cc: [EMAIL PROTECTED]
 Sent: Wednesday, February 13, 2002 10:31 AM
 Subject: [Zope] IBM DB2/CLI Database Adapter
 
 
  Anybody know about the current status of this DA?
 
  I'm currently locked into using Perl ZDBI_DA to get access
  to a DB2 datasource. I've had some problems
  with connections being reset and the DBI_DA lacks a table browser.


___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] Error : exceptions.SystemExit

2002-02-15 Thread buelent aldemir

everything is allright!

with -D you have started zope in debug-mode

python /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/z2.py -D

read the z2.py file, there you can find more switches to run
zope

if you run zope without the -D parameter, you will not get any
detailled debugging info

hope this helps
ba

 -Ursprüngliche Nachricht-
 Von: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]Im Auftrag
 von Pascal Samuzeau
 Gesendet: Freitag, 15. Februar 2002 15:31
 An: [EMAIL PROTECTED]
 Betreff: [Zope-dev] Error : exceptions.SystemExit


 Hi,

 I've got this error when I shutdown my Zope :

   PAn error was encountered while publishing this resource.
   /P
   PSTRONGexceptions.SystemExit/STRONG/P

   Zope has exited normally.p
 !--
 Traceback (innermost last):
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 223, in publish_module
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 187, in publish
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 171, in publish
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/mapply.py,
 line 160, in mapply
 (Object: manage_shutdown)
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/ZPublisher/Publish.py,
 line 112, in call_object
 (Object: manage_shutdown)
   File
 /src/Zope-2.4.1-solaris-2.6-sparc/lib/python/App/ApplicationManager.py
 , line 411, in manage_shutdown
 (Object: LockableItem)
 SystemExit: 0

 --

 My Zope version is :
 Zope 2.4.1 (binary release, python 2.1, solaris-2.6-sparc), python
 2.1.0, sunos5)
 My Python Version  2.1 (#2, Jun 22 2001, 11:02:37) [GCC 2.8.1] .

 Any idea ?

 Sincerily
 PS
 --
 Oreka ! Nous sommes l'internet moins cher !
 Surfez 25% moins cher avec http://www.oreka.com

 ___
 Zope-Dev maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope )



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )




[Zope-dev] Webdav conformance testing with litmus

2002-02-15 Thread Stefane Fermigier

Hi,

just came across the litmus WebDAV compliance testing tool on
www.webdav.org, and ran it on zope 2.5.0. Here's the result:

- running `basic':
 0. init.. pass
 1. begin. pass
 2. options... pass
 3. put_get... pass
 4. mkcol_over_plain.. pass
 5. delete pass
 6. delete_null... pass
 7. mkcol. pass
 8. mkcol_again... pass
 9. delete_coll... pass
10. mkcol_no_parent... pass
11. mkcol_with_body... pass
12. finish pass
- summary for `basic': of 13 tests run: 13 passed, 0 failed. 100.0%
- running `copymove':
 0. init.. pass
 1. begin. pass
 2. copy_init. pass
 3. copy_simple... pass
 4. copy_overwrite pass
 5. copy_cleanup.. pass
 6. copy_coll. pass
 7. move.. pass
 8. move_coll. pass
 9. move_cleanup.. pass
10. finish pass
- summary for `copymove': of 11 tests run: 11 passed, 0 failed. 100.0%
- running `props':
 0. init.. pass
 1. begin. pass
 2. propfind_invalid.. pass
 3. propfind_invalid2. pass
 4. propfind_d0... pass
 5. propinit.. pass
 6. propset... pass
 7. propget... pass
 8. propmove.. pass
 9. propget... pass
10. propdeletes... pass
11. propget... pass
12. propreplace... FAIL (line 349: HTTP error:
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found)
13. propget... FAIL (Property {http://webdav.org/neon/litmus/}prop9 had 
value value9, expected newvalue9)
14. propnullns pass
15. propget... FAIL (No value given for property {}nonamespace)
16. propinit.. pass
17. propmanyns pass
18. propget... pass
19. propcleanup... pass
20. finish pass
- summary for `props': of 21 tests run: 18 passed, 3 failed. 85.7%

Hope that helps someone. (I'm trying to debug a problem with Zope,
WebDAV and DreamWeaver, and I was glad that this tool was available to
check that most of litmus' fonctional tests pass).

  S.

-- 
Stéfane Fermigier, Tel: +33 (0)6 63 04 12 77 (mobile).
http://nuxeo.com/  http://portalux.com/  http://aful.org/

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] Webdav conformance testing with litmus

2002-02-15 Thread Andreas Jung

Looks good. The last time I run the test, the testing
tool crashed all the time :)

- aj
- Original Message -
From: Stefane Fermigier [EMAIL PROTECTED]
To: [EMAIL PROTECTED]
Sent: Friday, February 15, 2002 13:02
Subject: [Zope-dev] Webdav conformance testing with litmus


Hi,

just came across the litmus WebDAV compliance testing tool on
www.webdav.org, and ran it on zope 2.5.0. Here's the result:

- running `basic':
 0. init.. pass
 1. begin. pass
 2. options... pass
 3. put_get... pass
 4. mkcol_over_plain.. pass
 5. delete pass
 6. delete_null... pass
 7. mkcol. pass
 8. mkcol_again... pass
 9. delete_coll... pass
10. mkcol_no_parent... pass
11. mkcol_with_body... pass
12. finish pass
- summary for `basic': of 13 tests run: 13 passed, 0 failed. 100.0%
- running `copymove':
 0. init.. pass
 1. begin. pass
 2. copy_init. pass
 3. copy_simple... pass
 4. copy_overwrite pass
 5. copy_cleanup.. pass
 6. copy_coll. pass
 7. move.. pass
 8. move_coll. pass
 9. move_cleanup.. pass
10. finish pass
- summary for `copymove': of 11 tests run: 11 passed, 0 failed. 100.0%
- running `props':
 0. init.. pass
 1. begin. pass
 2. propfind_invalid.. pass
 3. propfind_invalid2. pass
 4. propfind_d0... pass
 5. propinit.. pass
 6. propset... pass
 7. propget... pass
 8. propmove.. pass
 9. propget... pass
10. propdeletes... pass
11. propget... pass
12. propreplace... FAIL (line 349: HTTP error:
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found
http%3A//192.168.2.12%3A8081/litmus/prop2: HTTP/1.1 404 Not Found)
13. propget... FAIL (Property
{http://webdav.org/neon/litmus/}prop9 had value value9, expected newvalue9)
14. propnullns pass
15. propget... FAIL (No value given for property {}nonamespace)
16. propinit.. pass
17. propmanyns pass
18. propget... pass
19. propcleanup... pass
20. finish pass
- summary for `props': of 21 tests run: 18 passed, 3 failed. 85.7%

Hope that helps someone. (I'm trying to debug a problem with Zope,
WebDAV and DreamWeaver, and I was glad that this tool was available to
check that most of litmus' fonctional tests pass).

  S.

--
Stéfane Fermigier, Tel: +33 (0)6 63 04 12 77 (mobile).
http://nuxeo.com/  http://portalux.com/  http://aful.org/

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] Zope 2.4.4b1 dumps core

2002-02-15 Thread Dieter Maurer

Jeremy Hylton writes:
  ... memory corruption ...
  Does the community have any Zen about how to narrow down bugs like
  this?
I once used purify to analyse this type of problem.

I was not easy: purify slowed Zope down by one to two
magnitudes. It has been only feasible because the mean time
between two crashes have been only a few minutes (which turned
into some half hours when run under purify).


Dieter

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )