Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-24 Thread Dieter Maurer
robert wrote at 2003-11-24 05:32 +0100: ... Traceback (innermost last): * Module ZPublisher.Publish, line 100, in publish * Module ZPublisher.mapply, line 88, in mapply * Module ZPublisher.Publish, line 40, in call_object * Module

Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-23 Thread Marc Lindahl
Probably you're trying to index non-CMF non-plone objects - you can get a similar error with plain CMF if you have non-CMF objects that you try to index. I think what you have to do is clear the catalog and then use the 'find objects' page to reindex, only select the object types which are

Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-23 Thread robert
Thanks for your answer, The error happens with a plain CMF site freshly installed. So there are no unruly objects to reindex. Robert Am Sonntag, 23. November 2003 19:04 schrieb Marc Lindahl: Probably you're trying to index non-CMF non-plone objects - you can get a similar error with plain CMF if

[Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-19 Thread robert
If I try to reindex a (plone) portal_catalog I get the following error Traceback (innermost last): * Module ZPublisher.Publish, line 100, in publish * Module ZPublisher.mapply, line 88, in mapply * Module ZPublisher.Publish, line 40, in call_object * Module

Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-19 Thread Andreas Jung
I can not reproduce this. Can you give us detailed description how to reproduce it or track it down on your own? -aj --On Mittwoch, 19. November 2003 17:15 Uhr +0100 robert [EMAIL PROTECTED] wrote: If I try to reindex a (plone) portal_catalog I get the following error Traceback (innermost

Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-19 Thread Casey Duncan
On Wed, 19 Nov 2003 17:15:13 +0100 robert [EMAIL PROTECTED] wrote: If I try to reindex a (plone) portal_catalog I get the following error Traceback (innermost last): * Module ZPublisher.Publish, line 100, in publish * Module ZPublisher.mapply, line 88, in mapply * Module

Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-19 Thread robert
I did not track it down really, but fixed it by removing the update_metadata argument in ZCatalog.py on line 459. What I did is creating a Plone Site, and then went to portal_catalog.indexes and reindexed all indices. I am at home now, where I do not have 2.7 installed. Robert Am Mittwoch,

Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-19 Thread robert
I am using 2.7 from cvs robert Am Mittwoch, 19. November 2003 17:56 schrieb Casey Duncan: On Wed, 19 Nov 2003 17:15:13 +0100 robert [EMAIL PROTECTED] wrote: If I try to reindex a (plone) portal_catalog I get the following error Traceback (innermost last): * Module

Re: [Zope-dev] Zope 2.7 b3 problem with reindexing catalog

2003-11-19 Thread robert
I did some more investigation: The problem does occur when a CMF portal_catalog is reindexed. It does not happen with plain catalog Robert Am Mittwoch, 19. November 2003 17:40 schrieb Andreas Jung: I can not reproduce this. Can you give us detailed description how to reproduce it or track it