On Fri, 28 Feb 2025 21:30:14 GMT, Sean Mullan <mul...@openjdk.org> wrote:
>> Ok, so I don't like "Security-Related System Property" because you would not >> need a title like that for one property. The overall intent of this document >> is to use it as a place to document more system properties, but if we have >> no immediate plans to do that within the JDK 25 timeframe, then maybe a more >> specific title like what Weijun is suggesting is more appropriate. >> >> There are many other security related system properties which are worth >> documenting but more of them are in the TLS and Kerberos areas, which are in >> different packages or modules. I'm not sure if we need different html pages >> for each of those areas. I was really hoping we would have one page for all >> security library areas. >> >> Let me think about this more first. > > Ok, so for now, since we are only documenting one property I think it makes > sense (as Weijun suggested) to change the title of this to "The > java.security.debug system property". Remove the paragraph starting with > "There are several system properties ..." > > As a followup, let's open another issue to add the JSSE system properties to > this file, and then it can become more of what was originally intended. So > think of this as a temporary title. Updated. Created new bug to track that [JDK-8350979](https://bugs.openjdk.org/browse/JDK-8350979) ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/23569#discussion_r1976167401