Tung TRAN commented on JAMES-3969:

I just tried to run the maven build on James-project-3.8.0 zip file, 
and the build was successful for me. ( even when I attempted to delete all 
repositories in the .m2 directory before initiating the build)

My environment:
Apache Maven 3.9.5 (57804ffe001d7215b5e7bcb531cf83df38f93546) 
Maven home: /home/tungtv/tool_install/apache-maven-3.9.5 
Java version: 11.0.21, vendor: Eclipse Adoptium, runtime: 
Default locale: en_US, platform encoding: UTF-8 
OS name: "linux", version: "6.5.0-14-generic", arch: "amd64", family: "unix"

Can you check if the dependency `scala-maven-plugin:4.6.1` is exists in .m2? 
Maybe some issue can not download it?

> Compilation issue for James 3.8.0 related to scala-maven-plugin
> ---------------------------------------------------------------
>                 Key: JAMES-3969
>                 URL: https://issues.apache.org/jira/browse/JAMES-3969
>             Project: James Server
>          Issue Type: Bug
>          Components: James Core
>    Affects Versions: 3.8.0
>         Environment: Development
>            Reporter: Sachin Nilajkar
>            Priority: Blocker
> We are compiling the James source file - 
> [james-project-3.8.0-source-release.zip|https://www.apache.org/dyn/closer.lua/james/server/3.8.0/james-project-3.8.0-source-release.zip]
>  but compilation getting failed with error as - 
> [ERROR]: Failed to execute goal 
> alchim31.maven:scala-maven-plugin:4.6.1:compile (scala-compile-first) on 
> project apache-james-backend-pulsar
> which is the correct version of "scala-maven-plugin" to be use for this 
> compilation?
> We are using Java 11 and
> tried various versions of Maven such as 3.6.0 till 3.9.6 but still getting 
> error so kindly help to provide correct version of "scala-maven-plugin" to be 
> use for this compilation.

This message was sent by Atlassian Jira

To unsubscribe, e-mail: server-dev-unsubscr...@james.apache.org
For additional commands, e-mail: server-dev-h...@james.apache.org

Reply via email to