On Tue, 19 Nov 2024 19:54:45 GMT, William Kemper <wkem...@openjdk.org> wrote:
>> src/hotspot/share/gc/shenandoah/shenandoahHeap.inline.hpp line 276: >> >>> 274: log_info(gc)("GC cancellation took %.3fs", cancel_time); >>> 275: _cancel_requested_time = 0; >>> 276: } >> >> Do we need this? Is this useful? > > We could log this at debug? I believe it is useful because this time > (currently) is not accounted for in the heuristic's notion of 'cycle time'. Yeah, `gc=debug` would be okay for this. >> src/hotspot/share/gc/shenandoah/shenandoahPhaseTimings.cpp line 193: >> >>> 191: Phase phase = Phase(pi); >>> 192: if (is_worker_phase(phase)) { >>> 193: double sum = uninitialized(); >> >> I think you can avoid changing this method to limit the churn. > > Hmm, I find the version in the PR much more readable. How about we upstream > these changes separately? Yes, let's do that, if you have cycles. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/21273#discussion_r1852533117 PR Review Comment: https://git.openjdk.org/jdk/pull/21273#discussion_r1852533548