On Thu, 16 Jan 2025 16:48:02 GMT, Coleen Phillimore <cole...@openjdk.org> wrote:
> Please review this change to replace SIZE_FORMAT with %zu in the runtime > code. The second and third commits are hand editing for fixing up formats of > the code, not the output. After this, there'll be a separate change to > remove SIZE_FORMAT. Note that SIZE_FORMAT_X_0 depends on LP64 so that macro > will be retained. There were a couple of compiler files that I missed. > Tested with tier1-4. This makes code more readable. Looks good. I've not checked the copyright years. src/hotspot/share/oops/array.hpp line 77: > 75: > 76: size_t elements = left / sizeof(T); > 77: assert(elements <= (size_t)INT_MAX, "number of elements %zudoesn't > fit into an int.", elements); Nit: It seems that a space is needed after `%zu`. This was this way originally. ------------- Marked as reviewed by sspitsyn (Reviewer). PR Review: https://git.openjdk.org/jdk/pull/23160#pullrequestreview-2557917156 PR Review Comment: https://git.openjdk.org/jdk/pull/23160#discussion_r1919521203