On Fri, 25 Apr 2025 15:17:17 GMT, Aleksey Shipilev <sh...@openjdk.org> wrote:
> I noticed in `macros.hpp`: > > > #ifdef ASSERT > #define DEBUG_ONLY(code) code > #define NOT_DEBUG(code) > #define NOT_DEBUG_RETURN /*next token must be ;*/ > // Historical. > #define debug_only(code) code > #else // ASSERT > > > There are 350+ instances of `debug_only`, and 1600+ instances of > `DEBUG_ONLY`. We can cleanup `debug_only` and rewrite all uses to > `DEBUG_ONLY`. > > I think we can do this in one shot. This was a mechanical rename. I have > looked through the `grep -R debug_only src/ | nl`, and there are no hits > anymore. > > Additional testing: > - [x] GHA Thanks for reviews! I re-merged with current master locally. There were no conflicts, and no backsliding of `debug_only` either. Light testing (`hotspot:tier1`) still passes. So I think we are good to go. Here goes: ------------- PR Comment: https://git.openjdk.org/jdk/pull/24879#issuecomment-2834467628