On Thu, 16 Jul 2026 15:15:17 GMT, Chris Plummer <[email protected]> wrote:
> It looks like `objectCountMax` could be replaced with `objectTagCount` since > once `objectCountMax` is set `objectTagCount` doesn't change. Is that > correct? I'm not saying it should be replaced. Assigning to `objectCountMax` > probably makes the code easier to read, but I just want to make sure I'm > understanding it correctly. However, an assert that they are still equal > after the 2nd `IterateOverReachableObjects` call might be a good idea. Thanks. Added the check. ------------- PR Comment: https://git.openjdk.org/jdk/pull/31585#issuecomment-5041739161
