On Fri, 26 Jun 2026 10:16:54 GMT, Thomas Schatzl <[email protected]> wrote:

>> Ivan Walulya has updated the pull request incrementally with one additional 
>> commit since the last revision:
>> 
>>   StefanK review
>
> src/hotspot/share/gc/g1/g1HeapRegionSet.cpp line 253:
> 
>> 251: 
>> 252:   verify_optional();
>> 253:   DEBUG_ONLY(uint old_length = num_regions();)
> 
> old_length -> num_old_regions?

We still maintain `G1FreeRegionList` as a list, so some uses of “length” 
remain. They can be renamed once `G1FreeRegionList` no longer exposes its 
implementation details through its name.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/31688#discussion_r3727863757

Reply via email to