This is a part of [JDK-8382392](https://bugs.openjdk.org/browse/JDK-8382392).
"eh_frame" is a key to unwind native frames, so SA uses "eh_frame" in as a type name and a field name. Before to work for `.debug_frame`, we need to rename it to `frame` because "eh_frame" is no longer an only representation of frame information. And also this ticket would remove `library_base_addr` from `eh_frame` (`frame` after renaming) because we can get library base address from `base`. --------- - [x] I confirm that I make this contribution in accordance with the [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai). ------------- Commit messages: - 8390620: Refactor eh_frame to frame in libsaproc Changes: https://git.openjdk.org/jdk/pull/32436/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=32436&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8390620 Stats: 18 lines in 4 files changed: 0 ins; 2 del; 16 mod Patch: https://git.openjdk.org/jdk/pull/32436.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/32436/head:pull/32436 PR: https://git.openjdk.org/jdk/pull/32436
