On Wed, 19 Aug 2026 05:41:21 GMT, Yasumasa Suenaga <[email protected]> wrote:

> This is a part of [JDK-8382392](https://bugs.openjdk.org/browse/JDK-8382392).
> 
> "eh_frame" is a key to unwind native frames, so SA uses "eh_frame" in as a 
> type name and a field name. Before to work for `.debug_frame`, we need to 
> rename it to `frame` because "eh_frame" is no longer an only representation 
> of frame information.
> 
> And also this ticket would remove `library_base_addr` from `eh_frame` 
> (`frame` after renaming) because we can get library base address from `base`.
> 
> ---------
> - [x] I confirm that I make this contribution in accordance with the [OpenJDK 
> Interim AI Policy](https://openjdk.org/legal/ai).

This pull request has now been integrated.

Changeset: 9633dd75
Author:    Yasumasa Suenaga <[email protected]>
URL:       
https://git.openjdk.org/jdk/commit/9633dd75fee4b828e27ec8b4ea0ae8405698c4ef
Stats:     18 lines in 4 files changed: 0 ins; 2 del; 16 mod

8390620: Refactor eh_frame to frame in libsaproc

Reviewed-by: cjplummer, sspitsyn

-------------

PR: https://git.openjdk.org/jdk/pull/32436

Reply via email to