> The fields declaring layout support for value classes are duplicated across > the FieldLayoutBuilder, InlineKlass, and ClassFileParser. I suggest that we > move all of these into a new class, called AvailableLayouts. > > This rids us of many duplicated lines of code, and makes keeping the names > consistent easier (today, they are not consistent). > > For the design of `AvailableLayouts`, I decided on putting the size fields > into an array which is indexed by casting `LayoutKind` into an `int`. This > saves us code bloat, both in the repo, and also in our binaries. When I've > looked at the generated code for the inlined callsites of > `InlineKlass::layout_size_in_bytes`, the switch is compiled down into table > dispatch. Now, we can just have it be a load from an object offset. This > ought to be faster as well, as no prediction needs to take place. > > There's a lot of added `const` stuff in this PR as well, as issues with > const-correctness came up during the refactoring. > > --------- > - [X] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai).
Johan Sjölen has updated the pull request incrementally with one additional commit since the last revision: Rework ------------- Changes: - all: https://git.openjdk.org/jdk/pull/32276/files - new: https://git.openjdk.org/jdk/pull/32276/files/9b6dd1ef..e2f9016c Webrevs: - full: https://webrevs.openjdk.org/?repo=jdk&pr=32276&range=01 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=32276&range=00-01 Stats: 208 lines in 28 files changed: 27 ins; 53 del; 128 mod Patch: https://git.openjdk.org/jdk/pull/32276.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/32276/head:pull/32276 PR: https://git.openjdk.org/jdk/pull/32276
