On Fri, 11 Sep 2026 07:30:51 GMT, Stefan Karlsson <[email protected]> wrote:

>> [JDK-8391728](https://bugs.openjdk.org/browse/JDK-8391728) replaced the word 
>> inline with value for value objects and types. That change deferred the 
>> update of names using the word "inlined", because it should likely be named 
>> "flattened", and I wanted that part to be easier to review.
>> 
>> Note:
>> * The second summary of the CDS test needs to verified that it says the 
>> correct thing
>> * I wasn't sure about what to do with 
>> test/hotspot/jtreg/runtime/cds/appcds/test-classes/WithInlinedField.java. Is 
>> it meant to be named WithValueField.java, WithFlattenableField.java, or 
>> WithFlattenedField.java. I left it untouched.
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Stefan Karlsson has updated the pull request with a new target base due to a 
> merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains five additional 
> commits since the last revision:
> 
>  - Merge remote-tracking branch 'upstream/master' into 
> 8391951_rename_inlined_fields
>  - Merge remote-tracking branch 'upstream/master' into 
> 8391951_rename_inlined_fields
>  - Merge remote-tracking branch 'upstream/master' into 
> 8391951_rename_inlined_fields
>  - Rename flattened to flat
>  - 8391951: Rename inlined fields to flattened fields

LGTM

-------------

Marked as reviewed by iklam (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/32756#pullrequestreview-5180551493

Reply via email to