> We are reworking some code around value field layouts and creating a class 
> named `ValueFieldLayout`. To lower the risk of misunderstanding I propose 
> that we rename `ValueFieldLayoutInfo` to `ValueFieldInfo`.
> 
> ---------
> - [x] I confirm that I make this contribution in accordance with the [OpenJDK 
> Interim AI Policy](https://openjdk.org/legal/ai).

Stefan Karlsson has updated the pull request with a new target base due to a 
merge or a rebase. The pull request now contains nine commits:

 - Merge remote-tracking branch 'upstream/master' into valhalla_rename_vfli
 - Merge branch 'valhalla_remove_cached_null_marker_offset' into 
valhalla_rename_vfli
 - Merge remote-tracking branch 'upstream/pr/33177' into 
valhalla_remove_cached_null_marker_offset
 - Create [copy_]size_in_bytes helpers on ValuePayload
 - Remove copy_layout_kind parameter
 - Simplify Read
 - 8393451: ValuePayload copy and null marker simplifications and cleanups
 - Rename ValueFieldLayoutInfo to ValueFieldInfo
 - Remove cached null marker offset from ValueFieldLayoutInfo

-------------

Changes: https://git.openjdk.org/jdk/pull/33179/files
  Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=33179&range=02
  Stats: 363 lines in 46 files changed: 68 ins; 68 del; 227 mod
  Patch: https://git.openjdk.org/jdk/pull/33179.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/33179/head:pull/33179

PR: https://git.openjdk.org/jdk/pull/33179

Reply via email to