Dear Reza,

my guess is, that the fortran compiler does not get to know that the
parallel versiion is requested. You might try the following change
in your arch.make:

.F.o:
$(FC) -c $(FFLAGS) $(INCFLAGS) $(FPPFLAGS) $(FPPFLAGS_fixed_F) $(DEFS_MPI) $<
.F90.o:
$(FC) -c $(FFLAGS) $(INCFLAGS) $(FPPFLAGS) $(FPPFLAGS_free_F90) $(DEFS_MPI) $<
.f.o:
   $(FC) -c $(FFLAGS) $(INCFLAGS) $(FCFLAGS_fixed_f)  $<
.f90.o:
   $(FC) -c $(FFLAGS) $(INCFLAGS) $(FCFLAGS_free_f90)  $<

An alternative could be to add -DMPI to the FPPFLAGS. I hope this helps.

Best regards,

Hauke Paulsen



Reza Kalantari schrieb:
Dear all friends

Hi,
I try to compile parallel version of siesta according to Dr. S├ębastien Le 
Roux's  guide which I found on the web. I guess that I pass all steps of this 
instruction correctlly but finally my siesta is serial version when I run. I 
use Open suse 10.3, Openmpi and my fortran compiler is gfortran. I attached 
arch.make  file which I use in compiling. After making of this file at the 
first I go to the siesta/src/mpi and run make command and then come back to the 
src folder and run make agian. There is not any error in during of complie but 
the executable siesta file is serial. I run it with following command:
mpirun -np 2 siesta < input.fdf > output
Would you please let me know what can I do?
Best Regrads
Reza Kalantari-Nezhad PhD. Student AmirKabir University of Technology

begin:vcard
fn:Hauke Paulsen
n:Paulsen;Hauke
org;quoted-printable;quoted-printable:Universit=C3=A4t zu L=C3=BCbeck;Institut f=C3=BCr Physik
adr;quoted-printable:;;Ratzeburger Allee 160;L=C3=BCbeck;;D-23538;Germany
email;internet:paul...@physik.uni-luebeck.de
title:Privatdozent Dr.
tel;work:++49 451 500 4208
tel;fax:++49 451 500 4214
url:www.physik.uni-luebeck.de
version:2.1
end:vcard

Reply via email to