Hi Tommy,

I just tried this in US-EAST-1 with….

triton create debian-8 g4-general-8G

Then….

    1  sudo apt-get install curl openssh-server ca-certificates postfix
    2  curl -sS https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash
    3  sudo apt-get install gitlab-ce
    4  sudo gitlab-ctl reconfigure
    5  ifconfig
    6  exit

And I’m able to log in just fine. When I get some time I’ll try with less memory and see if I can recreate the error - but in the interim you may want to retry with a bigger package and see if that fixes things?

Jay

tom my wrote:

Hey all,
just a try.

I installed Gitlab on LX zone (tested centos, ubuntu, debian) using Gitlab's recommended Omnibus installation. 
I configured lx-zone with 4GB memory.
Installation went ok, however I can't access Gitlab's web, receiving error "Cannot allocate memory - fork(2) (Errno::ENOMEM)" even all system uses only just under 1G.

My guess is that some part of Gitlab checks available memory "in no standard" place.

Is there any chance that somebody of you tried / experienced the same?
Any idea what / how can I debug?

Under KVM is everything ok.

thanks.

Tommy

Reply via email to