Thanks for the tip Jason.  I didn't see the -j option there or here

I'll keep this short, i tried to add it to the init.d script and then
interacting directly with the solr binary, but ultimately saw that
logs/solr-console-8983.log was updated with an exception saying dependency
not met.

It looks like only /opt/solr/server/lib/jetty-http-9.3.20.v20170531.jar is

So i guess at this point i have one question that i don't think i'd go
through with b/c i'd like to keep the application install clean, But for
curiosity will solr pick up any jar in the lib directory and then i could
pass -j --module=http2, perhaps or define if where module=http is defined,
but that may just be passed at start i'd assume.

Otherwise i may just put nginx in front of the master admin, which has A
LOT of other security around it, b/c i am trying to access it from outside
my VPC.

Thanks again!

On Fri, Feb 23, 2018 at 1:53 PM, Jason Gerlowski <>

> Hi Jeff,
> I haven't tested your exact use case regarding H/2, but the "bin/solr"
> startup script has a special "-j" options that can be used to pass
> arbitrary flags to the underlying Jetty server.  If you have options
> that work with vanilla Jetty, they _should_ work when passed through
> the "bin/solr" interface as well.  Check out "bin/solr start -help"
> for more info.
> If it doesn't work out, please let us know, and post the commands you
> tried, output, etc.
> Best,
> Jason
> On Fri, Feb 23, 2018 at 11:56 AM, Jeff Dyke <> wrote:
> > Hi, I've been googling around for a while and can't seem to find an
> answer
> > to this.  Is it possible to have the embedded jetty listen to H/2 as well
> > has HTTP/1.1, mainly i'd like to use this to access it on a private
> subnet
> > on AWS through HAProxy which is set up to prefer H/2.
> >
> > With base jetty its as simple as passing arguments to start.jar, but
> can't
> > find how to solve it with solr and the embedded jetty.
> >
> > Thanks,
> > Jeff

Reply via email to