Date:        Wed, 1 Apr 2020 11:45:53 +0000
    From:        "Kamil Rytarowski" <>
    Message-ID:  <>

  | Log Message:
  | Avoid comparison between signed and unsigned integer
  | Cast PAGE_SIZE to size_t.

This kind of pedantry is going way too far, PAGE_SIZE is a compile
time constant (1 << PAGE_SHIFT) which is an int (and so signed,
nominally) but one which is known to be positive.

What is to be next?  Given an unsigned var (any unsigned type) 'u'
are we going to be required to write

        if (u != 0U)
        if (u != (unsigned)0)

instead of just
        if (u != 0)

Get rid of the cast, it isn't needed in this case,
and anything that believes it is, is wrong (broken).


Reply via email to